SmartThings Community

Mode options being randomly ignored


(Richard) #1

For the last few days all of the routines on my v2 Hub have been randomly triggering in the wrong Mode. Is anyone else seeing this issue?

I use “Smart Lighting”, “Notify Me When” and custom rules in “Smart Home Monitor”. All use the “Set for specific mode(s)” or “Only when mode is” options to trigger only when Mode is set to Away and/or Night. These have all been working perfectly, but since a few days ago all of them have been randomly triggering when Mode is set to Home.

So for example when Mode is Away I receive a SMS if motion is detected in my hall, but I am now getting notified of motion in my hall when Mode is set to Home. I’ve had to disable the rule that triggers my external siren because that is also now being triggered randomly when I am at home, despite the rule set to only trigger when Mode is set to Away or Night.

I have raised support requests via Support@smartthings.co.uk, @smartthings tweet, and a direct message to @smartthings, and am awaiting a response.

Just to confirm again, everything was working perfectly, and now it’s not, and I’ve not changed anything.

Can anyone help please?

Many thanks,
Richard


Goodbye I'm back Routines
Anyone else in UK having issues today? AWAY notifications/actions when Disarmed
Issue: SmartApps not recognizing mode specific execution anymore
Hub Firmware Release Notes - 19.19
Notify me when - mode problem
MODE conditions not working
[RELEASE] NST Manager v5.0
Notify me when, false alerts
Speaker companion ignoring Mode setting
Lost control of my Castle! Help!
Hub Firmware Release Notes - 19.19
(Andy - United Kingdom) #2

I seem to have the same problem…

Apps that shouldn’t run in a mode still do…
Nothing on SmartThings platform status pages though

Also logged a ticket with smartthings support


(Jason Crosier) #3

Me too I have Lights firing up whilst location mode is in night even though the attributes are set not to. The pistons have worked correctly for months until a fews days ago I’ve created a pause Pistons routine to sort it for now but would love a proper fix. It’s driving me Nutts!


(Richard) #4

Thanks @Cobra and @jasoncrosier, sorry to hear but also glad to know it’s not just me!

Ellen from Support has since replied to my direct message on Twitter and I’ve let her know other people in the SmartThings community have confirmed they’re seeing the same issue so hopefully this will help them find a solution as quickly as possible for us all.

I’ll keep you posted when I hear anything else. At the moment I’ve just given them some examples of dates and times when specific rules incorrectly triggered so they can check my logs.


#5

Please fix this!

I’m very glad I’m not the only one. It seems since a few days ago, rules that are conditional on mode are not using the correct value. Sometimes they work, sometimes not. For example, my landing light is a dim red in night mode, but bright white otherwise. When I walked passed the sensor it turned on full brightness in the middle of the night, but when I walked back a couple of minutes later it went dim red. Seems random what mode it is using.

Thanks.


(Richard) #6

I last heard from Ellen at SmartThings support on Friday night. I assume they only work Monday to Friday so hopefully we’ll get an update today.

In the meantime I’ve continued to troubleshoot this issue myself and may have made some progress. I’ve created three new modes - Home_New, Night_New, and Away_New, and updated my routines to use these instead of the default Home, Night, Away. It’s too early to be absolutely sure of course but in the few hours since I made this change I’ve not had any more routines incorrectly triggering in the wrong mode. Maybe it’s the new modes I’ve created, or maybe it’s just the fact I’ve added a new one which may have “reset” some kind of corruption in the settings, or maybe it’s not fixed at all and I’ll get another incorrect trigger when I get home tonight…

I’ll keep you posted.


(Andy - United Kingdom) #7

Interesting thought.

If this works then I’m happy to delete and recreate my modes.
Please let us know

Andy


(Richard) #8

Will do - fingers crossed! :slight_smile:


(Andy - United Kingdom) #9

Just a quick question…

Is everyone in the UK?
Is it only affecting the eu shard?


(Richard) #10

I’m in the UK but not sure about the other three people who I am aware of so far (jasoncrosier, Charliemouse and @Alec_Howson) - hi guys, are you all in the UK too? Presumably you’re still seeing this issue?

I’m sure this is affecting many others too, for example someone replied to my tweet that they are also seeing the same issue. I wonder how many are suffering in silence without reporting it - perhaps it is affecting all UK users?

@smartthingsST - please can you help?

Many thanks,
Richard


(Alec Howson) #11

yes, I’m in the UK


(Richard) #12

Hi guys,

Ellen has just replied, they are still investigating. I’ll keep you posted.

Thanks,
Richard


(Paul) #13

I’m seeing an issue where my hub is not executing the Good Morning routine as expected at sunrise. Not sure if its related but I it ties in with the dates/times above and I’m UK based.


(Richard) #14

Thanks Paul. Can you confirm if your Good Morning routine also uses the Advanced Option “Don’t automatically do this if I am in one of these modes” as well as the sunrise option? I’ll feed this back to Ellen at support who is Direct Messsging me on Twitter.


(Richard) #15

Hi guys. Unfortunately my experiment with creating new modes detailed above did not resolve the issue after all and I am still seeing routines triggering in the wrong modes.

Ellen from SmartThings Support has replied again this morning and has confirmed their teams are looking into this, and has also brought this community thread to their attention. However she has also asked me to encourage you all to raise support tickets with your specific details if you haven’t already done so, so they have more examples to work with.

There appears to be several ways to request support so this is how I raised my ticket:

  1. Send a general tweet to @smartthings just to let them know you’re experiencing problems with routines triggering in the wrong mode and asking for help - they should reply and follow up with a Direct Message to ask for more details.

  2. Send an email to support@smartthings.co.uk with full details of the issue you are experiencing and include your SmartThings account email address so they can identify your hub and 2 or 3 examples in the following format so they can find them in your logs:

28-Nov-2017 at 07:22
“Smart Home Monitor” custom rule named “Motion Sensors - Alert John” triggered in Home Mode. This should only trigger in Away Mode.

28-Nov-2017 at 07:39
“Notify Me When” SmartApp named “Motion in Garage” triggered in Home Mode. This should only trigger in Away and Night Modes.

  1. When they reply to your Direct Message on Twitter, reply to the message with the same details that you provided on your email.

All my replies and updates from SmartThings support so far have been via Direct Message on Twitter, and as you have seen Ellen has been very helpful.

Here’s hoping for a speedy resolution. I will keep you posted and if you could do the same when you receive any responses that would be great.

Many thanks,
Richard


(Steven) #16

I’ll be opening a support ticket about this as well, but wanted to add that I’ve been having trouble with a webcore piston changing modes. The piston executes properly but the mode never actually changes in SmartThings.


#17

I’ll open a ticket tonight, ours has gone mad today. Getting notifications that are AWAY Armed mode when at home Disarmed. The family came home after school today, did ‘I’m Back’ routine a few min later the DLink Siren (Routine of NOT when in Home/Night) went off when they were in the same room as it. I am not popular with the kids today. Was just singing ST praises to work colleagues today.


(Richard Woodward) #18

UK here and seeing exactly the same issues. Routines that have worked for over 6 months are now pretty much ignoring modes and firing when they shouldn’t. Like others I have made no changes at all so the problem is not us users but something in the cloud.


(Steve White) #19

I’ll add my voice to the cadre of users who’ve seen this happen albeit a bit differently in my instance. Last night the I’m Back routine failed to change the system mode from Away. If not for this thread I would have dismissed it as a random glitch. It seems there may be more to this issue but I am going to put off opening a ticket until I can capture it happening again.


(Richard) #20

I sympathise - for the same reasons my other half is now screaming at me to throw SmartThings in the bin and install a more reliable home security system as it is just causing unnecessary stress and concern over the security of our home.

Thankfully I’m a little more patient so I’m waiting for this to be fixed and hoping the system becomes stable and dependable again.