Issue: SmartApps not recognizing mode specific execution anymore

Hi all,

for the last 2 weeks, I had some trouble with the reliable execution of native as well as my own SmartApps. Everything was working perfectly until then.

I use “Notify me when” when my Fibaro motion sensor detects motion while my home is in “away” mode to push a message via the Smartthings app as well as send a text message. However, recently I started getting these messages while my home is in “home” or “asleep” mode. (Even though I am not always getting the messages in “home” mode, it seems to happen mainly during night hours.)

Similar problem is with a (customized) SmartApp that I have installed via the developer interface: it is supposed to flip a switch (for camera motion detection) if the (virtual) master presence switch is being turned off, which is done via the “Goodbye” automation. The presence switch is changing reliably, but since 2 weeks ago it does not trigger the camera switch anymore. I have tried to set it only for specific modes, for all modes, left the “set for specific mode” empty but it still does not seem to work.

I am pretty sure that it is an issue with the SmartApps in Smartthings, as I am also using SmartRules and can reliably reproduce all rules and actions in SmartRules (with reliable, mode-dependent execution). (Even though SmartRules does not provide all options that I have in the SmartApps, which is why I would like to get this working again.)

I am running a V2 UK hub, and have added three additional modes via the developer interface (Guest, Asleep, Evening).

Anyone experiencing the same issues? Any ideas how to fix it?

Thanks a lot,

1 Like

Thanks a lot for posting the link to this discussion! Good to know that others are experiencing the same issue. Will continue the discussion over there.

1 Like