Mode options being randomly ignored

Quick update - Ellen from SmartThings support contacted me via Twitter Direct Message again today. They are still investigating and still need you all to provide recent examples of routines that have triggered in the wrong modes in a similar format to the following:

28-Nov-2017 at 07:39
“Notify Me When” SmartApp named “Motion in Garage” triggered in Home Mode. This should only trigger in Away and Night Modes.

All my responses so far are following my request for help on Twitter where Ellen has been Direct Mesaging me, but today I also finally received a reply to my email to which I sent 6 days ago. This reply was from Matthew Farrell, Support Technician. I’ve shared with him details of this community thread and the fact the issue is affecting other users not just me, and I’ve also shared with him the conversation transcript that I’ve had with Ellen so far. Hopefully they will both link up to work on this together.

When I hear back from Ellen or Matthew I will provide another update here.

Have raised a ticket via email address in the last 15 mins and had the support auto response. I referenced this community thread. I gave an initial timeline of when everything kicked off for ours today. I’ve edited my siren routine to prevent it going off till this is resolved.

System is unusable in this state.

Yes, my system is pretty much turning the hall light on and off when we walk about, and switching on our Blink cameras when we leave the house. Nothing is relying on Home/Night/Away now as it just doesn’t work.

However I’m still setting the mode to Home/Night/Away and I’ve left some test routines in place to send a SMS only to me when a test motion sensor triggers in the wrong mode so I’m still able to report new examples to support for them to check logs, etc, and I’ll also know when it’s finally fixed.

Here’s hoping our Things become Smart again soon…

I totally understand and feel your frustration when things start breaking. It’s pretty irritating to say the least. But SmartThings v1 or v2 Hub is not a Security system at all. Even though it has functionality within it that mimics and functions somewhat like a security system, it is not and shouldn’t be relied upon for the sole security of your home. It’s a home automation hub and allows for the consolidation and automation of devices that removes the manual intervention of things being done. If Security is the biggest and most important part for your home, I would look at a traditional true security system and compliment that with SmartThings.

Anyway, I do hope they get things resolved for you before the significant other hits you with the hub :slight_smile:

Haha thank you, me too! :slight_smile:

And yes I agree with what you say to a certain extent, however one has to be realistic and appreciate that nobody in their right mind is going to install two contact sensors on their front door, one SmartThings contact sensor to turn the light on when they open the door after work in the evening, and a separate security system contact sensor next to it to alert them when an intruder has broken in. In addition if security is not a focus then SmartThings should not be encouraging people to use it as a home security system by including built-in functions like “Smart Home Monitor” with a whole section entitled “Security” and with options that are clearly targeted at home security usage such as “Alert with Sirens” etc. Again nobody in their right mind is going to have two sirens next to each other, one SmartThings siren to alert them when the kids open the sweets cupboard after 9pm and a separate security system siren next to it to scare a potential intruder off (no I don’t have a siren on my sweets cupboard lol).

Finally I would also say that if SmartThings continue to provide and encourage the use of built in security features mentioned above they really should tighten up their testing and change control processes to a more rigorous level so that the basic functions are protected. It’s also quite frankly dangerous to include dedicated functions for things like “Smoke” if SmartThings are not serious about the platform for that particular use. I realise SmartThings is an open source system and that’s one of the beauties of it but let the third party developers tinker while SmartThings concentrate on providing a rock solid foundation where the basic functions like the one we are all suffering from today work reliably.

Just my own thoughts, but of course this thread isn’t about why we all use SmartThings so I don’t want to take it over with this discussion, I’m sure there’s a separate thread for that somewhere.

Thanks again and here’s hoping for a speedy resolution to this issue. :slight_smile:

+1 here too, from Canada. If I might ask, all this started after a firmware update I didn’t asked for. I feel like a beta tester who didn’t enroll :roll_eyes:

Doesn’t seem related to the firmware update
I was in the beta program for the latest firmware version and didn’t have any issues until recently.
Seems more like ‘backend’ process failure to me.


Good to know.

I my case, modes and pistons (webCoRE) are tied together so I thought recent inconsistencies I had might be related to this.

I have lot of occurrences when everything ran smoothly, except commands (events are logged according to normal operation but the command never reach the hub)

Is there any update to this? My “Speaker Companion” automations have been triggering when in Home mode despite only being configured to execute in Away mode.

I raised a ticket last night and tweeted them to confirm I’d sent it. Had an auto reply to the email last night. Had a response on twitter today to say they will be working to improve the experience as quick as they can.

Have you raised a ticket?

I just found this thread after being redirected by another forum user.
Experiencing the same issues and have emailed and tweeted Smartthings support. No response yet. I am also in the UK and this started happening about 2 weeks ago. I can’t recall if it started after the mobile client update which introduced SCENES.

I am now seriously considering alternatives but am in two minds as I’m heavily invested in this over the past 2 years or more.

+1 to all of the others above.

I have a WebCore piston which checks whether the mode is any of two that I’ve set, if it is, it triggers the piston.

For the last 2 nights this has failed even when the mode is most definitely one of the two.

I’ve had no updates since yesterday but will let you all know when I do. Ellen has been very responsive since last Friday and I’ve noticed some of her messsges come in quite late so hopefully I’ll hear from her again tonight.

In the meantime thank goodness I also have Blink cameras that don’t rely on mode, they’re still working well. Probably given them the kiss of death now though lol…

Is this deal with the Modes that everyone has been reporting isolated to the UK or is it also affecting anyone in the US? Has SmartThings staff made any reference specific to what the issue is. It sounds like you have one rep via Twitter “Ellen” assisting.

I can’t say unfortunately because like the others, I’m based in the UK.

Has anyone tried to reach out to any of the SmartThings staff out here in the community that are based in the UK? (I saw one user above reporting from Canada as well). I’ve seen nothing on the page. Maybe @anon36505037 knows a couple of their handles out here to see if they are aware of this issue.

I’m not a prolific poster on here but when I first started, @Aaron was the go to guy.

Not sure whether he’s left Samsung since though because he’s been very quiet the last few months.

Perhaps @Brad_ST has heard word of this issue across the pond

Same problem here, UK user, absolutely no problems until yesterday, when notify me when started sending me motion notifications whist in home mode, it had worked flawlessly up until then and I’ve not changed anything. I raised a ticket with ST yesterday, still waiting to hear back…

uk based. problem with notify me when. . I got a response from support but they could not do anything as I had removed the app! I have reinstated it and notified them this morning