Linear Garage Door Opener Stopped Working

boom, now my 2nd opener stopped working 2w later. bought them both at the same time.

+1 on one of my two GD00Zs. I was at 10 months after Amazon purchase so no joy there. I e-mailed Nortek as well as ordering another from AMZ (pessimistic mode)

I Installed the replacement from AMZ and lo - two days later, a brand new replacement device from Nortek arrived. (No indication there was a replacement coming - it just showed up)

So now - I have a working garage door, and a replacement on the shelf. I hate that I think I’ll need it, I’m happy that I’m prepared.

Similar issue here, I bought two of the GoControl labeled Garage door openers from Amazon in Sept 2016. I didn’t use the open/close feature often, but I did use the sensor status for other activities. The sensor status still works, but attempting to open/close, I hear it beep and my LED does flash, but then nothing.

I have two garage door openers, tried the remove & re-pair to the network, new sensor battery, and I even tried my old home automation hub (staples connect). It always behaves the same. I guess I’ll take it down and scope out the leads, but I’m not hopeful.

Bought two of these in July of 2017…same behavior as listed. One started to flash, beep, but no action, a few weeks later both are failed and won’t beep, flash, or move the door, but will still provide status to ST hub…super useful…At least mine are still in warranty (in theory).

I tried all of the same troubleshooting as everybody else to no avail.

Wow, I didn’t realize I wasn’t the only one with this problem. I have had mine about 1 year now. Same behavior as everyone else. Door sensor works, beeps work, no actuation of the door. It’s like an internal relay isn’t working. I’m going to reach out to them and see what they say, but I may just crack it open and take a look.

Any one else try that? Any images of the internals?

This exact same thing has happened to mine (was working fine, but now beeps and does nothing else). I tried swapping the battery in the sensor (some people in another thread claimed that it worked for them, and it made sense to me as a reason that so many seemed to quit working after about a year). Didn’t help.

I tried cycling the garage door with a multimeter at the opener unit so I could get an idea of what the signal should look like when it’s activated (it’s about a .5V difference when the button is pushed). I power cycled everything while I was up there, that didn’t help. I tried activating the GD00Z-4 and waited for the signal after the beeps: no change. As far as I could tell it wasn’t sending any signal at all, so I pulled it off of the ceiling and brought it inside to futz with it.

Happened to have this thread open on my phone while I was looking at it and saw the above post looking for images of the internals, so…

DSCN8788|666x500

Just adding to the numerous people who have the same problem. Bought GoControl/Linear GD00Z-4 from Amazon May, 2016 and it stopped working several months ago. It beeps, but it does not send any signal to the garage door opener. Clearly a common problem.

Even though it’s been over a year, I decided to chat in and ask because of the rep’s comment above. The chat rep said I had to call in. When I call in, their system answers and says, “Thank you for calling Nortek Security & Control, you call may be recorded…” and then it hangs up.

Seems their support line works as well as the garage controller unit.

For those of you who purchased on Amazon, I’d recommend calling and complaining to Amazon…they care about their customer’s experiences, and 1) You might find they can help you in some way, and 2) If they get a volume of complaints they will (I’ve seen this in the past) take steps to remove or suspend products being sold. That sends a message to both resellers (Go Control) and manufacturers (Nortek).

Won’t take more than five minutes of your time.

Also hit them in the product reviews as well…

After two months after I bought it I started get irratic behavior. It would say it’s open when it wasn’t and would be unresponsive.

The way I wired it was I had 4 wires under one screw. One of those was the gocontrol wire. It was very difficult to get that connected. My hunch was that the go control was not connecting well enough and getting confused.

So I bought some wire nuts and screwed all the wires into it. Then I put a single wire between the wire nut and the garage screw. I have had no problems ever since.

I can not speak for the people that have had the device for over a 10months . I’ll let you guys know if it makes it or breaks it by September. (I bought mine in November)

And if your wondering why 4 wires? Well, one is the left garage door sensors the other is the right door sensor and the other is the wall button and of course the fourth one is from go control. So by reenforcing the wire and it’s connections it seems better.

+1 Same. Exact. Story

Has anyone been able to successfully replace e the relay? I just got off the phone with Linear and Nortek support. Essenrailly they told me I’m SOL and to buy a new unit. Needless to say I’m very frustrated and won’t be doing that or recommend them to anyone else.

+1. Same issue as described. Support is silent.

When (not if) my current unit fails I will be looking for other options in this area.

I will contact Amazon again and complain so they get more customer feedback on how bad these units are.

@Jeremy8404, from what you’re saying please correct me and then we can move forward:

  1. Device communication is working? You press open in the App and the controller beeps, but doesn’t do anything?
  2. The device reports the correct status? In the app and the door is closed it reports closed? What about when the door is open? Does it report open?

If those are all YES. Then I would check the connection. It is possible that through vibration the wire connection to the garage door opener may have worked loose over a year. Check the wires, ensure they are connected nicely and then open/close manually and then check open/close from the app. Take take in between the manual open/close and then trying to do it with the app. There is a safety delay that it won’t accept remote control operations for a period of time something like 30 seconds if I remember between the time of one action to another.

Add me to the list. Same symptoms. It beeps, flashes the light, then nothing. Door status is correctly reported. I tried rebooting and checked the connections. Nothing. Mine died a few months ago and lasted about 18 months. I don’t really want to replace it with another one of the same model just to have this happen again.

X2 or is it X55? Add me to the list. Finally got off my duff. Replaced the battery on the tilt switch. Checked. Double checked. Switched. Isolated wires. Beep, but no door love. Only thing I haven’t done yet is get a multimeter out and see if there’s any kind of signal. Looks like that’d be a waste of time.

A big fat me too on this one. 13 months from date of purchase. Beeps, no LED flashing, doesn’t trip the relay.

Bought mine Feb 2017, noticed it was doing exactly this now last week of April, 2018.

Beeps, i cant see any flashing, door dossnt move up or down.

I swear it is beeping longer than it used to, but may be my imagination.

I also think it will beep to a close command nearly instantly over and over- no obvious 30 second delay. Maybe it knows it isnt opening or closing somehow (door sensor?).

I also tried cycling power and replacing battery in door sensor - no effect.

Finally, I sent an email to supplier, will see what they say.

Ok, I’ll reply to my own message :slight_smile:

I took the unit apart today and poked around. I’m pretty sure the relay was fine, obviously the zwave module and tilt sensor seemed fine too based on accurate door status and always responding to ST requests with beeping.

I still found it interesting that the module would respond to successive open or close requests with no time delay - as if the module knew it had not opened or closed the door.

I think the module can sense the LED operation (voltage across led within some range, it seems) and mine may have failed. I presume the LS testpoint is the feedback path from the LED to the micro.

I pulled the LED off the board and did some measurements, the drive appeared to work ok, and pushed out 1 amp from what I believe to be a constant current source, enabled by the micro @ 3.3v on the testpoint labeled LD.

I built a diode and 2.4ohm resistor combination in series and placed it in place of the LED. Of course this will not light up, but should be roughly the LED forward drop with 1A flowing through it. I am guessing I could have done a single 3.5 ohm resistor instead (no diode), but I didn’t try it. I picked a 1n4004 and 3W 2.4 ohm resistor. Technically I’m over powering my diode and the resistor should be derated as well if 100% on, but given the pulsed output for a short time, I should be ok for now - I didn’t measure the duty cycle, however.

With my diode and resistor in place my controller works again, I used it 5 times tonight. I also tried to open-circuit the led again in the middle of my tests and noted it did the beeping without action again.

Other bits of interest:
Some UARTs accessible via soldered in headers. These seem to be controlling the separate wireless modules for the tilt sensor and zwave interfaces.

If you jumper the TEST header at power up, the UART to tilt sensor seems to send out a note about being in Factory Test Mode.

RD is relay drive output from micro controller.

SS (switch sense?) seems to be a sense network across the relay contacts, possibly monitoring manual push button presses and/or looking for a minimum voltage on the contacts before operating. My sense network changes to ‘active’ with any more than about 2V across the contacts. Note it is a full wave bridge so polarity insensitive.

You can jumper VPP and COM on the PIC programming header to hold the chip in reset and play with its outputs (like to test the LD signal response or RD without fighting the GPIO output drive)

Many test points are nicely labeled with silkscreen for debugging, such as 12V, 3.3V, Common, etc…

I may order a new CREE led to see if I can get my blinking back, I think there is a compatible part on digikey for 0.75 each (yet, 3.75 shipping).

If anyone wants to sell a unit with this failure mode, I’d consider buying it fairly cheap, I could use a second for my other door.

7 Likes

Timnord,
That is great news. I had tested the relay and that is not the problem. Even if I get this working without the LED, it will be great. Does that LED need some extra resistance in series?