How I Made Linear's GD00Z-4 Work with LiftMaster's MyQ Door Opener

I should probably subtitle this “How I Broke My Warranty.”

Like many people that bought Linear’s GD00Z-4 “Garage Door Opener Remote Accessory,” I was surprised when it refused to open my garage door. How could it not work? It shows up in my SmartThings app. The position sensor works when I manually move the door. When I send a command, the beeper beeps and the strobe light flashes. Yet my garage door remains stubbornly still.

To make things worse, when I remove the wires from my opener and clip them to my continuity tester, then press the button in my SmartThings app, the tester beeps! Put the wires back on my opener and it doesn’t work again. Just confounding.

First I want to say “thank you!” to everyone that posted about the 60 second delay. Apparently there is a law which requires this type of device to wait at least 30 seconds between operations. It appears that Linear has chosen to wait 60 seconds or so. Your posts saved me a bunch of grief trying to figure out that one.

Then I read a few threads where the GD00Z’s wires were connected to the pushbutton of a wireless remote, which then operates the door. Another variation is connecting the wires to the coil of an external relay, which was then used to operate the door. This made me believe that Linear’s relay (either mechanical or solid state) wasn’t “strong” enough to handle the load.

So I popped open the GD00Z-4 and found a mechanical AZ957 Subminiature PC Board Relay. This little guy is UL rated at 1A max at 30V DC! For fun, I measured the current used by my opener when shorting its wires and found it was only 50mA. There is just no way the GD00Z-4 can’t operate my opener.

After a little investigation I discovered that the GD00Z-4 monitors the relay contacts to see if it’s connected to an opener. If it doesn’t detect some minimum amount of voltage then it does not activate the relay. Here is a simplified schematic of the “Contact Monitor” (my words).

As you can see, an external voltage applied across the contacts is run through a full wave bridge. This makes the contacts polarity insensitive. The rectified voltage is filtered by a small cap and fed to the base of a transistor. The transistor then switches the test point “SS” to ground.

So I looked at test point “SS” with my 'scope. When my continuity tester was connected to the GD00Z-4, SS was a steady low (close to 0V). When my garage door opener was connected, SS was low with high going pulses. I looked at my door opener with the 'scope and noticed that the 5’ish volt signal had bursts of noise every 250ms. When I zoomed into the noise, I could see they were little packets of communications data roughly 20ms wide.

Now I had a theory – the “noise” of the communications traffic was preventing the GD00Z-4 from working. And I understood something – the reason the wireless remotes and external relays work is because they isolate the GD00Z-4 from the communications “noise.”

I decided that if I could force test point “SS” low then the GD00Z-4 would work. I could have tried to remove the “noise” by adding a bigger filter cap, or forcing the transistor into the “on” state by lifting the base resistor and applying a fixed voltage to it. But knowing that the transistor just shorts SS to ground, I decided to simply do that. . .

As you can see, I soldered the white jumper wire from test point “SS” to the “COM” test point. The “COM” test point is circuit ground. And. . .

IT WORKS!

Now for the full disclosure part. My opener is a Raynor branded LiftMaster. I did not buy the MyQ option. My wall button does have the motion sensor and controls for options like automatically closing the door, etc.; but, I do not use any of that. I have not tried to see if the motion sensor or any of those other options still work. I only use my wall button as a button. And that still works, so I am happy.

Obviously, I’ve voided my warranty (for sure on the GD00Z-4, possibly on the door opener?). I was willing to risk permanent damage to both my GD00Z-4 and my door opener in this experiment. I’m posting my findings here for your entertainment. I was super curious to understand why the GD00Z-4 wouldn’t work with my opener. Now I understand, my curiosity is quenched, and hopefully yours is too.

TL;DR – Shorting test point “SS” to ground seems to have let my GD00Z-4 work with my LiftMaster. Been working for a couple of weeks now.

11 Likes

Thanks for the info…I have a liftmaster 8065, but short the SS to COM doesn’t solve my problem.
At the end, I connect wire to remote’s switch button, Which works very well…
BTW, there’s Vcc on the print board, which can provide +3V power to the remote. So, no need to change battery :slight_smile:

Thanks for the feedback.

I like that you stole +3V from the board to power the remote.

I am a little disappointed that the short did not work for you. I wonder why it didn’t?

I am curious – do you have the MyQ option? Did the GD00Z-4 open the door, but prevent other accessories from working?

Thank you for all the info. I was searching on another site and found out that you were able to step the signal through the wall mounted button. So I took it on step further. I got the wireless remote and soddered the wires on the board on the button terminals.

This is the board from the switch. The other side has the switch and terminals. Then I taped it up and mounted it next to the controller above opener. I was also able to connect to a zwave Hub. Just wanted to share in case someone else is looking to do same thing. My garage is a lift master 7675.

1 Like

mcavoya - this is brilliant! I have a Craftsman garage door opener with the “smart” wall switch (motion sensor, temperature, etc.) and was experiencing the same problem as you: The Linear could open/close my garage only when the wall switch was completely disconnected (rendering the wall switch useless).

Following your instructions, I opened the GD00Z-4 up and soldered a wire to the points you specified above. It worked perfectly! The wall switch functions normally and the GD00Z-4 is successfully opening/closing the door.

A HUGE thanks to you for taking the time to explore this and to share your solution!!!

1 Like

Outstanding!
I’m so glad someone else was able to replicate this. Makes my day.

1 Like

Hi Guys,

Which terminals on the Liftmaster did you plug the GD00Z-4 into?

Thanks,
D

I can’t find my documentation, so I don’t know exactly which terminals they are. I just spliced into the two wires running from the door opener to the wall switch.

I want to second this post as brilliant! Did the exact same thing on some linear openers for my craftsman (liftmaster rebadge) and it works! Thanks for sharing your modification!

I was able to get this working without cracking open any of the equipment. Just buy a lift master myq single button controller for about $10 and that can work in normally into a Chamberlain myq opener.

I connected the linear to the micro switch terminals and that triggers the opener after it’s paired. No hassle and basically in spec.

3 Likes

Ok so I need help, I have been reading and reading all of these posts. Like most people normal hook up of the linear device did not operate the garage door. So I bought a new wall button and soldered the wire from the linear device to the button and connected that into the garage door opener leaving the existing button connected on the wall.

IT WORKED!!!

The issue i’m having now is it works once. After I use smartthings to open or close the door it stops working. by that i mean the normal wall button and the wireless controller can still control the garage door, but… The button the linear device is soldered to will not control the garage door and when I use smart things to activate the garage door it does not beep or do anything.

My guess is its constantly sending a signal to the button, am I wrong? Does anyone have any other ideas what might be causing this issue and how I can fix it. I am greatly appreciative of any ideas you might have. Thanks.

I am going to go out on a limb here, and assume that the SmartThings connected button works again after about one minute. If so, this might be happening. . .

Apparently there is a law which requires this type of garage door opener device to wait at least 30 seconds between operations. It appears that Linear has chosen to wait 60 seconds or so.

I first thought it was that and waited a full day before trying again but still no dice. Thank you.

Actually I take it back, I don’t know if i did something but it seems to work once per hour. What do you think?

Earlier you said,

It’s the “does not beep” that bothers me. I assumed that was because of the one minute delay imposed by Linear. But if it works again after an hour, there must be something else going on.

I suggest separating the Linear device and the wall button to isolate the problem. Make sure they are both working independently. Obviously the Linear device won’t open the door, but it should beep. And if you have an ohmmeter, connect it to the Linear’s output. It should be normally open, and briefly short just after the beeping stops.

To be clear, are we saying that the fancy motion detector garage door push button’s wires can be shorted to open the garage door?

So to do this hack, just short SS to COM on the garage door controller, then splice the controller’s wires to the stock push button’s wires, which will allow the stock wires to be shorted despite the communication noise, thus opening the door?

To answer my own question, I decided to throw caution to the wind and test it on my opener. Shorting the two wires to the fancy push button does indeed open/close the door.

Off to do some soldering! Thanks @mcavoya!

Best of luck! Let us know how it turns out.

@mcavoya Thank You! I created a smartthings account just to say so!

Your solution worked perfectly for me.

I have a Liftmaster 8500 garage door opener and a MyQ 888LM Button connected to it. Everything existing still works as expected. and My GD00Z-4 also works as expected.
I use a vera home z-wave controller.

My only qualm with the whole setup is that the powercord of the GD00Z-4 is only about 3-4 ft which I have used an extension cord, but will install a new outlet once its not freezing outside. My garage is detached and about 30 feet from my next closest z-wave device. I’m hoping this works through the winter since we’ve had -20C (-4F) a few days.

@scurrier, since no one else answered your question… yes, after shorting SS to COM in the GD00Z-4, just connect its leads to the 2 wire screws on the back of the MyQ button.

Hope this thread helps many others! Good Luck!

Russell,

Did you ever figure out he one hour delay?

I appear to be having the same issue where I only can do one operation per hour. No beeping or anything until the hour is up. Also seams to break the wall button until the hour is up.