Linear Garage Door Opener Stopped Working

I believe the LED on board is a bright white LED, with a forward drop of around 3-3.5 V and they seem to run it at 1A (no additional resistance, it is powered by the switching IC driving constant current through the LED).

I wanted to provide roughly the same behavior - rectification properties and voltage drop, so I used a standard diode and series resistance. The diode to rectify and resistance to bring voltage roughly within assumed range (knowing it was a 1A supply). I presume merely using a 3.5 ohm resistor by itself would also work, likely needing at least 1W, better at 3W or more (knowing that fully on it would be burning 3.5W, but assumed blinking and rare usage may allow less power capability)

I soldered mine back up and put it back together. I will report again if anything doesn’t work (yesterday it was a bit of an alligator clip experiment).

I am considering buying some Cree parts from digikey, I suspect they would work ok - XPEBTT-01-0000-00T80


Just had the same exact problem…


Could you post a photo of the insides of this unit and what you did to make it work, Seems to be a very common problem.

Let’s try this…

I didn’t take pictures of the final assembly, and now it’s back packaged in the case and mounted to my opener… if this is inadequate maybe I could take it apart for further shots.

I did take a poor picture of the board itself, prior to any modifications. The LED is on the “back” with the piezo – see area with the red box.

The red box is then zoomed up here with crude Paint.NET sketch showing what I did.

  1. I removed the chip LED as carefully as I could, note there are actually 3 pads, I presume Anode, Cathode (on ends visible) and a center pad likely for heat sinking (it runs at nearly 3W if on continuous).

  2. I created a series combination of axial parts: a 2.4 Ohm, 3W resistor with a 1N4004 diode - just because it is what I had. I would have preferred a larger wattage diode. I really think it would work fine with a single ~3.5 Ohm resistor and no diode, but I did not try this.

  3. I soldered the diode/resistor combination to the LED pads as shown in my diagram - anode side towards the bottom of the board (furthest pad from the piezo). I did this after carefully bending leads to ensure it would fit in the case after assembled.

So far it still seems to work every time I’ve tried. This is maybe 5 more uses since I put it back in last week.

Here is also a shot of the top of the circuit board, I didn’t do anything with this.

Sorry about the photo quality (overhead lighting glare). When I took them I didn’t take the time to find a suitable environment to take better shots.


I didnt have a 2.4 ohm or a 3.5 ohm resistor laying around so I put 3 10 ohm resistors in parallel and soldered them to the LED pads… and it worked! My opener had the same symptoms as everyone elses - lights flash, beeps a bunch of times, then nothing. After I soldered the resistors in place the opener functioned on the first try. Thank you!


Yup, me too, 13 months.

My opener had the responsive LED, but no opener control issue. I put a 3.3 ohm resistor with both the LED in place, then without, but did not resolve the issue. Mine was bought in 2015, so I can’t be too upset at its life. But, I have two of them - one for each garage. If they start breaking any faster, I will be looking into alternatives.

What is the resistor supposed to do? There can hardly be any resistance that the LED provides w/o the resistor in place, so what does putting resistance on those terminals supposed to do? I can hear the relay in Linear flipping like it wants to lock, but maybe that is the failure point?

Each of my units are on Tripplite surge protectors, but if it was something with the electrical circuit you’d think the other would be problematic, too.

According to the post above, the module can sense the voltage drop across the LED (to ensure it is blinking and operational, for safety reasons I assume). The problem is that the LED falls out of spec quickly and this could cause sense issues and therefore the opener will not open the door if it thinks the LED is not operational.

I think the control has feedback lines on each of the outputs:

  • LED
  • Piezo (buzzer)
  • Contacts

I say this because there were test points near each of these functions labeled with an “S” like sense. I think the LED was LS, the contacts of the relay were SS (switch sense?) and the piezo may have been AS = audio sense (weird, but possible?). There were somewhat matching “D” signals = LD (LED drive), AD (audio drive) and RD (relay drive).

It may use the contact sensing also for detecting voltage coming from the opener / the manual push button. I don’t know, just assume from inferring what “SS” may mean on the sensing circuit across the contacts.

If you hear a relay clicking in the module, I would place a Volt Meter across the contacts and expect it to go from some voltage (driven by your opener) to 0V when the relay is made. If I recall correctly there is a diode bridge across the contacts that provides a digital input to the processor whenever there is > 1.8V across the contacts.

Personally I would not probably not play with the resistors that I suggested if the LED is functional as the problem likely lies elsewhere.

I wonder if your unit can be triggered numerous times over and over. They have a built-in 30 second to 60 second delay between actuation attempts, but when mine was failed this was not being done. This implied to me that the unit was actively avoiding an attempt at driving the door and therefore allowed me to retry immediately repeatedly.

1 Like

Whatever was the root cause, I ended up returning both new replacements that I tried to get working with this motor:

All functionality was there on both - audible beeps, LED flashing, and relay triggering, but the motor on the opener flashed diagnostic lights that led me to find this:

Up Arrow Flash: 1
Down Arrow Flash: 3

The door control will not function.

The wires for the door control are shorted or the door control is faulty. Inspect door control wires at all staple points and connection points, replace wire or correct as needed.

I know everything was wired correctly because it had been working for a long time, then just out of the blue with NO changes to either the garage door opener, or the Linear unit, things quit working. I know the infrared eyes are good since my door control on the wall works just fine, which is also (obviously) what the Linear wires go to.

I fixed mine using 3x 10ohm (1W) resistors in parallel, just like @tscan did. Thank you @timnord

Sorry to say that the unit itself is garbage. I had the same issue, as did a very large number of other users.

Check the Amazon site for all the 1-star reviews of this unit (the Linear and the Iris are made by the same manufacturer).

Sure, you can break out the solder iron and try to fix the design flaw, or you can get a quality opener instead. Personally, I have the Nexx Garage and I like it for the most part. They say they will have Smartthings integration this year. It already works with IFTTT, so I am able to integrate it with my routines, etc.

First of all big thanks to timnord! I’m not a big electronics guy but based on your recommended fix and part from digikey I was back up in running in a few minutes.

My unit was making the beeping but no flashing and the led must have been shot. Replacing it has everything back working again. I’m not great at soldering but I got it working at least for now.

Thanks you guys are awesome.

Would you mind sharing a link of the resistor you purchased?

I wasn’t sure whether the forum would allow me to post a link. You can go to digikey and copy this into the search engine and you will find it XPEBTT-01-0000-00T80.

Otherwise here is the link. Note that this is for the replacement LED as I wanted to get it totally working again. It is a little tricky to solder but I managed it. Just make sure you note the polarity. The notched end should be soldered to the shorter end of the board.


Got mine working again! Thanks ya’ll!

@Jharrin1 did you solder in the resistors AND the LED? or only the LED? I have the same issues as everyone else, and am wondering if I only need to solder in the replacement LED or whether the resistors would be required as well.

I only soldered in the LED as a replacement. I did not add a resistor in series or parallel because I don’t think it is required. People were using the resistors as a replacement to the LED.

A few more notes:

  • to remove I noted the direction of the led using a marker so I knew the polarity. The notched end was towards the short end of the board

  • using a small soldering tip I heated both the visible pads to liquify the soldier and remove the old LED. As noted before there is a pad in the middle that I’m not sure what it is for but I did not heat that and the old LED popped free

  • I added more a little more solder to both the outside pads. I lined up the led with the notch end towards the short end of the board. While lightly pushing down I heated each pad to liquify and connect the LED.

  • it took me 2-3 times to get a consistent reliable connection and since then it has been working fine.

$5 in parts (mainly shipping) and 20-30 minutes and I was back in business.


Thanks for the info. I am wondering if I should replace with the exact LED or just some resistors. We know this LED has a life of 1 year. Looking at the specs, it has to be stored in RH<85% and <86F. CREE calls this a torch LED. Maybe that is why it is going bad. I am assuming this will go bad in one summer. I really don’t want to solder another one next year.
Anybody know all LED are moisture sensitive. The LED in landscape lights last longer hopefully we can find a better one.
I see this Silicone conformal coating MG Chemicals 422B-340G at Digikey for $18. Anyone have any experience with that.

I can’t comment on the reliability. However my original LED did last almost two years.

A resistor should be more bullet proof (nothing really to break). I’m going to see how this replacement lasts and go from there.

I’m sure others can comment on the choice of part. I just used the suggested part from the other poster.