Linear Garage Door Opener Stopped Working

@Jeremy8404, from what you’re saying please correct me and then we can move forward:

  1. Device communication is working? You press open in the App and the controller beeps, but doesn’t do anything?
  2. The device reports the correct status? In the app and the door is closed it reports closed? What about when the door is open? Does it report open?

If those are all YES. Then I would check the connection. It is possible that through vibration the wire connection to the garage door opener may have worked loose over a year. Check the wires, ensure they are connected nicely and then open/close manually and then check open/close from the app. Take take in between the manual open/close and then trying to do it with the app. There is a safety delay that it won’t accept remote control operations for a period of time something like 30 seconds if I remember between the time of one action to another.

Add me to the list. Same symptoms. It beeps, flashes the light, then nothing. Door status is correctly reported. I tried rebooting and checked the connections. Nothing. Mine died a few months ago and lasted about 18 months. I don’t really want to replace it with another one of the same model just to have this happen again.

X2 or is it X55? Add me to the list. Finally got off my duff. Replaced the battery on the tilt switch. Checked. Double checked. Switched. Isolated wires. Beep, but no door love. Only thing I haven’t done yet is get a multimeter out and see if there’s any kind of signal. Looks like that’d be a waste of time.

A big fat me too on this one. 13 months from date of purchase. Beeps, no LED flashing, doesn’t trip the relay.

Bought mine Feb 2017, noticed it was doing exactly this now last week of April, 2018.

Beeps, i cant see any flashing, door dossnt move up or down.

I swear it is beeping longer than it used to, but may be my imagination.

I also think it will beep to a close command nearly instantly over and over- no obvious 30 second delay. Maybe it knows it isnt opening or closing somehow (door sensor?).

I also tried cycling power and replacing battery in door sensor - no effect.

Finally, I sent an email to supplier, will see what they say.

Ok, I’ll reply to my own message :slight_smile:

I took the unit apart today and poked around. I’m pretty sure the relay was fine, obviously the zwave module and tilt sensor seemed fine too based on accurate door status and always responding to ST requests with beeping.

I still found it interesting that the module would respond to successive open or close requests with no time delay - as if the module knew it had not opened or closed the door.

I think the module can sense the LED operation (voltage across led within some range, it seems) and mine may have failed. I presume the LS testpoint is the feedback path from the LED to the micro.

I pulled the LED off the board and did some measurements, the drive appeared to work ok, and pushed out 1 amp from what I believe to be a constant current source, enabled by the micro @ 3.3v on the testpoint labeled LD.

I built a diode and 2.4ohm resistor combination in series and placed it in place of the LED. Of course this will not light up, but should be roughly the LED forward drop with 1A flowing through it. I am guessing I could have done a single 3.5 ohm resistor instead (no diode), but I didn’t try it. I picked a 1n4004 and 3W 2.4 ohm resistor. Technically I’m over powering my diode and the resistor should be derated as well if 100% on, but given the pulsed output for a short time, I should be ok for now - I didn’t measure the duty cycle, however.

With my diode and resistor in place my controller works again, I used it 5 times tonight. I also tried to open-circuit the led again in the middle of my tests and noted it did the beeping without action again.

Other bits of interest:
Some UARTs accessible via soldered in headers. These seem to be controlling the separate wireless modules for the tilt sensor and zwave interfaces.

If you jumper the TEST header at power up, the UART to tilt sensor seems to send out a note about being in Factory Test Mode.

RD is relay drive output from micro controller.

SS (switch sense?) seems to be a sense network across the relay contacts, possibly monitoring manual push button presses and/or looking for a minimum voltage on the contacts before operating. My sense network changes to ‘active’ with any more than about 2V across the contacts. Note it is a full wave bridge so polarity insensitive.

You can jumper VPP and COM on the PIC programming header to hold the chip in reset and play with its outputs (like to test the LD signal response or RD without fighting the GPIO output drive)

Many test points are nicely labeled with silkscreen for debugging, such as 12V, 3.3V, Common, etc…

I may order a new CREE led to see if I can get my blinking back, I think there is a compatible part on digikey for 0.75 each (yet, 3.75 shipping).

If anyone wants to sell a unit with this failure mode, I’d consider buying it fairly cheap, I could use a second for my other door.

7 Likes

Timnord,
That is great news. I had tested the relay and that is not the problem. Even if I get this working without the LED, it will be great. Does that LED need some extra resistance in series?

I believe the LED on board is a bright white LED, with a forward drop of around 3-3.5 V and they seem to run it at 1A (no additional resistance, it is powered by the switching IC driving constant current through the LED).

I wanted to provide roughly the same behavior - rectification properties and voltage drop, so I used a standard diode and series resistance. The diode to rectify and resistance to bring voltage roughly within assumed range (knowing it was a 1A supply). I presume merely using a 3.5 ohm resistor by itself would also work, likely needing at least 1W, better at 3W or more (knowing that fully on it would be burning 3.5W, but assumed blinking and rare usage may allow less power capability)

I soldered mine back up and put it back together. I will report again if anything doesn’t work (yesterday it was a bit of an alligator clip experiment).

I am considering buying some Cree parts from digikey, I suspect they would work ok - XPEBTT-01-0000-00T80

2 Likes

Just had the same exact problem…

Tim,

Could you post a photo of the insides of this unit and what you did to make it work, Seems to be a very common problem.

Let’s try this…

I didn’t take pictures of the final assembly, and now it’s back packaged in the case and mounted to my opener… if this is inadequate maybe I could take it apart for further shots.

I did take a poor picture of the board itself, prior to any modifications. The LED is on the “back” with the piezo – see area with the red box.

The red box is then zoomed up here with crude Paint.NET sketch showing what I did.

  1. I removed the chip LED as carefully as I could, note there are actually 3 pads, I presume Anode, Cathode (on ends visible) and a center pad likely for heat sinking (it runs at nearly 3W if on continuous).

  2. I created a series combination of axial parts: a 2.4 Ohm, 3W resistor with a 1N4004 diode - just because it is what I had. I would have preferred a larger wattage diode. I really think it would work fine with a single ~3.5 Ohm resistor and no diode, but I did not try this.

  3. I soldered the diode/resistor combination to the LED pads as shown in my diagram - anode side towards the bottom of the board (furthest pad from the piezo). I did this after carefully bending leads to ensure it would fit in the case after assembled.

So far it still seems to work every time I’ve tried. This is maybe 5 more uses since I put it back in last week.

Here is also a shot of the top of the circuit board, I didn’t do anything with this.

Sorry about the photo quality (overhead lighting glare). When I took them I didn’t take the time to find a suitable environment to take better shots.

5 Likes

I didnt have a 2.4 ohm or a 3.5 ohm resistor laying around so I put 3 10 ohm resistors in parallel and soldered them to the LED pads… and it worked! My opener had the same symptoms as everyone elses - lights flash, beeps a bunch of times, then nothing. After I soldered the resistors in place the opener functioned on the first try. Thank you!

4 Likes

Yup, me too, 13 months.

My opener had the responsive LED, but no opener control issue. I put a 3.3 ohm resistor with both the LED in place, then without, but did not resolve the issue. Mine was bought in 2015, so I can’t be too upset at its life. But, I have two of them - one for each garage. If they start breaking any faster, I will be looking into alternatives.

What is the resistor supposed to do? There can hardly be any resistance that the LED provides w/o the resistor in place, so what does putting resistance on those terminals supposed to do? I can hear the relay in Linear flipping like it wants to lock, but maybe that is the failure point?

Each of my units are on Tripplite surge protectors, but if it was something with the electrical circuit you’d think the other would be problematic, too.

According to the post above, the module can sense the voltage drop across the LED (to ensure it is blinking and operational, for safety reasons I assume). The problem is that the LED falls out of spec quickly and this could cause sense issues and therefore the opener will not open the door if it thinks the LED is not operational.

I think the control has feedback lines on each of the outputs:

  • LED
  • Piezo (buzzer)
  • Contacts

I say this because there were test points near each of these functions labeled with an “S” like sense. I think the LED was LS, the contacts of the relay were SS (switch sense?) and the piezo may have been AS = audio sense (weird, but possible?). There were somewhat matching “D” signals = LD (LED drive), AD (audio drive) and RD (relay drive).

It may use the contact sensing also for detecting voltage coming from the opener / the manual push button. I don’t know, just assume from inferring what “SS” may mean on the sensing circuit across the contacts.

If you hear a relay clicking in the module, I would place a Volt Meter across the contacts and expect it to go from some voltage (driven by your opener) to 0V when the relay is made. If I recall correctly there is a diode bridge across the contacts that provides a digital input to the processor whenever there is > 1.8V across the contacts.

Personally I would not probably not play with the resistors that I suggested if the LED is functional as the problem likely lies elsewhere.

I wonder if your unit can be triggered numerous times over and over. They have a built-in 30 second to 60 second delay between actuation attempts, but when mine was failed this was not being done. This implied to me that the unit was actively avoiding an attempt at driving the door and therefore allowed me to retry immediately repeatedly.

1 Like

Whatever was the root cause, I ended up returning both new replacements that I tried to get working with this motor:

http://a.co/hXQIyeh

All functionality was there on both - audible beeps, LED flashing, and relay triggering, but the motor on the opener flashed diagnostic lights that led me to find this:

https://support.chamberlaingroup.com/s/article/What-do-the-flashing-UP-and-DOWN-arrows-mean-1484145672350

Indication:
Up Arrow Flash: 1
Down Arrow Flash: 3

Symptom:
The door control will not function.

Cause:
The wires for the door control are shorted or the door control is faulty. Inspect door control wires at all staple points and connection points, replace wire or correct as needed.

I know everything was wired correctly because it had been working for a long time, then just out of the blue with NO changes to either the garage door opener, or the Linear unit, things quit working. I know the infrared eyes are good since my door control on the wall works just fine, which is also (obviously) what the Linear wires go to.

I fixed mine using 3x 10ohm (1W) resistors in parallel, just like @tscan did. Thank you @timnord

Sorry to say that the unit itself is garbage. I had the same issue, as did a very large number of other users.

Check the Amazon site for all the 1-star reviews of this unit (the Linear and the Iris are made by the same manufacturer).

Sure, you can break out the solder iron and try to fix the design flaw, or you can get a quality opener instead. Personally, I have the Nexx Garage and I like it for the most part. They say they will have Smartthings integration this year. It already works with IFTTT, so I am able to integrate it with my routines, etc.

First of all big thanks to timnord! I’m not a big electronics guy but based on your recommended fix and part from digikey I was back up in running in a few minutes.

My unit was making the beeping but no flashing and the led must have been shot. Replacing it has everything back working again. I’m not great at soldering but I got it working at least for now.

Thanks you guys are awesome.