I seem to have a 'ghost' driver

During a lot of driver packages and installs, I seem to have got myself into a weird situation.
I have a driver that appears when I logcat, but does not appear anywhere else. If I do logcat it, It does seem to be active during a scan. (It is a lan, local driver).

I have tried rebooting the hub to no avail.

Any suggestions?
@nayelyz

This should have helped. It has happened to me with LAN drivers (and I already reported it). For example, I create a driver package and install it, then, I delete the driver (uninstall > unpublish > delete). After this, if I hit “scan nearby” it seems the driver still appears but as “unknown”. Rebooting the Hub helped.

In this case:

  • Do you see the driver’s name?
  • Which version of the CLI are you using?
  • If you use the driver ID to uninstall, unpublish and delete, does it accept it?
    I’ve also seen that I had a driver “installed” but the package was deleted. So, running these commands helped check where it appeared:
smartthings edge:drivers:uninstall
smartthings edge:drivers:unpublish
smartthings edge:drivers:delete

Sounds familiar. In my case it was a survivor of a factory reset of the hub. Twice. It disappeared eventually. No idea if someone deleted it for me but it certainly wasn’t anything I did.

1 Like

Ah well I guess Its good Im not the only one.

Thanks for letting me know

See inline

Aha…I see I am out of date on CLI ill update and try again

Ok installed the latest version.
@smartthings/cli/1.0.0-beta.19 linux-x64 node-v16.16.0

went through the uninstall/unassign/delete with the same results

ok, then, I’ll open a report about this. To do so, please send the info below to build@smartthings.com:

  1. Email account that you use for SmartThings
  2. ID of the Ghost Driver
  3. The content in logcat when you see the driver in the list.
  4. Provide access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

Oh Brilliant. Thanks so much. I will dm you the details

After @nayelyz kindly reported this, I find thaat this morning after a reboot the offending driver has disappeared. So weird.

Apologies for wasting everyones time

1 Like