As of 1 hour ago, I can no longer install drivers to my hub Am I the only one?

As per title…There are drivers already installed that appear to be functioning correctly, but logcat no longer sees any new drivers, although using cli to check installed drivers shows the driver installed.

Doing a scan, and the new driver does not respond (i.e., as per logcat, it appears to be missing as opposed to the cli installed response)

Hi, @Davec!
Is this still happening?

Is this a LAN driver or Zigbee/Z-Wave?
Do you have the corresponding permissions in config.yaml?

Also, which model is your Hub? There’s a scheduled maintenance for models v2, v3, and Aeotec Smart Home

It’s a v2. A lan driver. I had spent the morning constantly installing it and tweaking. It does have the permissions set

Firmware is .11. I also tried on my other hub. Firmware v.9 same problem. I also couldn’t install any of my drivers on that .9 hub.

I am wondering if I’ve done something stupid. Happy to wait and see if the maintenance helps

Mmm it is strange that the Hub logs don’t show the initial part of the driver execution.
When you hit scan nearby, do you see the Hub’s LED blink in green? There was an issue in iOS where the button scan nearby didn’t put the Hub in discovery mode, but the latest app release solved this.

Another thing that would be worth checking, does your device have a unique value in device_network_id? Each device must have a different value in order to be discovered.

Just to be clear, logcat was not showing the new driver as being available to stream from!!! The hub was scanning fine. It was as if the driver had not been installed.

Anyway, just tried again and all worked fine without me changing anything…Maybe it was the hub maintenance, or I was dreaming.

There isn’t any guiderail or limit on number of driver installs is there? I did do about 20 installs in an hour

Thanks anyway for your comments

I only know of the general limit where we can only install 50 drivers in our Hub. But I’m not aware of drivers installed per amount of time. I’ll check with the team just in case.

I’m having a similar issue. I am able to install the driver (Tasmota Edge) but when I do a scan it never picks up the device. Been trying for a few days now. Here is the link to my post at the Tasmota Edge thread. Tasmota Edge

@KennyG when you run ‘smartthings edge:drivers:logcat’ it should list installed drivers for connection. In my ‘weird’ case above, it was not listing the driver. Can you confirm it is the same in your situation? (ie nothing to do with scanning) If your situation is different, I recommend opening a new topic specifically about the driver in question.

I think I have the same issue. I don’t see the Tasmota Edge Driver when I run logcat.
When I run “smartthings edge:drivers:installed” I do see the Tasmota Edge Driver.

C:\Users\Kennyg>smartthings edge:drivers:logcat
? Enter hub IP address with optionally appended port number:

Driver Id Name

1 e67c842f-49a5-4083-95f0-c8137ae3c2f6 Edge Counter Utility V1
2 6a90f7a0-e275-4366-bbf2-2e8a502efc5d GE Zigbee Switch
3 e8a1a0b7-32e4-4882-8d38-45a96ead543d LAN Motion Device Driver
4 b973fd1e-52a8-4bcf-a2b8-1f3f5216891f Online Status Monitor V1g
5 0fd9a9a4-8863-4a83-97a7-5a288ff0f5a6 Virtual Devices V2
6 206918b4-c049-4225-91db-808b943b8041 Virtual Energy Meter
7 d462e24c-97dc-42d0-b843-59f85c7d9346 WLED Driver
8 e7947a05-947d-4bb5-92c4-2aafaff6d69c Z-Wave Fan
? Select a driver. (all)

Oh!!! I thought my problem was something to do with the firmware release that was at a similar time and was just some sort of aberration.

I assume you have restarted your hub?

My problem ‘fixed’ itself after a few hours although I did undertake normal ‘headless chicken’ activities restarting hub, deleting and re-installing the driver.

@nayelyz is this worth investigating? Is the discrepancy between logcat available drivers and installed drivers something the devs can explain?

Hi! I already opened a report about this. This is a particular issue, so that’s why it needs further investigation.

Thanks. I must admit I thought it was something I had done wrong😄