Hub Showing Offline


(Anthony S.) #1

Anybody else’s hub offline?
I have verified that I have internet access at home, but my hub still shows offline since 10:40am (EST)
I also checked http://status.smartthings.com and it is showing everything as up.


(Anthony S.) #2

It’s weird because my wife just got home and it sent a notification and triggered her routine. So it’s technically online. I can still control devices but it shows offline in mobile app and inactive in IDE.


(Kyle ) #3

If the issue is SmartThings related it will show here:

http://status.smartthings.com/


(Rick R.) #4

I have been experiencing the same issue. I can ping the hub from the ping utility from the api site but the hub still shows inactive.


(Jesse S) #5

Same problem here. At 11:12pm my hub (v2) reported it is “now inactive” and suggested I check my internet connection. Internet connection is fine, and the Hub is still handling local processing, but anything non-local is broken. Reported it last night to ST support, but no response yet. I saw in the forums that there’s an expected hub update coming out this week. Maybe they rolled it out with some new bug somewhere?


(Jesse S) #6

Update: Hub is back up and running… All automations appear to be functional.


(Al Straub) #7

I have been offline since last Thursday. The hub is active on my network, and responds to ping.
Support has been very courteous and responsive but hasn’t been able to resolve it.

They suggested:

  • ensure all necessary ports are open on my router (they are - I even bought a new router)

  • connect directly to my modem (tried with no change)

  • try on another network (I tried this with the wifi hotspot on my phone using an wifi/ethernet bridge but support claimed that was not a valid config - I have yet to take it to another physical network)

In the meantime, I’ve been doing some sleuthing of my own and found from a packet capture that the hub is trying to resolve a non-existent address. When the hub first comes online, it queries for fw-update.smartthings.com. It connects to the server, exchanges some data, then it tries to resolve “SmartThings” which fails. Once it fails on that name query, the hub goes to sleep for a while and then tries again where it just loops forever.

29 53.034512000 192.168.201.44 8.8.8.8 DNS 71 Standard query 0x5bb9 A SmartThings
30 53.104017000 8.8.8.8 192.168.201.44 DNS 146 Standard query response 0x5bb9 No such name

This query doesnt look correct to me since its not a fully qualified domain name. I’ve reported this to Support - hopefully this will help them narrow down the problem.


(Al Straub) #8

SmartThings support could not provide any explanation for the DNS behavior of the hub and suggested to exchange it. I was still convinced there was a software bug, but I gave in and decided to pull the plug on Monday (10/12) by submitting an RMA request to replace the hub.

The replacement arrived yesterday (10/14). Ironically, the hub started functioning the same day within minutes of the package delivery. I was not at home at the time and received notification on my phone.

Support claims that there have been no changes on their end to account for the hub recovering. I’ve rebooted the hub several times and it seems to be going online now without trouble.

So, now I’m in a pickle - do I proceed to swap out the hub or just leave it? Resetting my devices will be a pain in the butt and I’m not convinced it was actually a hardware problem to begin with. The fact that SmartThings cannot provide a reasonable explanation at all leaves me with doubts though.

A working packet trace looks a little different too - it queries for “SmartThings.home”, then “SmartThings”. It didnt do that before. After the local DNS queries, it then goes on to query for the cloud servers and establish the necessary connections.

I also figured out the strange DNS query for “SmartThings” - turns out the hub was trying to resolve its own hostname. My router just so happened to not have a default domain name which explains why it was querying for “SmartThings”. I reconfigured my router to use a domain name of “home”, and noticed the hub started querying for “SmartThings.home” but it didnt clear the problem even though the DNS server it was now providing a valid reply that referenced the hubs own IP. Honestly I dont think it should even be doing that dns query because home routers could be configured to hand out public dns server addresses in the dhcp reservation in which case typically, those DNS servers would not be able to resolve the hubs name at all.


#9

Mine went offline 5 minutes ago. My router port is working fine when I switch it with other devices. This sucks.


(fherbst) #10

Mine too. What’s going on?


(Riyad Chowdhury) #11

Mine went down 20 mins ago. Internet at home is fine, I can ping the hub. I have net flow analyzer installed at home and I see my hub communicating with ec2-54-225-218-213.compute-1.amazonaws.com. Not sure why smart things thinks its offline.


(Chris Horka) #12

Mine is showing back up


(fherbst) #13

Mine is still inactive.


(Chris Horka) #14

6:18 am EST now showing inactive again :frowning:

6:20 am EST now showing back up

Obviously, our friends at Smartthings are having server issues


(Riyad Chowdhury) #15

Yep, looks like nothing is wrong on my end so nothing to do but wait for smartthings to fix it.


(fherbst) #16

OK, mine just came back online.


#17

My hub went an hour ago and is still down now. I’m getting an alert to check my internet connection, which appears to be just fine.


(Sean Holbert) #18

Mine has gone offline and come back up several times this morning. It is offline at the moment.


#19

I’m glad its not just me. Mine came back to life after rebooting, but is off again an hour later.


(Mike) #20

Mine too I have been getting alerts all am about if


SmartThings Is Over Party