Hub Problems, Replacement?

I have two Hubs in my home, a V2 in the house and a V3 in my shop. I seem to have more and more issues with the V2 in the house dropping devices and not working. I added two floor sensors about a week ago and the one that is about 10 feet from the hub is just about always off line, the other one is on more then off but it doesn’t seem to reliable either. I have two door looks that will not work and always have in the past. I have gone as far as removing them and readding them to the Hub, still no work. It shows them but they don’t do anything. The good night routine is hit or miss on turning all the lights off, some times it takes like 5 minutes to shut them off.

Smartthings doesn’t seem like they are keeping up with the times, should I be looking at better options.

So is it a Hub issue? If so can you replace a Hub and transfer all the devices without trying to re add them all one at a time

Probably not during this time of migrating devices from groovy device handlers to Edge drivers.

To start, please post the devices you are experiencing problems with:

  • brand/model
  • are they using device handlers or Edge drivers?
  • what are the device handlers or Edge drivers being used?

If you don’t know what Edge drivers are… just let us know and we will get you started with more info :slight_smile:

1 Like

The flood sensors are Fibaro and the door locks are Kwikset, light switches are GE (junk by the way, have to replace many of them)

As far as drivers go I will need some help with that.

Start with the community faq, it should help catch you up.

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

Could that make this any more complicted…

It is getting to the point of unusable, 2 minutes to turn lights on and off. This is both with devices that do and don’t have a driver. Some devices that list a driver give a network error when using them.

One door lock says connected yet no lock state or battery level, can’t lock or unlock it and no driver option to click on.

The other lock is off line but lists a lock state and battery level. Also doens’t work and Driver is greyed out, can’t click on it.

I just want something that works.

start here: SmartThings API Browser+

once you get it connected, go to the Devices section and locate the devices that you are experiencing issues with. Hightlight one, click on Details and take a screenshot of each details box and post them. Do that for each one. That should allow other community members to assist you better in resolving issues. My guess is these devices have automatically been migrated over to stock Edge drivers and they are causing the issues you noted. Others can point you to community developed Edge drivers that should resolve. :slight_smile:

here is open thread on kwikset locks:

and GE switches:

the fibaro flood sensors may work better with the Edge driver from @Mariano_Colmenarejo

that screen shot for fibaro shows groovy device handler. You may wish to remove it, add the Edge driver I linked above and add the switch back by Add Device : scan for nearby devices

unless other community members have better advice for you :slight_smile:

So you are telling me I have to basically remove everything and start over?

What about this switch, is this an edge driver? It has the same problem. 1 minute 45 sec for the light to respond to a command.

Here is the flood sensor

There’s no reason a garden variety GE/Jasco dimmer would be causing slow mesh performance just because it’s still on a DTH. I’ve got a mix of Leviton, GE/Jasco, and Zooz with about 75% migrated automatically to stock Edge drivers and the other 25% on stock DTHs. Performance is fine.

I’m not an expert troubleshooter but isn’t the all-zeros in the device noted as “Door Lock” indicative of a problem?

no because some will be have been migrated to an Edge driver… no need to remove those… simply switch the driver.

yes for the first one you posted for fibraro… it is using a groovy device handler… you can wait until it is migrated if you want… then change the Edge driver when it is migrated.

The other images appear to be Edge drivers below it appear to be Edge. Haven’t reviewed the locks yet

I amended my post… it was meant for the leak sensor

too many posts and comments to keep up

when viewing on a tiny, tiny screen…I am overwhelmed


of the two locks… one ss using groovy device handler, the other Edge but as noted above , it has the xeros issue so I will definitely leave that to the experts

Your “Fire Place” is on an Edge driver.

In the API Browser, the Type field will be DTH for anything using the old Groovy device-type-handlers.

My best guess is you’ve got an issue with some device on your z-wave mesh. Either a ghost device or something flooding the mesh.

You’ve posted details for a device named “Door Lock” which has zeros in a couple fields where it should not. I’d start with removing that device using general exclusion followed by deleting it. Even though the IDE isn’t trustworthy, I’d verify that the device is not visible in the IDE after removal. Then do a Z-wave repair, wait a couple of hours and do a second Z-wave repair.

Leave things like that for a day and see if responses are better.

Back in the all-Groovy days there was some chance of finding ghost devices by noting an Unknown Device in the routing field. I’m not sure what tools there are for diagnosing that problem now.

1 Like

Well neither of the locks work. The one labeled “door lock” I recently excluded it and re added it and still no go.

That one is on a DTH so possibly a remaining custom DTH? I’m pretty sure having zeros in those two fields is a sign of incorrect/incomplete installation.

What make/model is it? I don’t have any smart locks but from observing these forums for the last few years they’re among the most problematic devices.

did you also reset the lock?

  • exclude lock
  • reset lock
  • add a custom Edge driver,
  • add lock back by Add Device > Scan for nearby devices and do no choose by brand
1 Like