Hub Firmware Release Notes - 0.30.5

We’re excited to announce the release of Samsung SmartThings Hub firmware version 0.30.5. This release is a hotfix to version 0.30.3. Once downloaded, your Hub will briefly go offline as it reboots and applies the update; most customers will experience less than one minute of downtime. We will update the status page when the release is complete.

Hub Target:

  • Samsung SmartThings Hub 2015 (Hub v2)
  • Samsung SmartThings Hub 2018 (Hub v3)

Release Date: 12 May 2020 ~ 14 May 2020
Note that this release may be spread over a few days, so you may not see your Hub update the first day of the release period. We will post on this thread once all users should have received the update.

Release Notes:

Fixes

  • Change to Z-Wave functionality to accept all incoming Multi-Channel encapsulated messages regardless of the Destination Endpoint value, correcting issues communicating with certain devices.
  • Fix for a rare problem causing issues communicating with zigbee devices.
8 Likes

What was the rare problem causing the issues with zigbee devices?

That wasn’t outlined in the beta release.

1 Like

@tpmanley, is there any more info about this? There are a few people here that may need this.

tagging @slimshizn and @Tom_von_Trott1

2 Likes

The first update to 30.3 was perfect for me, with no issues or problems.

But for now, I have got problem… blue light flashing.

1 Like

I know the reason, but my hub was normal before that …
I’m just reporting and sharing by here one more issue …

And again, it must be necessary to reset the hub … bad thing

did you check your ethernet cable?

Blue (blinking)

What it means: No LAN connection, Hub doesn’t have an IP address

What to do: This is likely an internet connection issue. If your Hub is connected via Wi-Fi, try changing the Wi-Fi network or connect the Hub directly to the router via Ethernet. Make sure your Ethernet cable is securely plugged into the back of the Hub and not loose. If the Ethernet cable is snug but the blue light keeps blinking, the cable may be defective. Swap it for another shielded model. This may also be caused by strict network security settings preventing the Hub from connecting.

Of course I did, mainly my network is perfect, with no issue and nothing has been changed.
Until minutes before everything was fine, after the update, it returned that way

Silent about the rare problem causing issues for zigbee. Interesting. Also saw that this was pushed to everyone, but upon completion of said update I checked my IDE.

Last Updated 2020-05-11 9:51 PM UTC

So are beta users opted out of regular firmware updates? Effectively negating this update and fix for people who need it?

@Edu Probably doesn’t need a full reset. Just a power cycle of the hub and/or your internet equipment.

1 Like

It was in 0.30.4

Fix rare issue communicating with the Zigbee radio on the Hub V3 that could result in failures to communicate with all Zigbee devices even though the Zigbee radio is reported as functional in the IDE.

Where did you find that information? If it’s “Fix rare issue communicating with the Zigbee radio on the Hub V3 that could result in failures to communicate with all Zigbee devices even though the Zigbee radio is reported as functional in the IDE.” Why didn’t they just put the entire fix instead of being so vague?

@tmleafs

@prjct92eh2
Thanks, I tried to… twice.
I will let turned off for more time and turn on again, befor the reset.

1 Like
1 Like

The update that went to the full set of users is the same firmware that beta received yesterday. Because the two releases are bit-for-bit identical, your firmware did not update again.

1 Like

Thank you for your reply on this. Appreciated. However I still have an issue where all of my zigbee devices have dropped off since 3.03. I have rebooted, kept the hub offline for 30, pulled the repeaters, done all of the steps that are provided.

I’ve spoken to customer service and they are going to push it up a level, saying that it’s possible they are going to send it back to tell me to just delete and re add the devices.

That is not what I should be doing as if this happens again then I would be out all that time, as I am now with trying to figure out what happened.

Wanted to mention that when pulling batteries out of the zigbee devices that the light’s turn green as if it has connected to the hub. Still showing offline since my hub was updated to 3.03.

Have a look on this topic and follow the general guidelines how to resolve a zigbee mesh issue.

1 Like

This sounds right. I have a wifi hub (plume) and after I received a firmware update last Thursday my Zigbee devices slowly stopped being controllable and acting on events.
Fast forward to today… It’s affected my zwave now :frowning:

I’ve been in communication with support and the engineers while they try to track it down

Could your wifi or zigbee channel have changed and cause the issue?

On a side note, I had some zigbee issues right after the update last night. I didn’t mess with it but it seems to have resolved itself this morning.

Now if we could correct my issue with zwave since 30.3 I’ll be a happy camper.

1 Like

That was the first thing I tried.
It’s something between the hub and cloud
If I manually actuate the devices there state changes in the mobile app