Hub Firmware Release Notes - 30.3

5/12 UPDATE

This release has been hotfixed by version 0.30.5.


We’re excited to announce the release of Samsung SmartThings Hub firmware version 0.30.3. Once downloaded, your Hub will briefly go offline as it reboots and applies the update; most customers will experience less than one minute of downtime. We will update the status page when the release is complete.

Hub Target:

  • Samsung SmartThings Hub 2015 (Hub v2)
  • Samsung SmartThings Hub 2018 (Hub v3)

Release Date: 04 May 2020 ~ 05 May 2020
Note that this release may be spread over a few days, so you may not see your Hub update the first day of the release period. We will post on this thread once all users should have received the update.

Release Notes:

Features

  • Several system updates for stability and security improvements
  • Improved reliability and responsiveness of Sonos device discovery
  • Increased the number of Zigbee devices whose metrics and routes can be tracked
  • Added more Zigbee device metrics

Fixes

  • Various minor bug fixes
7 Likes

Can we get details on this? :sunglasses:

The 30.X hub firmware adds reporting of the number of messages received from the device.

2 Likes

Will this include the Smartthings wifi? I noticed mine says Connect home in the IDE firmware. I thought that the Smarttings WIFI was a V3. Can you confirm this?

This release is specifically for the Hub v2 (2015) and Hub v3 (2018) models. SmartThings Connect Home and SmartThings Wifi hubs are getting closer to sharing the same major firmware version as the v2 and v3 hubs though.

2 Likes
  • Increased the number of Zigbee devices whose metrics and routes can be tracked.
    More details on this please.
    Also, is there a maximum number of Zigbee and Z Wave devices that can be added?

Any chance this will fix some bugs in automation and Smart Home Monitor? The last 2 days my typical morning Disarm based on motion routine has malfunctioned and the siren has been triggered when it shouldn’t have when a door was first opened.

This happened to me too this morning!!! The Siren went off and my lights entered ‘Brothel’ mode, although in the ST app SHM was showing Disarmed and no push notifications were sent saying the alarm went off - all very strange.

And again this evening… looks like the system is being set to Arm stay, being disarmed in the cloud but the local instance of SHM on the hub isn’t synced causing the siren to go and the lights to go red. What have Samsung fiddled around with this time…

I hope this update addresses the worsening delays when motion automations are used.

It’s getting more and more delayed.

3 Likes

I’m really hoping this solves the delays for me as well. The slowness is getting to be out of hand.

1 Like

@SmartThings and all,

My hub was updated minutes ago even the configuration was to DON’T Update Automatically … strange, isn’t it?
Also it changed the my hub name. Too bad as it could generate a big error.

I don’t approval this method.

Unfortunately, it is not possible to refuse or defer hub updates. :disappointed_relieved:

The only thing you can set to not update automatically are individual Zigbee devices like sensors.

1 Like

@JDRoberts … I didn’t know… thanks!
So, I don’t approval but can’t do anything…its ok.
But the situation of change my Hub name is very invasive, isn’t it

1 Like

Yes, I would definitely get in touch with support on that one. That is not supposed to happen. :scream:

https://support.smartthings.com/hc/en-us

1 Like

Same thing here…disabled the alarm, came downstairs and as soon as I hit a motion detector the alarm, and lights came on, but SHM not reporting anything. Then for some reason the alarm and lights fired up about 8:00 this evening.

I am only on the Classic app, and yes I use SHM, but it was not armed in either case. For the incident this morning I had just disabled SHM and had gotten my disarmed message from Alexa (virtual switch). For the one around 8:00pm today SHM had not been activated since the disable this morning.

User with Classic and SHM for over 3 years, nothing very elaborate. About 50 devices, including virtual switches.

TG

After the update my SHM is now just hanging and won’t load status.

SHM not working here either. Alarm went off this morning, and when I tried to turn it off the SHM was not loading. Only using classic app. A few moments ago it also has a red dot (next to Smart Home Monitor) saying migration issue on my home screen and when I click it, it says loading.

Same issue, SHM not working in the Classic app after the update. The system will not switch out of ‘armed’ and the screen will not fully load.

SHM (Classic app) failed to disable via Good Morning automation routine. Mode had changed from night to day, so no failure to execute.

Too much of a coincidence following yesterdays hub update. This does question the level of basic testing, when this is stock functionality!