Hub does not support edge drivers?

Thanks. Just sent the requested information. Posting the complete CLI error message on here as well.

FYI, The CLI did not give me option to choose a hub to instal the driver to. But I get the same error when trying to install the driver on either hub that shows in the app and in my IDE

In addition. I do have a case number and was supposed to get a call back from higher level tech support within 48 hours but that has not happened. So far, everyone I have spoken to in tech support has not been able to find a solution to this issue.

I still have not been contacted by any engineering support team member and it has been a week without the ability to add edge drivers to my hub

Hi! I already replied in the thread of In order to avoid duplicating information, please, let’s continue our conversation there.

Hello Nayelyz,
For a strange reason, our Smarthings WiFi Hub does not support edge drivers anymore…We’ve started getting the BadRequestError message lately, after we’ve reset the hub for a fresh installation.
Can you please help clarify the issue?
our firmware version is: 000.043.00005.


Looks like I’m not the only one. @nayelyz please do what you can to fix this ASAP. TY.

Another issue we have is the inability to add our IKEA motion sensors to the system anymore.
It seems that the hub does not go into the ‘discovery mode’ anymore…

Are you on iOS? Bug in the current version of the app. There are several workarounds posted on the forum here.

You are right. We are on iOS.

I think Ikea motion sensors are FUBAR’d on SmartThings until this pull request is moved in

Thank you for sharing your experience, does the “BadRequestError” you get also say “Edge drivers are not supported”?

I already shared your comment with the team.

The new iOS app release ( solves the issue.

Thanks for getting back to us Nayelyz,

Confirmed it also says that “Edge drivers are not supported”.

We have the latest release of the app installed ( and still experience this issue.

Mmm is it happening only for that specific device?
Have you verified if you see the Hub’s LED blinking or get any logs in the logcat?

It’s a series of devices we have issues with.
The LED on the hub does not blink to indicate that it goes into “discovery mode”. It stays solid green.

:scream: this is weird, I made a test in the morning and it worked…
I shared a workaround when this was an issue, please check if it helps:

Unfortunately, this workaround does not work. We’ve reset the hub again and re-configure it, but still nothing.
The LED stays solid green, so the discovery mode does not trigger on the hub.


Can the team just acknowledge that something is messed up here with Wi-Fi hubs not being able to load edge drivers and confirm with the community that a fix is in progress. It has been two weeks now that I am without edge functionality on my hub when prior to 10/10/22 I was able to load edge drivers. I can pin it down to almost an exact time when things broke.

In addition, I still have not been contacted by ST engineers.

This would be greatly appreciated to update the community.


I’m sorry if I wasn’t clear before, this is considered a bug, and the team is working on a solution. As there are more people reporting it, we already escalated it.
We understand this is something you have struggled with since a long time ago, we’ll keep pushing.

1 Like

@ecobiax, have you verified which drivers are installed in your Hub? If you’re getting the BadResponseError, it can cause an issue because by default devices are expected to connect to a Driver. If there’s not one compatible with the device, then one from the default channel should be installed but it could be facing the same “BadResponseError” but I believe this won’t be shown in the logcat.
The command to check the installed drivers is:

smartthings edge:drivers:installed

To check if this is both issues are related, could you send me the following information, please?

Note: It can be over DM or an email to

  1. The email used in your SmartThings Account
  2. Access to your data:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

thanks for acknowledging. I’ll look forward to the fix.

Is this firmware update going to fix this problem?