Hub does not support edge drivers?

Aeotec version 000.043.00004. I see the drivers installed on the hub but it seems it is not selected when I check in the driver information. It’s a generic thermostat which picks a generic Smartthings Z-Wave thermostat as it’s driver.

Hi! Can you provide more details about this, please?
When you install the device, enter its details and click on “menu” (three-dot symbol in the upper-right corner), do you see the option “Driver” but when you see the details it is not “Z-wave thermostat”?

I can see the uploaded drivers on the Hub but when I try to add a generic thermostat, it seems that it’s picking the “Z Wave Thermostat” driver from the cloud and not the one that’s uploaded to the hub. Is there a way to change to an uploaded driver manually?

The “cloud” version you’re referring to is the one from the SmartThings Drivers (Beta) channel?
There’s no other channel where your Hub is registered to, if you uploaded one manually with the command package, then, you’re missing the publish/assign and install command, after that, your personal channel should appear in the channels list.

I can’t tell. The only thing I can see that it’s saying cloud in the description :

I haven’t upload any file yet. I’m struggling to find out how. I created the deviceConfig.json with the changed labels but I’m stuck from that point. Do you have any how-to information about how to import it to the driver?

Ok, let’s go back a little bit to be on the same page

When working with drivers, please avoid using the IDE because they are not supported there as it is part of the legacy platform.

What we can see in the picture you shared is that your device is using a DTH because it shows “Z-Wave Thermostat” in “Type”. The part about “Cloud” isn’t too significative because, for drivers, you will have something like this:

Most of all fields are empty, and execution shows “Cloud” when it’s actually “Local”, the values of capabilities won’t appear either (because they are not supported)

So, just to confirm, you don’t have a copy of “Z-Wave Thermostat” in your IDE, right? I mean this section:

If not, despite the driver having a generic fingerprint, it is not recognizing your device which is weird…
Do you know the device’s fingerprint or can you provide more details about the brand and model, please?

About this other conversation, I’ll reply to you in that thread:

This is what I have done. I’ve selected it from the list of drivers found at | create new driver handler > from example > Z-Wave Thermostat.

Hi @nayelyz,

I’ve added another hub (0012) and try to install a driver but getting this error :

Error: Request failed with status code 400: {“requestId”:“CB7B01B0-1B65-4A20-9D7F-41C8D5334605”,“error”:{“code”:“BadRequestError”,“message”:“Hub (0012) does not support edge drivers”,“details”:}}

It’s a brand new Aeotec V3. It’s not showing firmware version the information page.

That is strange, have you tried restarting the app?
You can also see that info in the IDE, or I can check that for you, in which location do you have this Hub installed?

1 Like

It’s working now! No idea what caused it.

1 Like

If you tried when you recently added the Hub, it might have been in the process to get the latest firmware update, remember drivers are supported since version 38, so if it had a previous one preinstalled, that could have caused the issue.

Glad it’s working now :smiley:



I am also facing the same issue currently.

Error: Request failed with status code 400: {“requestId”:“6AD6BEA8-683E-4008-B0CD-51AC3973A6A0”,“error”:{“code”:“BadRequestError”,“message”:“Hub (Hub) does not support edge drivers”,“details”:}}

Welcome to the SmartThings Community, @Hwa_Hwa_Ong!

Can you share the Hub model and its firmware version, please? Edge drivers are supported since version 38.

I have a new Aeotec Smart Home hub:

When i click on ‘Driver’, i don’t see any drivers.
So far, i have only installed a few Fibaro devices, and i don’t see the driver option for any of them either.

Any ideas?

You won’t see any drivers until there is a driver already on your hub.

At the present time, we are still in the transition period, so most people don’t have edge drivers unless they either subscribed to the beta channel or they downloaded a custom edge driver.

The production edge drivers will start being downloaded to hubs in the next few weeks, and then roll out gradually over the next couple of months.

So it’s not surprising if you don’t see any now.


This transition sucks. I week ago I was able to load an edge driver on my ST WiFi hub. Today I had to reset and re-add the hub to my location. Now I can’t load any edge drivers on the hub. Get the same error as others. Hub does not support edge drivers. WTH Samsung!

Hi, @Its2loud, Can you check the current firmware version used by your Hub, please? The one on the screen above belongs to the Wi-Fi Router
There are some instructions about it on this post:

@nayelyz Thanks for your reply. This is a very confusing situation indeed.

When I open my app I show two hub devices. One is the apparently the “Router” and the other is the “ST Hub”. This is thoroughly confusing and I don’t remember this being the case prior to 10-10-22.

This is my “router” firmware

This is the “Hub” firmware.

The problem it seems is that I have devices connected to both of these, which shouldn’t be possible. The devices also show as online.

I can only control the devices associated with the “Router” but when I look in the IDE is see two active hubs

This makes absolutely no sense to me. I cannot add edge drivers to either one. But WHY on earth would the app be showing TWO hubs as being active in the same location. Thanks for the assist.

BTW, I’m not getting a prompt to update the firmware on any of the devices.

Just for grins. Here’s a screen capture of the “Hub” that shouldn’t be showing any active devices since I had reset ALL my hubs prior to re-adding them back into the app.

When I add in any new devices it adds them to the “Router”

Soooo, what’s should be the correct setup here? One Smartthings Wifi Hub with Smartthings turned ON?

and one more thing. If I tap on the “Router” and go into the MANAGE SMARTHINGS HUB on the app and the tap the three dots in top right for “information”. This is what I see. No firmware version at all

My app shows BOTH devices. As you can see here.

This is a very messed up situation that I hope can get resolved very soon. Thanks.

mmm this is strange, I’ll open a report for the team to check what’s going on in your case.
To do so, please provide the following info to

  1. The email you use for your ST account.
  2. Access to your account’s data:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  1. Replicate the issue but this time install the driver from the CLI, this is to get the complete error message.
smartthings edge:drivers:install

The CLI will prompt you to select the channel, driver and Hub, so, just type the corresponding number that belongs to it in the list and hit enter.
4. After replicating the issue, please send the Hub’s logs through the IDE:

  1. In the IDE, enter “my hubs”
  2. Enter the corresponding Hub and go to “view utilities”
  3. Click on “send” below "send hub logs