SmartThings Community

How to Update Smartthings Hub (2018) Wifi Settings?


(Anton Yukhymenko) #21

So, it’s mid January now and still no way to update WiFi on this thing? How it’s even possible, that you rolled it out without that major feature at the first place


(Patrick) #22

See this article for how to change wifi config: https://support.smartthings.com/hc/en-us/articles/115002084806-How-to-add-a-SmartThings-Hub-in-the-SmartThings-app (scroll down to “Change a SmartThings Hub’s Wi-Fi network”.)


(Allan) #23

Why is this a manual process involving powering down the hub and holding in the reset button??? It’s 2019… Are you saying there’s no way to just simply change the Wi-Fi settings through the app still?


(Patrick) #24

Huh, I didn’t actually notice that part. You shouldn’t need to as far as I know. You should only need to hold the “reset” button for a few seconds to re-enable the hub’s setup mode. (Note: this doesn’t actually “reset” anything, it is just how we make sure whoever is trying to change the wifi settings actually has physical access to the hub.)

I’ll ask around to see if I can figure out what’s up with that instruction.

Edit: Nevermind, the hub being offline is a requirement for that menu option to be available in the app. I don’t know why and I don’t have anyone I know who I can ask about that. :confused: Sorry.

Although I will still say, if your hub is already showing as offline, there’s no need to power cycle it.


(Jay) #25

I released the pin as soon as the blinking yellow started. I was able to get the hub working but the displayed devices were unreachable and had to be all redone. Smartthings really needs to have a configuration backup feature, not really a professional system until then.


(Michael Leonardo) #26

Patrick, why is this option grayed out in the new app. I’ve tried everything but it stays grayed out and not accessible.


#27

Opposite of the standard IT question…

Is it unplugged from power?


(Brad) #28

Nova5 is right. I do not know why but the Hub has to be in a “disconnected” state for that option to be accessible.


(Al Rosen) #29

I’ve followed above directions to change Wifi network since I am only able to connect via ethernet. However, I have a problem that I can only connect for ~ 1 minute then hub reboots - I loose connection- then reconnects and the cycle repeats.
I am able to get to 78% of the setup and I am stuck at verifying or verifying code depending on whether manually entering serial number or scanning QR code. There is obviously something preventing access to the wifi .Under saved wifi I can see st-hubv3-396 which was saved by SmartThings. Please help. I have spent several days with constant rebooting of Hub v 3 & connecting.

Thanks,

Al


(Brad) #30

This sounds like a different issue. The hub may need to be replaced.


(Al Rosen) #31

Brad:

Since the hub can connect, all the logs etc are viewable. Did you look into the beta “ backup scenario” so if I need a new hub I would not have to start from scratch. It took me a tremendous amount of time to get to where I am and the only thing that I really did was loose power for a while to the hub and then all was lost. Since everything was working perfectly before, it sound more like a software thing. I would think someone familiar with how the updates & connections function for both wifi & Ethernet, that someone should be able to figure out with the “clues” I have given, esp since there are times when the hub connects. For instance, on my phone under saved wifi is hub information st-hubv3-396. If this phone was rooted I would mostly likely have figured out why I amnot connecting with wifi, etc

What do you think??

Thanks,

Al


(Paul Osborne) #32

Hi Al,

I looked at the logs from your hub a bit and recommended a hardware replacement as what we are seeing is that the Wi-Fi driver is failing to initialize the Wi-Fi radio. The errors from the driver are pretty opaque and the system ends up rebooting as, at present, there is a watchdog monitoring processes like the Wi-Fi supplicant (userspace helper for managing Wi-Fi client operations) that eventually try a reboot of the hub as a recovery step.

Here’s a few things I would be interested in having you try:

  1. Confirm that you are using the provided power supply rated at 5V/2A. If you are, we could try a different 5V power supply with similar current rating. We have seen that in some cases if a power supply is provide insufficient current it can result in internal USB enumeration issues that could cause the Wi-Fi module to not be detected. If you previously used a V2, it’s power supply should also be 5V/2A rated with the same barrel jack connector.
  2. Try disconnecting power from the hub for several minutes and powering up again. This will ensure that the power rails to the Wi-Fi chip are fully off for a bit (the reboot from the watchdog does not have full control of the power rails to the Wi-Fi chip, just the enable lines).

If neither of those things work hardware replacement (possibly with the failing unit sent to engineering for analysis) is probably our only course of action.


(Al Rosen) #33

Is there some way of me doing something to " removing wifi information from hub / SmartThnngs app " or doing something that maybe would allow just the ethernet connection to stay connected. I could live with this since I have put the router & hub on UPS so should not have any problems with loosing power and causing this problem. It is still unusual to me that everything was working perfectly & I had used both wireless and ethernet and did not have any problems.
The version 3 hub is my first hub . The problem is that the SmartThings power adapter I think has a 1.35 mm male plug which is not too common. Were yo considering sending me a new power adapter to try?

Al


(Paul Osborne) #34

That was just something to try if you had one available and is likely not the problem. Support will probably move forward with replacement. Right now the problem doesn’t appear to be any problem with the Wi-Fi configuration but with detection that parts of the hardware not working properly resulting in reboots that attempt to recover operation.

I talked over this case briefly with @Brad_ST who will drive things on the support side. On the engineering side we agree that this is odd and will be working on root cause analysis. Part of that root cause analysis may include getting RMA’d hardware back from the field for further analysis.

Were you able to try removing power for a period of time to see if this recovers anything? Apologies if you already tried this.


(Al Rosen) #35

Paul:

I have removed power for minutes and also for hours and it makes no difference. The reboots as you know are every minute or so. As asked before, if you feel it is rebooting because of attempts to recover wifi ,is there no way to “ shut this attempt to look for wifi off” or do something when connected with Ethernet to prevent the reboots . Also. Brad was looking into some sort of backup or exporting of setup so that replacing my hub with new hub or doing factory reset on my hub would not be so difficult for me since I am not looking forward to having to redo my entire setup. Also, if you have any additional info or links that you could email me about all the things that need to be done when replacing a hub I would appreciate it.

Thanks,

Al


(Brad) #36

If you continue with customer support via support@smartthings.com or 1800-Samsung, they are best equipped to help. I apologize if I indicated otherwise but there isn’t a backup at this time.


(Paul Osborne) #37

No, there is nothing you can do to prevent the watchdog logic from rebooting the hub as it is part of the firmware. As Brad notes you will need to work with support on hardware replacement.


(Michael Leonardo) #38

Regarding standalong Hub v3, I spent 30 min on the phone with tech support and they confirmed there is currently no way to switch wifi networks, through soft reset or other means. The instructions being provided where you’re supposed to go into the app and select add hub and scan QR code, are apparently for the new router/hub combo unit. I’ve tried several times with tech support but the option to change the network is grayed out in the new app.

Is there anyone that can confirm a wifi network change on standalone hub v3 without doing a hard reset?


#39

Yes, link above in psbarrett response.


rtThings-Hub-in-the-SmartThings-app

Read all the way to the bottom of the link supplied above


(Michael Leonardo) #40

I can 100% confirm that doesn’t work. I tried 4 times with scanning QR code or entering serial number. Support also went to higher level tech to confirm that there is currently no way to do this unless you have the beta software.