Help with Setup SmartThings v2

I am having some issues with setting up a Samsung SmartThings Hub v2 2015 STH-ETH-250

Basically it has no firmware but is connecting fine to the SmartThings app it also is not factory resetting the yellow light never blinks or turns solid.

In the Samsung SmartThings IDE when going into the hub the firmware is blank. :confused:

Any help would be great!

Edit: Basically this is all coming up because I needed to connect a ZWave Lock and the SmartThings hub is not even finding it or acting like it’s trying.

when you perform the factory reset… have you removed the batteries from the hub if using them?

what is (was) the color of the led light on the front of the hub after adding?

2 Likes

in addition to @jkp 's post above, we had performed a factory reset a while back but were a bit too impatient on the lights changing color, so we had jumped the gun and reset again. The solution was to assure it was connected via LAN and that we gave it more time to cycle through the various stages.

Hi thanks for help! Yes I tried removing batteries and then doing the factory reset but I had the same results. After plugging in the power while holding down the tiny red button on the back the first light that comes up is a solid blue then after a while it goes red then the lights disappear entirely I have held it down past that for easily 60+ seconds and it just cycles through those same colors.

tiny red button?? the v2 hub has the tiny slot/hole where you insert a pin of some type to reset. Can you provide the model number of the hub?

Model: STH-ETH-250

Sorry that is the same thing the tiny pinhole next to the power that you have to use a close pin to reach. I have tried a couple different methods of factory resetting but none produce that yellow light. Nothing online that I have seen have shown a similar situation of it not showing any firmware so I’m concerned about that

1 Like

You may want to contact ST support about missing info in the Advanced Web App.

The missing yellow or blinking yellow has been reported by a few users in past few weeks. I haven’t seen anything about a resolution. Is it an app issue or back end issue is unknown.

If you don’t get it resolved and you recently purchased it… you may want to consider returning it and getting your money back.

3 Likes

Just for clarity: there is no “SmartThings IDE” anymore. That was discontinued with the old architecture in 2023.

Under the current 2024 architecture, you should see your device details at the advanced page of the official Web UI to your account:

My.smartthings.com/advanced

2 Likes

Correct that’s what I mean sorry! I’m catching up with the terms and community. I have had the thing in my storage for awhile.

3 Likes

How long was it in storage?

Let’s just put it this way I have had the device since I purchased it at the store back in like 2015… it has never been installed till now.

That clears up a few things. Probably safe to say you will be unable to use that hub but contact ST support first. The reason is… ST made a change in either 2017/18 (forget the exact year) where they sent out a firmware that adjusted hub boot up and also pointed the hubs to a new server that hubs reach out to for firmware updates. If your hub never received that one firmware update…. It has no way to contact the new server and the old one is no longer available at this point. Yikes!

3 Likes

That actually makes sense that is why I was concerned about the no firmware and no real logic happening in the hub. I will contact ST support and let everyone know if they were able to help!

1 Like

I believe it was firmware version 23 which made the server switch and of course… that thread is no longer available. It was posted in 2018.

The boot up change I mentioned was 17 and not relevant to your issue. Time has a way of blurring event timelines.

3 Likes

Well I’m in queue for internal support with the SmartThings Support team so if anyone can make a change to help I’m guessing it be them.

2 Likes

Yeah so as we suspected the device is just too old and it seems like the ST supports only recommendations at this point is to replace it.

So I’ll most likely investigate what zwave hub options for a smart lock I have.

if you are going to stay with the ST platform… I would recommend the Aeotec Smart Home Hub for $130 at Amazon. There is another vendor that offers it for around the same price. As I was pointing out to someone else… don’t get the ST v3 hub as the price will likely be $200 or higher if going through Amazon Marketplace. The Aeotec and ST v3 hub are basically the same hub but with a different branding.

The ST Station is not an option has it does not have a z-wave radio.

With Prime Dy set to arrive in July, it “might” be possible to get it at a lower price. That is you are willing to wait for 2 months at the time of this post.

2 Likes