Can not get my STH-ETH-250 to Factory Reset

This is my 3rd STH-ETH-250 Hub. Each are at different locations in the same Samsung account. I use them to control my door locks.

For the life of me I can not get this STH-ETH-250 Hub to connect any device or to Factory reset. I’m on Kauai and don’t have time to order a new one so I’m hoping this one isn’t defective.

On my Florida property I remember I had to Factory Reset this sucker and then it started connecting devices.

This one I set it up but just can’t get any devices to add. It says it’s connected in the cloud…but just not adding anything so I figure I would factory reset.

But following many youtube videos and instructions it just doen’st do it. having power in and holding the rest pin and them unplugging and plugging back in and holding for 30 sec… it never flashes yellow like I see everyone else doing. It acts like a soft reset.

If anyone has any suggestions I would appreciate it. I have a version 3 at home and I’m about to have my wife spend $100 to overnight it out here but would love to figure this out.

I appreciate any feedback.

have you tried removing the batteries when resetting?

what firmware version is showing for the hub?

Yes I have the batteries out… the firmware… is that the same as the controller version? 2.1.21-3

not same as controller. it should be listed above the controller version. near the top of that screen.

That’s what is strange…nothing is listed …when I got to the information I see the Hub name and controller version at the bottom… the rest is a big blank spot. I’ve also noticed that z-wave utilities is not an option under this hub name but is on my other 2 hubs… Something wrong with this hub or it needs a firmware update maybe?

this is where i need to direct you to contact ST support. there was another user yesterday reporting the same situation. best advice is to call support and speak to someone directly. if you get the run-around, ask that is get raised to a higher level of support because chances are the 1st line will not have any answers for you. by run-around… they will probably ask you to reboot, uninstall/reinstall your app, etc.

my guess is with ST getting out of the hardware for ST, a batch of much older hubs were found in a warehouse and being sold. just speculation on my part. could just be a fluke with all the recent changes going on with the ST backend.

Thanks for your help… I’ll figure out how to contact them…

I made a video showing what I’ve got going.

@heyday I don’t know where you get this plug and unplug method for reseting a v2 Hub, that is for the v3 Hubs.

SmartThings Hub v2

  • Press and hold the red recessed button the back of the Hub for 30 seconds. When the LED on the front switches from flashing yellow to solid yellow, release the button.

Note: make sure the Hub is plugged in with the included power and Ethernet cables. Do not disconnect the cables.

Odd enough someone posted a similar issue just a day ago…

Thanks @GSzabados . Yes that was actually the first way I tried to reset. but all it ever does is cycles between solid Blue to Solid Orange. Maybe it’s yellow but it never flashes. I’ve probably tried that method 10 times now. Super strange. Thanks for the feedback

I replied in my thread, but yes, same thing I’ve been going through with two old stock v2 hubs that were powered on for the first time this past Friday. I have a case open that is supposed to be escalated and so does my neighbor. I’d call and open a case, it will take about 30-40 min for them to realize it needs to be escalated and then they will get you to send log files using a contact form.