HELP - Androd App does not fully interface with SmartThings Cloud

Phone: Samsung S20
Android Version: 13
Problem: Interaction from App to SmartThings Cloud does not work. Cloud to App appears to work (i.e., if I turn a device on, the app will reflect this).

  • App reports proper on/off state of switches (controlled elsewhere).
  • App is UNABLE to Control Devices
  • App getting list of Supported Devices goes into retrieve loop (icon rotating on screen). Same is true for adding devices.
  • Non-SmartThings Hub access via personal access tokens also impacted similarly.

Fix Attempts:

  • removed and reinstalled app. Nil impact.
  • deleted all Personal Access Tokens used by other hub integrations.

Assistance appreciated.

have you tested between cellular only and WiFi only?

Just tested. Same result.

More testing on tokens. After deleting all, I recreated one of my Tokens for SmartThings / Hubitat (using my driver set that worked for over a year). Did full authorization (as a precaution). Get the following error message:

[status:ERROR, httpCode:408, errorMsg:Certificate for doesn’t match any of the subject alternative names: [*]]

Yes. Using a Hubitat driver that has worked for over 1 year without any issues. The token is not being accepted and unless the API changed the last few days, it should still work. (API documentation has not changed in this area.)

But the issue is also with the Android App - I think they are related (or a weird coincidence). Therefore the mention here.

From the two item, it appears like my SmartThings App access has been limited to read only for a device status (i.e., can not modify a device state). But the app gives no notification or status related to the failure - just churns for a few minutes without doing anything to change the device state.

(I am thinking of the nuclear option of full uninstall and reinstall of SmartThings (remove then re-add cloud account). Maybe this will fix the issue.)

which hubitat driver?

Downloaded to my gitHub test folder:


(this version allows me to get the full version of capabilities definitions (especially custom that are not documented in the API documentation).

I am having similar issues with the HubiThings Replica integration.

It may be my account has been messed up some how. Do not know.

1 Like

Where has * sprung from?

Do not know. I think from SmartThings direct. It is part of the httpGet response - resp.errorMessage

I’d be digging around that as the root of the problem. Not sure how though.

I have placed a ticket in to the Help Desk. I will come back with results.

PS - I can control via the SmartThings Web app. Just not the Android or other apps (that may use tokens???). May be that somehow access has been denied for controlling devices.


Issued Resolved during personal troubleshooting.

Further Troubleshooting: Disconnected phone from wifi so that it used only Cell data. SmartThings worked as expected.

Investigation: Router (ASUS RT-AX3000, last firmware update: Dec 2022) showed no abnormal security setting and had not been modified for several months.

Final FIX: REBOOTED router. After reboot, reconnected phone to wifi. SmartThings worked as expected.

1 Like