Google Home cannot connect to my Smart things. (ikea lamp)

I have a UK V2 Smartthings Hub
I have an american Google Home and an American google home mini

So - my hub is on graph-eu01-euwest1 and not on the american one (I’m mentioning this cause this might be an issue later on?)

  • I managed to add my IKEA Tradfri bulb to Smarthub and controlling it thru the smarthub.
  • then I linked Smartthing to Google Home thru the app and it allows me to select the bulb with a checkbox (See screenshot to see lightbulb show up
  • then I’m being thrown back (as it’s supposed to, I’m guessing) to the app where I can add the bulb to a room but there the tab stays empty and throws this error : Couldn’t retrieve the settings , check your connection (see included screenshot) link to screenshot

In my google home app under “linked services” , it shows the Smartthings / Samsung Connect correctly, but it says “0 devices”

See if any of this helps…

Google Assistant / No Devices Found

and this part that’s important…

Disconnect SmartThings from Google Assistant

Hi , thanks for chiming in.
Tried re-installing , re-connecting. Upgraded Android (cause that was needed, it seems).
Still same result: able to link Google Home to SmartThings/Samsung Connect service , but it still shows 0 devices, even tho I’m able to select my IKEA light when I’m authorising the Smartthings connection.

Thing that’s till weird is that I still keep on getting “The Google Assistant” and not “Google” like you have, as a smart app.

That “The Google Assistant” thing seems OLD (january 5th 2017. I’m guessing a lot of things have changed since then)

Would there be a way to force this to be chosen over “The Google Assistant”, provided this would solve my issue ?


Yeah, it gets a little tricky. Make sure this is set to allow all devices as below under the GA SmartApp. If disallowed it will give you a list of devices that GA can access… This could be a good clue, tho.

If that doesn’t provide any better results, I would suggest deleting Google Assistant from the SmartApps in the ST app. Then you would want to Link SmartThings thru the Google Home app (same one you use to set up Google Home).

Of course this could be a UK V2 Smartthings Hub and an American Google Home issue or the UK shard as you mentioned…

“The Google Assistant” does not have this “Allow access to all devices and routines” - option in the Smartthings App. In fact , it’s only “option” is Uninstall…

Also already deleted The Google Assistant from the SmartApp and relinked. Same result :frowning:

Lars Finander (from Smartthings) confirmed that UK V2 Smartthings and American Google Home shouldn’t be the issue here…

I edited my response above to include…

Of course this could be a UK V2 Smartthings Hub and an American Google Home issue or the UK shard as you mentioned…

You are trying to Link ST thru the Home app, correct…

I am indeed trying to link ST thru GH app.

in GH app : Hamburger Menu on left > Home Control > 3 dots -menu on top right : “Manage Accounts” > Add New: Smart Things / Samsung Connect > It then opens a browser (chrome) to graph.api.smartthings . com and there I see my hub and my IKEA light which I can authorise.

Fun fact : when I go to I do not see my hub (“You don’t have any hubs yet.”)
When I go to graph-eu01-euwest1.api.smartthings . com I see my hubs.

But again - in the regular flow of adding Smartthings in GH app, I do get to see my hub and Ikea light , even if I’m on

Ok, first shot in the dark: same email for both ST and GH?

If I recall correctly, when I had this issue I had to find the correct combination for it to work. Following the instructions below, I unlinked ST thru the GH app, deleted the SmartApp from ST app, then Linked ST thru the GH app in that order.

Disconnect SmartThings from Google Assistant
To properly disconnect SmartThings from the Google Assistant, you need to both unlink your SmartThings account from either the Google Assistant or Google Home app and delete the Google SmartApp in the SmartThings app.

Note: If only one of the above is completed, your Google device will no longer accept voice commands for SmartThings devices and cannot be reconnected until completely disconnected.

Also, if you have shared your SmartThings Location with any other users and they have connected their Google Assistant…

edit: corrected details

I’m using same email for both ST and GH, yes.

I removed Google SmartApp in SmartThings APP
I unlinked Smartthings in Google Home App
Linked Smartthings in Google Home App

same result :frowning:

Try this in order…

Unlink Smartthings in Google Home App

Uninstall Google or Google Assistant SmartApp in SmartThings APP

Link Smartthings in Google Home App

If that doesn’t work, I’ll try to replicate the issue when I get to the house.

Tried in that order, altho after unlinking Smartthings in the Google Home App , I no longer have to uninstall anything in the Smartthings App, cause after unlinking in google home app, “the Google Assistant” has also “uninstalled” itself in the SmartApps list in my Smartthings App.

thanks so much for your continued support in trying to solve this thing

I may be mistaken but I thought you had either Samsung Connect OR SmartThings. I understood that they won’t work together (at the moment, but will when all these new changes are brought together). I am sure I read this somewhere. I also remember my Assistant saying no devices, but my Google Home still controlled my lights switches etc… And when I used assistant on my phone it all still worked. Also if you don’t put the Tradfri thingy (can’t think of the name) in Device Handlers it won’t find the bulb. If it can’t find the bulb then you can’t send commands to it.

From Google Home App , I can only link “Smartthings / Samsung Connect” that’s the name of the service I can link to… there’s no option to choose just Smartthings , or just Samsung Connect.

0 devices , so I can’t allocate them to a room in the Google Home App and I also can’t control them thru GH (I tried).

It seems I’m the only one on the planet with this unsolvable problem.

Piling on something else that might be of interest:

My Google Home located in the kitchen is on 5GHz wifi
My Google Home Mini located in the bedroom is on 2.4GHz wifi

Not sure if that matters. My phone is on the 2.4GHz right now , but that changes (I’m using Google Wifi - so a mesh network that lets me slide onto the most optimal network based on my position on the house)

I’m stuck on the “connection” part of my error warning… maybe I’m looking at this too literally.

I just looked on mine.
Under Devices I have the following.
1st Category is Assistant. In there I have Chromecast Audio and Google home.
Under this I have a Group of Icons representing the The Things that each of my devices are Available too.
These are in order as follows
The Home speaker. My Phone. 2x TV’s and finally my watch.
Then Under these are
2nd Category I have same as you “SmartThings/Samsung Connect” in there are my 44 or so Home control devices.
As Samsung Connect doesn’t support my My MiHome (energenie) sockets or my Tradfi Bulbs ( or didn’t last time I checked what Samsung Connect supports) I have not set it up.
I have changed all the settings in the App (stopping notifications, and blocked the other stuff) as the app can’t be stopped or uninstalled.
So I am only using the ST app and nothing else.
Is this roughly what you are seeing?
I have just reread your post. So you can control the light via SmartThings, ie: on,off,dim etc! but it just won’t work through “Google Home Hub” speaker via voice control?

That would be correct.
I can control and see the Tradfri perfectly fine through the SmartThings APP, but when I link my Google Home app with the Smartthings HUB I get to select my HUB, I can even select my Tradfri bulb to Authorize it being used by GOogle Home, but then it all ends. After the Authorization screen I’m being thrown back into the Google Home App, I get the warning “Couldn’t retrieve the settings, check your connection” and I’m left with 0 devices I can control.

No that shouldn’t matter, you are still on same network. Mine is like that, I have some devices on 5 and some on 2.4.
I also had it say “Couldn’t retrieve the settings , check your connection” several times while setting up rooms and devices. Many times it had actually worked but it still popped up saying that.
On one occaision it crashed out and I had to uninstall and start from scratch.

Problem is that I get that “Couldn’t retrieve …” thing every single time. I haven’t been able to get my Tradfri light working in Google Home once. Not even once …

And I unlinked, re-installed, multiple multiple times.

Ok, when you click to Authorise SmartThings does it open up your browser and take you to an authorisation page that way? If it does, I had a problem doing that with Chrome browser. I read somewhere it was causing problems so I installed Firefox browser did exactly the same using that instead of Chrome and it worked first time. Not saying it will solve your problem but it worked for me on many different authors on ST, where Chrome wouldn’t.

It indeed takes me to that page , and I see my Tradfri there.
I also tried changing to Firefox, but same end result.