SmartThings Community

Problems integrating Smartthings with Google Home


(Seth Rosenberger) #1

Hi,

I just tried to connect Smartthings to Google Home and it seemed to work. It shows connected on both Smartthings and Google Home app. The problem is, I don’t see any of my devices in Google Home and can’t control them.

What could be the issue? I am connected with my Samsung account in both apps and I have already tried unlinking and relinking.

Thanks for any help.


(Bryan) #2

In the Classic app, go into the Google SmartApp and insure the toggle button to "Allow Google Assistant to access all devices . . . " is turned on.


(Steve ) #3

As above.
And try saying ok Google sync devices.


(Seth Rosenberger) #4

Thanks for the suggestions but I downloaded the classic app and it is checked. The sync voice command didn’t do the trick either.

Any other possible solutions?

Thanks again


(Steve ) #5

So what do you see in the Google home app ?
On the home page and in the settings for adding Smartthings.
Can you post screenshots.


(Seth Rosenberger) #6

I see no trace of the Smartthings on the Google home Home screen. I took a screenshot of the top of my home screen.

If I try to add Smartthings again, it shows a list of connected apps and Smartthings shows up and shows 5 connected devices… I just don’t see any way to access those devices and add things to rooms. Screenshot attached.

I have also added a screenshot of the Smartthings app showing Google as a connected app.

Am I just missing a super easy step for accessing the devices?

Thanks

PS I need to do 3 posts for the attachments

since I am a new user


(Seth Rosenberger) #7

Screen 2


(Augusto Geovanny Martínez Cortés) #8

i see you have several cuby devices…any idea for controlling directly on smartthings app as a thermostat? thanks


(Derek) #9

Smartthings itself does not show up in the Google Home home screen, just the devices you have integrated into Smartthings (lights, sensors, switches, etc.). This allows you to control your Smartthings integrated devices through Google Home and Google Assistant. I see you have a room labeled 1st Floor with 1st Floor Lights assigned to that room. That should be either your smart bulbs or switches you have in Smartthings, correct? If you scroll down to the bottom of the Google Home home screen there should be a section labeled “In Your Home”. All of your Smartthings devices should be in there. From the Google Home home screen select settings then scroll down to “Rooms, Groups and Devices”. From there you can select the room you want to add devices to and then add them to that room.

I recently added a few new devices to my home and they didn’t immediately show up in my Google Home. I ended up going into the Smartthings Classic app, unchecked the toggle button that @Bry mentioned earlier and then turning it back on. Everything, including my newly added devices, then showed right up.


(Seth Rosenberger) #10

Sc

reen 3

So none of the SmartThings devices are showing up as you described it. All I see are the lights and thermostats that are either connected through a different Hub or are connected with the devices themselves. If they are supposed to display on the homepage they are definitely not there for some reason.


(Derek) #11

Gotcha. Yeah, that does seems a little weird. You do have the Google smart app installed in Smartthings, right?


(Seth Rosenberger) #12

It shows as connected


(Steve ) #13

It seems like it’s added to Google ok as it’s showing the amount of devices like what mine does.

But I think you need to check your Smartthings app.
Try using the SmartThings classic app and going to SmartApps and clicking on Google and manually selecting the devices instead of leaving it on allow all and then saving.

Then go back to Google and ask it to sync all devices or even reboot your router and your Google device.
Did you have to do the account migration on Smartthings from a Smartthings account to samsung or have you always used the Samsung account maybe it’s something to do with that.
I’m guessing you have tried detecting everything and doing it again.