Google Assistant / No Devices Found


#1

Hello, after many searches I cannot find a solution to my issues with the control of ST using Google Assistant.

I setup Google Assistant and it works as expected. When I attempt to authorize devices via the Google Assistant menu, it shows me a list of my devices, but when the authorize process is done (after checking all devices), it just shows zero devices.

Then, in the ST app for setting up Google Assistant, it has a screen with greyed out test saying the Google Home app has to be installed and to select “Home Control” from that app. I installed Google Home but it has no such "Home Control from the menu??

Any help to setup Google Assistant for the control of ST would be very helpful.

I am using a PIXEL with the latest firmware.

Thanks.


Google Home cannot connect to my Smart things. (ikea lamp)
(Chris H) #2

Lots of good setup related info here:


#3

Thanks for the reply @Hydro .

This is the set of instructions I used to setup Google Assistant with ST but it is not working? Specifically, after completing number 11, I see the devices “syncing” and being authorized (as confirmed in the ST IDE), but when the app is done and returns to the Home Control page it shows 0 (zero) devices authorized and “you haven’t added any devices yet”?

I’ve tried everything I can think of (e.g. uninstalling, reinstalling) to no avail. I believe the interface between ST and GA is broken and fails to complete the necessarily actions to authorize devices…

  1. Choose your SmartThings Location in the From: menu
  2. Tap Authorize
    All devices and Routines from this Location will be authorized

(Bill) #4

In the hamburger menu you are not seeing this?


#5

@bne

Bill - Thanks for asking. I am seeing the Home Control, but I have to drill down a bit further to see it. To complicate matters, there is a drop down asking if I want Pixel or Google Home. I made a short video so you could see. In doing so I noticed something I had not seen before. In the “done” screen, there is a flash of text at the bottom of the screen which says “couldn’t retrieve the settings check your connection”. I suspect that is my issue but I have no idea which connect it is referring to (I have a good internet connect and the app is authorized with ST in the IDE)?

Hopefully you or someone will see what I am doing wrong in the video.

Really appreciate the help.


(Bill) #6

In watching your video I notice some differences from mine. I am on Nougat and from your first post, I assume you are running Oreo. It could be a specific issue with Oreo, but let’s try a few things first.

Going back to the ST app, you should see Google under Automation/SmartApps…

Under Google from that screen you should see this…


#7

@bne

Thanks again for your time and help.

I think Oreo is correct.

Oddly, I do not have “Google” show, but Google Assistant. It’s the following screen that perplexes me because the described actions in the Google Home app (which I have downloaded) do not seem to exist?


(Realy Living Dream) #8

Go back into GH app & disconnect ST & then reauthorize it again. The connection issue could be connection between the clouds. I remember having a real PIA trying to get ST, Hue & Harmony accounts linked to GH. Once I did they have been fine. It was all through the GH app though.
On the bright side Google has finally distinguished between lights and outlets, so now " turn off kitchen lights " does not also turn off the waffle maker and refrigerator.


#9

@RLDreams

Well I am grateful for your prompt to give it a try. GH doesn’t show a connection to ST. But your message caused me to think it through a bit (i.e. what the linkage is). So I went to Google Assistant where the linkage and authorization is to ST. Figured I’d try it again, and this time it worked !

I noticed the authorization pages are all completely different as compared to yesterday. The only thing that has changed since yesterday is an Android update which must have corrected whatever the issue was.

Anyway, thanks again for your reply and thanks much to @bne and @Hydro for the help!


(Realy Living Dream) #10

Glad you got it working, I meant the Google Assistant app.