Ikea Tradfri Devices in Australia?

I’m in Australia and purchased a few Ikea Tradfi globes. I’ve got a smartthing hubv3. I’m able to add the devices, but when I click on them they all say “Can’t connect to device. Check device and try again”. I’ve connect to my google home account and control the light through there, but not smartthings.

Try to reboot your Hub. If the problem still exist after that, then please post here your type of mobile phone and version of the operating system, and the app’s version number.

Hey Mark,

I’m also in Aus with the v3 hub and many ikea bulbs/remotes. I never had any problems connecting mine. Perhaps delete them and then reset the bulbs (toggle power six times) and then add them back in? If you have them working on google and not smartthings that tells me you might be using the ikea hub? which I don’t have any experience with, I connected my globes directly to the smartthings hub.

Definitely using the Samsung smart hub. Tried restarting the hub and adding the devices with no luck. They show as being added and when I go back to click on then, it comes up with the error.

I’m using a note 10+ with smartthings app version 1.7.44-22. The hubs firmware is 000.028.00012

Hmmm…that is unusual. I would be curious to see what your IDE looks like. Have you checked in there to see what it says about the device status in there? There’s a field in there called ‘next hop’ which I would be curious to see and also to see if it’s offline, when it last connected, etc…

Do you have secure mode turned on for zigbee? Mine is turned off…don’t know if that could affect it.

Thanks mate. Not sure how to check IDE or find the status. I did have secure mode on. I turned it off and tried pairing and with no luck.

I’ve been testing the 5 button remote. Seems to happen on all the Ikea devices I bought though.

login to https://account.smartthings.com and see what is assigned in the Type field for each device.

1 Like

Thanks for that! It’s showing as online through the web portal.
Next Hop [Philips Hue White (369D)]

  1. delete the network ID from your post
  2. Do you have philips hue bulbs connected directly to your SmartThings hub?
  3. What does the Type field say?


I have 1 philips hue bulb connected.

Type field showing as Ikea Button

I’m leaning towards it being the hue bulb not repeating the signal properly or some interference in your zigbee network. Try turning off that hue bulb so it isn’t hopping through that, connect the ikea bulb or button as close to your smartthings hub as you can and then see if it stays online. That way we can eliminate that being an issue. I can’t say I have any hue bulbs connected directly to my smartthings hub so I’m not sure how well they work as repeaters, I know the ikea bulbs work well as repeaters.

Turned off the hue bulb at the point. Then tried connecting the 5 button ikea remote. Connected successfully, but still receiving the same error when clicking on the device in the android smartthings app.

My guess is that it’s an issue with the android app as the device is showing online through the web ui.

Ah okay, yeah that’s a fair conclusion. I have a Pixel 2XL and i’m running version 1.7.42-22 just fyi. I’m guessing you don’t have a different phone or tablet you can try with to see if you have the same experience…

Tried my wifes old Samsung s8 and it worked. I then cleared my data and cache, uninstalled the app on my phone. Reinstalled and now it’s working. Thanks everyone for your help.


No worries mate! Glad you got it sorted