GE / Jasco (45612) In-Wall Dimmer Won't Connect


(Jon Carroll) #1

Got one of these dimmers which is supposed to work installed and it works great when adjusting the light manually.  For whatever reason I can’t seem to get it to connect to SmartThings.  I go to the add device screen and it never appears.  I have followed the instructions and tapped the switch, but it never finds it.  I tried pulling the air gap for awhile and then trying again, but no luck.  I even tried power cycling the hub but that didn’t help either.

Anyone have any tips for getting this connect or is there something I am missing? Maybe I got a bad dimmer switch?


(Gray) #2

Is it far from the hub?  It seems that that can cause problems.  But if there’s no way to bring the hub closer, there’s not much you can do about that.

 

I’ve found connecting in general to be kind of iffy, but I did succeed with one of these.  I messed with it for a while and then figured I should try turning it on.  I did that while SmartThings was already in pair mode, and it found it almost immediately.

I have two more coming today, and those will be a little farther from the hub.  I’ll let you know if I learn anything useful from pairing those.


(Cory S) #3

I would try setting it up in place of a switch as close to the hub as possible. After it is paired you should then be able to move it further away. I have heard, and it makes sense, that Z-Wave switches have some range issue because they are inclosed in a metal box. Once you start getting more and more repeat capable devices on the network it should be smoother.


(Jon Carroll) #4

It is close, about 5 feet away from the hub, but through a wall and around a corner.  I live in a really old house with thick walls, I will try using a longer ethernet cable tonight and bring my hub closer to the dimmer and see if I have any luck.

Would love to hear if you have any issues with your other dimmers Gray.


(Matt B) #5

I have not installed the Jasco dimmers, but I have installed quite a few of the Jasco light swtiches (45609 and 45614).  Once I figured out that I needed to run a new neutral from the switch to the nuetrals that were collected in the back of the box, the install went relitively smooth.  However, if I recall correctly, I had problems getting the hub to recognize one set of the switches (and they literally control the lights in the room the hub is in).  I ended up contacting Support via the app and they had to “Exclude” the switches.  Once they did that, all was good.

And, on a side note, their in-app support is the best support/help I have ever had for any product I’ve owned.  Seriously.  If you haven’t tried that, I would definitely recommend it as your next step.


(Cory S) #6

+1 to the in app support. I hope they can keep it as good as it is now once the product goes mainstream.


(Gray) #7

Have you guys had good luck with finding someone available for the in-app support?  I’ve tried it three times, and every time it told me nobody was around so I just needed to e-mail.  I’m assuming they don’t have a huge team devoted to that, so I wasn’t too surprised, but it seems like others have been luckier.


(Cory S) #8

I was surprised when I logged into it at 7:30 PM central last night and Ryan jumped right on. It did disconnect a couple times…but that could be my ancient iPhone 3GS I had to dig out of the drawer it has been sitting in for 3 years to be able to use the app.

Despite my bribes of an unlimited starbucks gift card though, he would not conjure up an Android app for me :frowning:


(Gray) #9

Well, I guess I spoke too soon.  I installed both switches and messed with them for about half an hour (until my wife got tired of me using her phone), with no luck getting them to pair.

 

I think I’m going to have to scrounge up a longer ethernet cord and give that a go once the Android app exists.  These switches are about the same distance away as @admiraljonjon’s: probably eight feet, but through a wall.  The previous one was in the same room as the hub.


(sidjohn1) #10

I had the same issue last night, just in case anyone else has the same issue this is how i fixed it. Menu > Settings > Select you Location (Home) > Under Hubs, Select your Hub (Home) > Z-Wave Utilities > General Device Exclusion > Remove. Now turn on/off the device that won’t join, it should say it was removed. It should now add w/o issue.

Enjoy!


Strangeness
(Jon Carroll) #11

Thanks sidjohn1, that fixed it for me, my dimmer is working great!

I followed the steps above, while in exclusion mode I pulled the air gap tab out on the dimmer for ~15 seconds then popped it back in and tapped the light on. I waited a few seconds while still in exclusion mode and never noticed a message like mentioned above, but I might not have been paying attention. I then hit cancel and went back out to the area where you add devices and it added almost instantly, no issues now.

I was never able to contact support as suggested further up above, they were only available while I was at work.


(Eduardo Vk) #12

Hi @sidjohn1 just wanted to say thanks. Your solution fixed my issue instantly.

Thanks!


(pete) #13

thanks @sidjohn1 that worked for me also… just had to toggle the switch while in exclusion mode.


(jeff) #14

your fix worked perfectly for me. Thanks


(Robert Goldstein) #15

I am hoping someone in the SmartThings community can help me, as SmartThings’ technical support has been useless.

For the past week I have been struggling with my hub’s refusal to let me add a Z-Wave dimmer switch. It also lost a connection to another Z-Wave dimmer switch that worked fine until last week, but will not let me add the switch back in to the network. My numerous other Z-Wave switches and devices are currently working fine.

I have tried all of the recommended steps to connect the switches to the hub, such as excluding the devices before trying to add them, rebooting the hub, temporarily pulling out the air plug in the Z-Wave switch, repairing the Z-Wave network and moving my hub closer to the devices but nothing has worked. The exclusion process in particular simply hangs and does not appear to do anything and the IDE log does not reflect any exclusion.

Tech support has been a (bad) joke. I have emailed them multiple times but get a different person each time who apparently reads off a script and tells me to do the same exact things that I have already done over and over, like excluding the device, moving the hub closer, etc.

Unbelievably, after I was chatting for 2 hours with another support technician in real time to try and resolve this, he simply dropped out in the middle of the chat without so much as a warning, a goodbye or an explanation!! Prior to him abandoning the chat, our discourse was perfectly cordial. To have a technical support representative simply walk away from a discussion like that is a first for me and reflects very poorly on SmartThings.

Since SmartThings support has not been helpful, I am turning to the community to see if anyone has any suggestions.

Thanks!


(Bruce) #16

The most likely source of this problem is that the dimmer switch that can’t be added thinks it is part of a z-wave network already. The manufacturer’s instructions include the steps to reset the device to factory settings. You have to do that, and what it is depends on the manufacturer. If there aren’t such steps, let us know what model of switch it is.

In the IDE check My Devices, and make sure that all of the devices shown there exist in your network. Sometimes excluded z-wave devices hang around, and need to be deleted.

Do you happen to own an Aeon Minimote? It can be quite handy for removing and adding z-wave devices.


(sidjohn1) #17

Here is a list of supported Smarthings compatible devices. With out the make and model there is no way to confirm if the device is currently on the list or if it should work. To troubleshoot where your issue is be sure to have live logging open when you pair. If you see an entry for in clusters and out clusters, you’re missing a compatible devicetype. If you see nothing for the device in live logging then the devices are not being detected at all, move them closer and try again. If you still get nothing and you are less than 1 foot away try running a wave exclude from https://graph.api.smartthings.com > My Hubs > View Utilities > Z-Wave Exclude. Once you have hit the z-wave exclude turn on and off the devices you are trying to pair several times. If the devices were paired to another hub for testing, this will clear it out. Now try to pair again. If you are still unsuccessful in getting in clusters and out clusters in live logging or a successful pair, then you most likely got a bad batch


(Robert Goldstein) #18

Thanks for the advice. The devices are GE/Jasco dimmer switches. The GE/Jasco instructions tell me to follow the instructions provided by the Z-Wave controller to reset the devices. I have tried excluding the devices through the SmartThings App multiple times but I never get a confirmation that the exclusion was successful and the IDE logs do not show any exclusions.

I’m not sure what I am supposed to look for in live logging. When I tried viewing the live logs while excluding the device, however, I didn’t see anything. I previously moved the hub to about 5 feet away. I will try to move it 1 foot away if I can find a long enough ethernet cable. I will also try excluding the device using the link you provided. Hopefully that will work.


(sidjohn1) #19

Be sure to turn the switches on/off during the exclude process that is the magic. This is normal for these switches, and well documented on the forums. The magnifying glass at the top left hand corner is your friend. :slight_smile: Also if you are loosing connection from your hub to your switches, you may have a distance issue. Try to keep the distance no more than 30-40ft from the hub or another zwave device.
@April can you merge this thread with this one pls GE / Jasco (45612) In-Wall Dimmer Won't Connect


(Robert Goldstein) #20

Thanks. I have been turning the switches on/off during the exclusion process but it just doesn’t work. That is what makes this so frustrating. I searched the forums for a solution when this problem first arose, before I even contacted support, and I previously read the thread you linked as well as others. I followed those suggestions to the letter, but it is simply does not work. In the past, I was able to exclude a new Z-Wave device before adding it to the hub and it worked fine, so I know the correct exclusion procedure. For some reason, the exclusion process is simply not working with these devices. Also, I moved the hub to 5 feet from the device, but it still won’t exclude the device.