Jasco/GE Dimmer Switch Nightmare


(Travis Roy) #1

I’ve gone through all the things here. I don’t know what I’m doing wrong.

I got the switch, and set it up, the thing worked great, except I had it plugged into an unsupported fluorescent lamp, after swapping out some lamps, I figured I’d try excluding it and re-adding it to learn, since this is my first Z-Wave device.

Well, the exclude seemed to do nothing at all, it never gave me feedback on the phone that it worked, and now I can’t re-add it, it’s not seeing it.

Worst of all, the thing doesn’t even seem to be working as a normal switch anymore. I hit on, off, whatever, it does nothing except leave the light on, I think somewhat dimmed. The only way to turn it off is pull the little button out.

I tried to get the instructions off the Jasco/GE site, but the pdf never downloads.


(Chrisb) #2

Sounds like it didn’t actually exclude. Did you try excluding again?

As for turning off, when you hold down ‘off’, does it dim? How far? If you hold it down for long time, does it dim to off?


(Travis Roy) #3

Turns out the other light fixture was a problem too…

I did get the switch itself to work as expected. I can turn it on/off, dim in both directions just fine.

But I still can’t get it to exclude, or rejoin the hub.


(Travis Roy) #4

GOT IT! Had to put the hub in exclude mode via the utilities in the developer portal. That worked perfect.


(Travis Roy) #5

Also, turns out that these “dimmable” LEDs are not so much. Totally doesn’t work with the Z-Wave switch - http://www.lowes.com/pd_472703-75774-LA19DMLEDG2_0__?productId=50109746&Ntt=


(Ha World) #6

Which model dimmer switch do you have? There is only one model for sale to the public, the GE 45612 and it is NOT compatible with the bulb or any LED. It may work the odd time or by luck, but it isn’t designed to work with anything other than an incandescent or halogen bulb.

JASCO makes a 3-wire LED dimmer but it is not supposed to be sold to the end consumer, contractors only, although that doesn’t stop a lot of e-bay/amazon sellers from selling them. Its a Model 45712 and it should work fine with the Lowes Bulb you linked to.

Which one do you have?


(Travis Roy) #7

I have the one without a neutral, that’s what it was. Thanks :slight_smile:

I do have a neutral wire, so I’ll probably swap it out and use this one where I use incandescent bulbs.


(Brian) #8

for additional reference on the topic


(Travis Roy) #9

Thanks.

I do seem to be having a problem now where the lighting control isn’t working… But, I think something else might be up, because the presence sensing via my phone also seems to be way out of whack.


(Brian) #10

My presence has been a bit wonky lately too. Maybe a platform issue?


(Travis Roy) #11

I think so @docwisdom… If it was just one phone, I might think it was that… But both phones, one being iOS, the other being Android. Both are also doing the same thing with incorrectly detecting presence…

That doesn’t sound like a phone issue to me.