HELP! I Can Connect GE Dimmer to ST But Can't Control It

After about 20 hours of trying to figure this out by searching this forum, I’m about to give up. I installed two GE Dimmers (12729). One was a stand-alone and the other has an add-on switch. The two dimmers are set up in the same box with one other switch. All are connected to the neutral wires in the box and work perfectly with their switches.

I have been able to add them to SmartThings–they show up as a generic Z wave Dimmer–not the specific GE Dimmer that it is. When I try to control them nothing happens. It will say “turning off” but nothing. If I changing the dimming level, nothing happens.

I have tried removing and excluding the devices multiple times. I have reset them using the up 4 times/down 4 times method. I moved the hub within three feet of the switches, and just about anything else I can think of. I am able to controlling my Ecobee thermostat with SmartThings–that is the only other device I have added.

Is it possible that I have them wired incorrectly? Would they still function properly with the manual switches and connect to the hub if this was the case? Is there something I need to do with my network? I really can’t figure this out.

Any help would be greatly appreciated.

1 Like

Since this is a z-wave switch. You can exclude the device by having the hub in exclusion mode in the ST app and press the switch on/off. You will get a message that the device was successfully excluded. You can then use discovery again to find the switch. The genetic dimmer DTH should work.
As far as wiring is concerned. I can’t comment on it since I don’t know the details of your installation but I would think it’s correct since you could manually operate the switch.

1 Like

Double check your device type and if its not switch it to “Dimmer Switch” and see if that helps. I have 15+ GE switches right now all using that default type and they all work fine. None came up as Z-Wave Dimmer by default which is a little worrisome.

Are you saying your dimmer “thing” appears in the App, all pairs/includes well, but when you go to trigger it (on/off/dim, etc), nothing happens other than app making you think it’s doing something? Delay or non-responsive to actions?

If so, same problem here - but not with dimmers - everything else that uses a switch though (power meters, door contacts, etc…)

If I’m lucky, about half the time after 20 seconds the intended action occurs. It’s been driving me crazy and seems to have started a few days ago. Tried everything like you as well.

Send logs to ST support. Awaiting a reply.

I have excluded and re-added the switch multiple times and always end up with the same result. I have never once been able to control the switch through the app.

Just that one item, or all items? Or is that all you have you have connected to your hub?

vseven–I tried changing it to Dimmer Switch and no luck.

BRB01–Yes, it pairs. It takes quite a while, but it pairs. It is completely non-responsive to actions. It never has turned off or on. Both of the dimmer switches are unresponsive, the Ecobee is fine. And, yes, that is all that is connected to the hub.

try running z-wave repair in your ST app.

I attempted that a couple of times, but it never finished (after about 30 minutes).

OK - so wondering if it is those devices causing the issue or another z-wave device. Any chance you want to remove the two dimmers from your hub and attempt to run z-wave repair again?

I removed the dimmers from the hub and ran z-wave repair and it completed the repair in about a second. I then added the devices again and still got the same results.

try only adding one back at a time. run z-wave repair after adding. if after adding one and z-wave repair runs successfully, try adding the other. if the first one fails, remove it and add the other.

Delay/multiple attempts to pair = same issue I experienced with 4 newly added power switches over the last few days. The other 6 paired in weeks prior I didn’t want to scream at. LOL. And like you, I Included, Excluded, took multiple factory reset thinking I didn’t RTFM or follow the process. Nope. And this was adding 4 more of the EXACT same Monoprice switch I added 6 times before without frustration.

Non-Responsiveness = same issue here, except its with both NEW and EXISTING paired devices. ALL 20+ SWITCHES!!!

But in all seriousness, I share your frustration. Here is what I think…

  1. It’s not your hub
  2. It’s not anything you’re doing wrong
  3. It’s not the device itself
  4. In reality, it’s the end of the year, and it wouldn’t surprise me if something is broken on the backend with SmartThings and tomorrow, when people are working, it miraculously gets fixed. Effectively, the SmartThings platform decided to go on holiday, and has had one too many, thus the hit or miss behavior. :wink:

I would log a ticket and send in logs. That’s what I did. Haven’t heard back yet. Sorry I don’t have a solution, but if it’s any comfort, I’m the same boat. All 30+ of my sensors and devices…

When in doubt. Remove the batteries and unplug the hub for a couple of minutes. See if that helped.

Pure comedy… I decided to test to see if the issue was resolved. Nope. Here is my test as of 5 minutes ago, which abruptly ended due to the device going “Unavailable”. Mind you, in weeks prior, I could toggle OCD style back and forth and the SAME switch would go on and off with in 3-8 seconds consistently. Not anymore

Starting State = ON
Attempt to turn off switch = 10 second delay
Attempt to turn on switch = 3 second day
Attempt to turn off switch = Now shows “unavailable” in app

As I was typing this after about 5 minutes, the switch went back online. Something’s up…

Not sure about about OP, but for me…

  • Tried Repair Z-Wave from IDE - No dice (I didn’t even see in the IDE logs where repair completed)
  • Tried battery removal, unplug and hard boot - No dice
  • –I didn’t wait several minutes. I know some electronics can keep residual energy in capacitors, etc., but does it really take a few minutes to deplete on this?
  • Tried to reboot hub from IDE - That worked, but no dice on original issue (responsiveness, and status)

As for responsive. It’s a dimmer so it’s won’t be instant like a switch.

I hear ya, I guess the moral here is… Did the intended action happen with the expected time frame? Fill in the intended action and time frame with your expectations. ;). Does it dim at all? Or does it just ignore you? lol. :slight_smile:

1 Like

I tried running repair z-wave after adding only one and it just keeps swirling and will not complete like before. I tried it with both of them.

I’ve done multiple hard resets of the hub. I’ll try leaving it unplugged for a while.

odd that two new dimmers are not working. You may want to check your wiring.

contact support…