Firmware KILLED Zigbee

See the thread about the new Firmware.

It killed ZigBee device functionality for most users and Smartthings is doing NOTHING.
Support also has not answered any support requests in this regard.

Do NOT buy Smartthings until they get their firmware update process and programming team in order.

This is NOT acceptable for a device this expensive!

$50? $99?

Price doesn’t matter if it doesn’t work, as @JDRoberts is very aware. And reliability isn’t necessarily proportionate to price.

6 Likes

Most users? I bet it’s not even .01% or less so I think you are being a bit dramatic by a few posts in the firmware thread. My system is running great these days a dci have plenty of zigbee.

Just continue to push on support and work through the issues.

I definitely don’t think you can use price as a valid argument. This hub is an amazingly low price for the capabilities but that openness also can lead to a lot more untested issues. Smartthings cannot account for all the wild ideas users come up with.

5 Likes

All my devices are working properly. OP, please elaborate on your issues… else your post will be viewed by rational folks as a bizarre, useless rant.

And as others have noted, the ST system hub is not an expensive piece of gear.

6 Likes

Just give supports more time to sort things out. This version did have some beta testing and there was no zigbee problem so calm down and in the mean time use the physical switches.

Great. Since $100 for the hub is apparently peanuts for most people why don’t the generous people on this forum send me a refund and then I will gladly wait until this is resolved.

All devices worked fine until the update on Monday.
I removed SEVERAL Zigbee devices (bulbs, sensors, etc) which are not reconnecting and cannot be found after removing them.
ALL devices have great battery and they don’t work even when I put them ON or RIGHT NEXT to the Hub.
Oh – and the devices that are supposedly ACTIVE and connected. Well that is a LIE since they don’t work, e.g. bulbs cannot be turned on/off, sensors don’t report when they are triggered, NOTHING works.
Don’t act as if the firmware had nothing to do with this, since everything worked FINE FOR ALMOST ONE YEAR.

Also please explain to me how the hub can show a bulb as active and connected IF THE BULB HAS BEEN TURNED OFF MANUALLY BECAUSE SMARTTHINGS DOES NOT WORK!

I may be affected by this - my ZigBee connected devices (ST motion, ST multi sensor, and 2 Lightfy RGB strips) have show “unavailable” in the app. Availability comes and goes, but it just started this morning. My home monitoring is shot, because it thinks the door is open, then when I reset it, it’s unavailable.

I get the OP is a bit dramatic, but I think this is a bigger issue.

I am being dramatic?

I have 30+ devices that don’t work and Smartthings is doing bupkus

It’s software and your issue isn’t a priority as it’s not affecting a lot of people. Your posts aren’t doing your cause justice. Just report it, help troubleshoot and reach out to support multiple times until it’s resolved.

4 Likes

I believe that the answer from everyone is an emphatic “YES”.

People understand your frustration and we have all been there for one thing or another, but your continued rants of calling people idiots (…) And dropping the F bomb (i changed all to WTH), well this does absolutely nothing for you. If you used a little more discretion and tact, someone may have quickly taken a look to see what might be going on with your environment.

I feel your pain, and knowing this from my own turmoil, trials and tribulations, this is not the way to handle yourself or get anything resolved. You can continue to post these dramatic non Oscar winning performances, but its not going to help your cause in anyway or get your issues resolved any quicker.

Take it from everyone who has replied to you, ST staff and community members and realize that there is a better way to approach things in the future. If you need to scream and pull your hair out behind closed doors, that’s great, do it, but before you reach out to the community, compose yourself and approach things more tactfully. The whole bees and honey versus vinegar proverb holds true here.

10 Likes

Almost 300 devices working great, 1/2 are all kinds of zigbee devices. In fact, this latest firmware update seemed to resolve a couple other issues I was having. This has been rock solid for me.

Yup.

8 Likes

There seems to be a typo in the OP.

Somehow you wrote “most users” when you apparently meant to write “me.”

4 Likes

Totally. Just need your checking account number, address, and mother’s maiden name. :smiling_imp:

3 Likes

I have 49 ZigBee and 32 Z-Wave, no issues what so ever. Maybe you need to unplug your hub, remove batteries for 20 minutes. Then I suggest you add them back since you removed them unnecessarily.

4 Likes

This really sounds like a case of 2.4GHz WiFi interference. Try changing the channel on your router and any extenders if you have them. If you can provide the Zigbee channel your system is using we can give you some guidance as to what WiFi channel to use. You can look up the Zigbee channel in the hub page in the IDE.

I take it you’ve surveyed thousands of SmartThings users since 19.19 was released? I would be curious to see your survey data and compare against the issues I have been experiencing.

I doubt if it’s interference since all his devices went down at once. There are some people, not everyone, but some, who have problems after almost every firmware update.

And with this particular update there were several people who reported zigbee device problems afterwards. Again, not a majority of people, but some.

It’s always infuriating when it happens. it is one of the biggest weaknesses of SmartThings’ architecture that you cannot refuse or delay updates.

Anyone having this problem should definitely report it to support, as the OP has done. But precisely because it isn’t affecting a large percentage of users, it may take some research to figure out what’s going on.

Again, I recognize that it’s infuriating, as it should be. Really the only thing that the OP has done wrong is to claim that a large number of users were affected. That damaged their credibility on this issue, because that part just isn’t true. And leads to too many responses of the “working fine for me” variety.

But it did happen to some people, it is likely related to a failure in the update process, and it is beyond aggravating when it happens.

Unfortunately, for this one as a community we can’t do much more than sympathize. There don’t seem to be any workarounds. You can try the unplug the hub and take out the batteries and leave it off power for 15 minutes approach and see if that resynchronizes everything when it comes back on power, but if it was the update itself that failed partway then it may well require support to do something on their side, and they may just not know what to do yet.

Again, I wish I had an answer, but I don’t. There are other systems out there which do allow you to postpone updates, and which would probably be worth looking at if you want to get out of this kind of forced update architecture. The challenge is finding one that works with zigbee, unfortunately. There aren’t many in the low-cost range except Zipato and vera plus and neither supports the range of devices that smartthings does.

For the OP, I would suggest reframing your posts to something like

I just need to vent. I’m one of the ‘lucky few’ whose zigbee operations got fried by the most recent firmware update and now none of my devices work! Support is looking at it, but for now I’m sitting in the middle of a smart house which has gone completely dumb. So frustrating! :rage:

You won’t get any more answers, but I would guess you’ll get a lot more sympathy. These things do happen and they are totally annoying when they do.

FWIW

6 Likes
2 Likes

Sadly, we see a lot of this kind of reaction out of frustration these days. It is how Fake News gets propagated: tell enough people and others start to believe it.

Your response was respectable and helpful, JD. I know it takes a lot of patience to deal with things that go wrong, but that is the nature of the business these days. I hope the OP hangs in there and finds resolution for his issues. Or moves on to a platform where everything “just works” and all users are happy as a clam at high tide. If that place exists…

3 Likes

Does our imagination count? :grin:

4 Likes

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.