Fibaro Single Switch 2 no longer responds to status (January 2020)

Sorry my device is working I was just trying to show my firmware version and I’m not using the official device handler, but I have wondered before why all the data points on some of my devices aren’t fully populated is that the reason why because they wasn’t included close to the hub?

One of them, you have the LS in the RAW so it must of been fairly close, but if all the data is filled in then it’s been included properly and there’s less chance of funky behaviour, plus it helps with OCD.

1 Like

Hm… i wonder how correct the firmware is. Af far as i know the fibaro single switch 2 has firmware 3.2 and 3.3 not 3.02 or 3.03. I am curius is this is the same firmware but smartthings displays it as 3.02 instead of 3.2.

Brilliant, thank you for this…I switched to this DH and its working perfectly! :slight_smile:

I can’t be bothered to follow if Smartthings are ever going to fix this issue or not, so I am happy to use this DH. Case closed for me :grin:

1 Like

Just upgrated both my fibaro single switch 2 devices to version 3.03 (3.3) but the device is still unusable. Changing the dht to fibaro double switch 2, fixes the issue but i have an extra fake device. @Brad_ST can you please solve this issue. There are so many people waiting for a fix. Please help us!

please fix this for fibaro single switch 2. There are so many of us waiting!

Hi guys so this a video of what is happening to my smartthings setup with my fibaro single switch 2 devices

1 Like

I have the same problems with FGS-213 v.3.2.
Does not work with any available DH.
Have you found a solution?

@Mati_Ruutel, This is what you are looking for then,

Unfortunately, I still don’t work.

Can you post what you are seeing in the IDE’s Live Logging when you toogle the switch from the app and/or physically?

Thanks! The switch works.

1 Like

Both of my single switch 2 have the same problem. Has it been fixed now?

Ironically, Amazon Alexa app works fine for this device, I can toggle on and off and see status correctly

Same here (except the part about Alexa control working) - my Fibaro Single Switch 2 dropped offline on 2nd July and hasn’t worked since :frowning:

Hi ST Community,
may I ask for newbie help? I unpacked the smarthings box tonight and successfully connected the fibaro single switch 2. yey! I had switch on the light, used the app to switch it off, worked fine and could never turn it back on (status remained on, app said ‘a network or server isse occured. Please try later’). A quick googling brought me to this page, but being brand new to this field I’m not able to use the great advice shared here. Would someone mind pointing me to the right direction to solve the issue?

I had the same problem. The DH in item 109 above by GSzabados fixes the problem with mine. See [FAQ: An Overview of Using Custom Code in SmartThings (SmartThings Classic)] for how to do it…


Thanks - that’ll help me get started :slight_smile:

I’ve been experiencing some weirdness with my Single and Double Switches in the new app.
All the devices use the old DHT’s from the classic app and I’ve done nothing to migrate them over to the default DHT’s provided by Samsung in the new app.
Has anyone changed or excluded/included the devices to the new handlers? Is it worth it?
I ask as they are behind the wall and will take a few hours to get them out and reintegrated.

thanks again for pointing me in the right direction. I was able to install GSzabados DH, and make it work. But to switch it on I have to press twice in the app. And the Fibaro Button I want to use with it can only switch it off - not on.
Again, does anyone has an idea on how to fix this ? I don’t mind pressing twice to switch it on of course, but was hoping to use the button for it.

As I said before current solution for SingleSwitch is:

  • go to groovy environment
  • find your single switch
  • change DTH to standard samsung provided DoubleSwitch
  • in the phone app delete DoubleSwitch USB device
  • use as ususal
1 Like