Fibaro Single Switch 2 no longer responds to status (January 2020)

I made reset for Fibaro Single Switch 2 device then readd it to ST hub, from this point it stoped to sync status. I still can to turn on the light and change settings (through both app and IDE) and it update settings on the device. But it always shows as Off in both app.

I thought that the problem is in switch so I deleted it from network. I have a new one single switch 2 device, after unpack, wire and add to the ST I have the same situation. So the problem in ST. Also the same devices added before this accident work well.

Any ideas how to fix it?

Looks like the problem in this:

And its weird, because Fibaro switch 2 is Z-Wave plus device, also I already have firmware 28.12 with hotfix installed

I guess you have excluded the device correctly first and removed it from your ST account too, and then added back from scratch. Because that would be the right order.

Buy reading your comments, you have just probably done some mocking on the device and thinking you reset it.

Zwave devices you need to exclude first to read. And I believe if you haven’t deleted from your account then it will just make a mess.

How many other zwave devices do you have? Are they working correctly? What was the reason, why you had to reset this switch?

Just for your information. The firmware updates happens automatically without user interaction. When the hub first connects to the internet it updates its firmware to the latest one before you could do anything with it.

I have 13 Fibaro switch devices. All works correctly except 2, one of them is new (has been never connected to any hub), the second one I made reset. I don’t think that it happens because wrong reconnect operation since the new one I connected first time is not working as well

What DH are you using? Do you see any errors in the live logging in the IDE?

DH provided by ST “Fibaro Single Switch 2 ZW5” and “Fibaro Double Switch 2 ZW5”.

The same device added before 28.11 firmware

Ok, now you are talking about two different types of devices.

So let’s start from the beginning. With your new device. Is it a single or double switch? Have you got the same type of the switch on your network working correctly?
What is your old device? Have you got the same type on your network working?

Try the following. Exclude both of your devices from your Z-wave network. Delete the devices from ST. When it is all done, go to the live logging and start the inclusion and add your device. Add first your NEW device. Do it with the new ST app. Look at any error messages in the log. Look at the Hub’s log too for any issues there. When added, check the device and do the syncing as required. Look at the live log for any error messages.

If it has been added correctly, then try to add the old device. The same way, looking at the live log for any errors.

For now I have a problems only with Single Switch 2. Don’t wont to try the same with double switch )

I have 3 single switch devices, 2 of them was connected to the hub, one is new.

1 Single switch work OK
1 Worked ok before reset and reconnect
1 new one, I connected it yesterday and it’s not work

I made reconnect and have the same result for both

Go to the settings of the device and change something there, like minimum power report or minimum time. Save and close. Meanwhile look at the syncing in the live log.

And can you look at the events of the device too? All events.

Settings changed, updated in IDE as well, but nothing in log.

Just out of curiosity have you changed the DH for the device in the IDE?

Yes, I tried to use “Z-Wave switch” and DH provided by Fibaro on github - same result

And are you sure that this device is a Single Switch and not the Dual Switch? Can you try to change the DH to the Dual Switch one for this?

Yes, I’m sure )

It’s weird, but when I switch DH to Double Switch it work. The new virtual device created for second channel which is not work because there is no second channel.

Very weird

That’s what I’ve thought. Can you check the device physically that it is a FGS-213 or FGS-223? Or has it Q or Q1 and Q2?

Ok! I see. Does the old device behaves the same? Can you compare firmware versions of the old Single Switches and new Single Switches?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.