Fibaro Single Switch 2 no longer responds to status (January 2020)

I am in the same boat as you guys. Some fibaro devices work perfectly and others (most) dont

Same issue here, I bought a new Single Switch 2 last week and that doesn’t update the status of ON or OFF. However, my 2 year old Single Switch 2 work fine. I was hoping the Hub firmware fix last night would fix this, but that hasn’t made any difference :frowning:

Try this device handler I’m using now and it works fine. https://github.com/erocm123/SmartThingsPublic/blob/master/devicetypes/erocm123/fibaro-single-switch-2-fgs-213.src/fibaro-single-switch-2-fgs-213.groovy

1 Like

There is no problem with DTH, my first Single Switches were connected to the hub in November 2019, they work ok now. But the same switches connected in January 2020 are not work. So the problem in firmware, I think connection process was changed and it affected Single Switch 2 devices somehow

I only have 1 single switch 2 that I got about 2 months ago and its never worked with the official device handler but dose work with that one that’s all I can tell you I’m sorry if this doesn’t help.

In my case, i checked inside the IDE and found out that the 2 fibaro single switch 2 devices that are not working, are using fibaro’s firmware 3.02, while the other 2 which are working fine, are using firmware 3.03.

Your not going to like it when I tell you that mine fibaro single switch 2 is running firmware 3.02 then :confused:

Is yours working with the official handler?

No I’m using erocm123 device handler the one I posted above.

i really dont want to use a custom dht for these devices…

Why may I ask?

Most custom dhts were made for the classic app and some aspects of them dont work well with the new app. Also i want to use the official ones so that if they get updated or get new features i wont miss out.

Yes, official DTH is work fine for devices connected in Nov 2019

My fibaro single switch 2 with firmware 3.02 does not while the ones with 3.03 work great

Mines never worked with the official device handler and it does not appear they are working on updating it also I’m only using the new app and as far as I’m aware the official handler also is only online in this case so there really doesn’t seem to be any difference using a comunity made one.

All my devices is version 3.3

How do you see the device firmware?

I found out that some of my Dimmer 2 devices responds immediately to physical switch in ST. But those who don’t respond have additional data in the device overview.

Data * MSR: 010F-0102-1000

  • firmwareChecksum: 127A
  • firmwareId: 0112
  • manufacturer: Fibargroup
  • manufacturerId: 010F
  • manufacturerName: Fibargroup
  • networkSecurityLevel: ZWAVE_S0_LEGACY
  • productId: 1000
  • productTypeId: 0102

All this data, what is that actually? The only data in the devices that is functioning is: “networkSecurityLevel: **ZWAVE_S0_LEGACY”
No more.

How did you find your firmware to be 3.3? Mine shows 3.02. Can i have a screenshot please?


Here is mine for reference.

@Adam_Young if the device in the screenshot above isn’t working correctly, you could factory reset it, then add it back close to the hub, so all the Data points get populated, then see if it works correctly.