Fibaro Dimmer 2 reports status but won't sync or take commands

I have a brand new fibaro dimmer 2 which is working fine with a local switch. It took ages to get it synced - i had to put the smartthings hub about 3 feet away before it would work - but eventually it did connect. I then installed the custom device type handler ([RELEASE] Fibaro Dimmer 2 (FGD-212) - Advanced DTH (V2))
Now, it reports status (light on/off, current drawn etc.) but it won’t accept commands from smartthings, nor does it complete sync - in the logs I just see “sync(): Syncing configuration with the physical device.” but nothing after that, and the settings are not effective. I tried resetting it (using the B button) and re-adding it, but this didn’t help. Any advice?

How far apart is it from the ST hub now? Is it within a small metal wall box that might be blocking lots of signal? Could the antenna have got damaged while installing it?

Or are you saying the status updates come through absolutely fine, but no send commands are working (config or control)? Do you have any other ZWave devices in your house and have any of them had a problem? You’re using the same DTH as me and it works well for me so Im sure we’ll get there. Perhaps give the SmartThings hub a quick power cycle aswell.

The latter device to hub is fine, huh to device not. The fib Ari has the v3.5 firmware if that makes any difference.

Tried power cycling, no luck. Other zwave devices are fine although there’s only 2.

removed it using the IDE, then reset the device. Re-added it, and now it works. Which is annoying as i reset it and re-added it 3 times yesterday - but got there in the end!

2 Likes

Thank you, I had the same problem but now resolved.

i.e. the fibaro dimmer 2 appeared to have connected but wouldn’t turn on or off, also had the message SyncPending that wouldn’t disappear.

Your solution worked for me: 1. remove device using the IDE 2. Removed codersaur’s device handler 2. Reset the device 3. Re-added codersaur’s device handler with all settings back to default. 4. Re-added the device 5. Changed appropriate Codersaur’s settings.

Like you I had previously tried resetting and re-adding but I think in earlier attempts I didn’t remove it in the IDE and the device handler with older settings were still there.

1 Like

Hi, I’ve tried everything you described a number of times…even with another Dimmer 2 and I still have a number of SYNCPENDING messages. I can’t see a new interface on my mobile either. Any ideas?

UPDATE … I’ve managed to break both my Fibaro Dimmer 2s. Even though I took great care, I found the recessed “B” button very flimsy and, after a number of clicks, it stopped “clicking” completely in one case , and in the other it didn’t respond at all from the start. It’s a pity the button is not surface-mounted rather than being recessed as it’s very easy for a screwdriver to slip to the side of the switch (which is probably how I broke them both). I made sure I used a flat-ended tool to make sure I pressed the button down evenly, but alas! My fault, but I need something a bit sturdier.