Fibaro FGS-222 Dual Relay (ZWN-RSM2 device type) - WORKS!

Hi, @abalch, The device essentially has 2 switches, but ST can only really deal with Switch 1 unless you go into the switch on your app every time you want to turn either one on/off, so you need:

  1. The relay device type assigned to your relay. this will show both switches and control both.
  2. 2x “Simulated Switch” - one for each of the relay switches you want to control.
  3. The custom app. This links the virtual switches to the relay device within smartthings.
    @pukka’s all work well for me, but there is also a device type and app by @erocm1231 that does the job great.

The virtual switches are what you use in other smartapps and routines etc. If you try and use the relay device in other smartapps you’ll only ever be able to control “switch 1”. So the actual device just kind of sits in the background, and the 2 simulated switches are the things you actually use to control each relay.
Hope that helps a bit? :persevere:

1 Like


Many thanks for the guidance. Think I may have go there now with the creation of simulated switches, just a shame that you end up with the relay device and the two switches as things on the home page in the app. Really appreciate your helpful response

Hi Guys,

Did anyone get this to work, as a newbee I have added a device handler and published for myself but how do i associate this with a device ?


in the IDE under your devices page, find your device and click on it then choose edit.

then just select your device type handler from the type dropdown to your custome device type and hit update

Thanks for the information. I will give it a go

Hello guys!
I am really new to this and most of the stuff I read here does not make much sense to me. But I have been keen on automating my home recently. After lots of research on hubs I concluded that Smarthings is one of the best because I want it to be integrated with Amazon Alexa for voice control. I have not bought the hub yet, but I bought some Fibaro double relay switches to check the wiring and fitting in the box. I managed to wire it and fit it and with the hard button on it can only turn one relay only, is this normal? My most important question is with my very little experience will I be able to operate these switches with the Smartthings? I also have one roller shutter switch. On smartthings website it mentions it is compatible with most Fibaro switches except these 2 I have and need most. Can please someone advise and help? Thanks.

Hi. I got my electrician to install my fibaro relay today. I have powered it up and pressed the switch button 3 times but I dont seem to be able to get Smartthings to recognise it. I have attached a picture of my config (only 2 of the switches are designed to be used with the FGS-222).

Any help or tips would be greatly appreciated.


Didnt see this post, I assume you got it working in the end?

If not then I would suggest this:

  1. Check the device is getting power, you should hear a slight hum when on, or see a small light (I cant remember without opening up my sockets)
  2. Try pressing three times faster, quite often I find you need all 3 presses in a second, rather than 1 every second. Also triple click is effectively 6x click if you have toggle switches (which they look to be).
  3. If the above dont work (and you cant control the lights manually on the switches then I suggest checking the wiring.
  4. If none of the above work then it looks like ST is failing to find it for some reason, is it definitely in ‘Search’ mode when you triple click?

Hi… thanks for the reply.

It seems the rapid switching (within a second) was the key. Thank you so mcuh

I have the dual relay so i guess now i need to swap the device type to control both channels (its only controlling the main one at the moment). There seems to be a few above. Any advise on which one to go for would be great.

Cheers again

Glad to hear it.
Im using “Fibaro FGS-222 Dual Relay” by Pukkahq

but I’m actually just about to write one myself so it has child devices (I.e. separate devices which can then interface with Alexa and CoRE). Currently it is quite difficult to arrange and requires a smart app but my solution will not need it. Feel free to install as you see fit, but then perhaps give my version a go if you fancy.

Hi Guys,

I had one of these setup on homeassistant connected to a aesotec z-wave stick. That died so I decided to get a smartthings hub instead of rebuilding.

I have managed to exclude and add my aeotec multi sensor, but I cannot get the hub to see my dual relay.

I’ve tried the hold for three second reset, then press 3 times, but it never seems to work.

Anyone got any pointers, have tried this over 30 times with no joy.

I have tried exclusion too from the smartthings hub, but I don’t get a notification of any kind when I do the three presses then either.

At a bit of a loss as I can’t press the button any quicker?



Hmm actually it seems to have paired itself with my Aeotec multi sensor of it’s own accord, just walked into my kitchen and the light magically came on of it’s own accord, anyone have any ideas how to fix this mess?



You need to send an unpair command to it. In the ST app Press where it says home and it should show you some Zigbee/Zwave utilities. Try a general exclusion by selecting it from the app, and then within 30s triple press the button on the Fibaro. That should release it from all previous pairings. Then go to add a device in ST and while it is searching try the triple press again.

The triple press (on and off which might be 6 presses of a toggle switch) should take ~2s in my experience. Hopefully you have some luck with that!

Edit, re-read and seen that you have tried this. All I can suggest is trying to do a few exclusions back to back to make sure it definitely receives the signal to unpair…

Thanks for the reply. I’ve given up with it, my other devices seem fine with the exclusion and add, but this thing is a complete nightmare. I’m going to return it as faulty and I’ve ordered a Quibino device instead, hoping to swap it out today.

Hi all,

Like a few of us here, I’m a bit of a noob when it comes to circuits and electrics. I’ve just purchased the Fibaro FGS 223 Double Switch, so I can control 2 separate lights from a single 2-gang switch. I was hoping it would be straight forward, but I guess not.

I’ve attached an image of my backbox, and I’m not too sure exactly which wires go where. I could take a guess, but would rather not.

Any help would be greatly appreciated, and would help restore some dignity in the household!


The two wires coming out of each L1 are your wires going to the lightbulbs, i.e. these are the things that go to the output of the Fibaro.

The two browns at the top (COM) are live, yours is wired in a loop so you will need to keep these two wires connected to each other (or it may stop other lights working in your house). Both of these will therefore connect to the live pin on the Fibaro (maybe through a plastic connection to hold the wires together). You can lose the

The blue cables with the plastic connection is your neutral, again this will be a loop, hence keep them connected together and add a wire which goes to neutral on the Fibaro.

That said I would add that is this is to much, get somebody else to do it for you or you risk a fire risk. One other thing you can do is take a picture before you start so you know you can return to do if you need to.

Hi, first of all many thanks to the community and all the help / advice provided.
I have been installing a fibaro relay switch (FGS 222) for my gate, but I am experiencing 2 issues :
1st : when I want to open the gate, it works fine,I hit the switch, and the gate opens. But when I want to close it after a few minutes it works 1 time out of 3… it’s supposed to work the same way on the gate side… maybe should I double wire with the second switch ,
2nd : the relay is supposed to work more like a pressed button, to send just a short pulse. When I open the gate, I turn my simulated switch to “on”… and then I use IFTTT to reset it to off. I could also use CORE. Am I missing something in the FGS config to have it work like a button ?
Thanks for your help

Im afraid Im not sure with this device type, but if you use the one I have created (modified from [deleted]'s and Eric’s) then you can first of all create a separate button that should be more reliable. Plus if you click on the settings icon at the top right, then you can set the auto off time for the relay (parameter 3 and 4 from memory). If you set this to 2s or something like that then when you press on, it will auto turn off after 2seconds.

nice work but I have problem

I go to settings and I can’t save my changes says “please fill out all reqired felds”

what goes wrong?

I have skated through the thread so not certain what device handler you are referring to but I can say that what you are describing is something I have come across which is a bug. From memory I believe you initially need to make the changes in the IDE simulator. Hopefully someone with more knowledge can expand on this.