FAQ: Fibaro FGS 222 Relay - Installation Guide / How to for beginner

dth_inwallmicro
project_lighting

(Jonas) #1

Step-by-step guide for the integration of Fibaro “FGS-222 Relay Switch”:

As I was a little bit lost at my first time integrating a non supported device to my ST hub, I hope this guide will help you with the Fibaro Relay.

Guide

  1. Include your device to your ST hub. It will be recognized as a “Z-Wave Device Multichannel” device (reset & inclusion details below)

  2. install the device handler of Pukahq (Link) or erocm123 (Link) via the ST webpage (Link -> Developer Tools)

  3. link the device handler to your included device

  4. install the smartapp of Pukahq via the ST webpage (Link); Pukahq offers you the possiblity to edit specific parameters if you don’t need this you can also use Erocm123’s (Link)

  5. create two simulated switches

  6. install the smartapp in your ST App and insert the necessary parameters

additional:
7) set parameter 14 to value 0 if you are using a momentary switch

General advices:

As the official manual is quite bad I’m collecting here some general advices I found due my research.

Reset:

Option 1:
-turn of power of the switch
-press B button and keep pressed
-turn on power (you should hear a click)
-release B button
-turn power off and on one more time

Inclusion:

you will need several trials to include the device

Option 1: press B button one time
Option 2: press B button three times very fast
Option 3: press the switch connected to S01 three times very fast

Wiring:

http://www.zwave-review.com/Anleitungen/Wechselschaltung_Fibaro.php

http://shop.tecmatic.ch/de/blog/21-elektrischer-anschluss-z-wave-module


Help: Fibaro FGS-222 Dual Relay physical switch keeps switching between on and off
Help Needed Wiring Fibaro FGS-222 to existing switch for outside lights
IFTTT to conrol Fibaro relay switch?
Fibaro FGS-222 Dual Relay (ZWN-RSM2 device type) - WORKS!
[RELEASE] Device Handler - Fibaro FGS-222 Double Relay Switch
Heating Control for Newbie
Fibaro Roller Shutter 2 - FGRM-222 (DTH in post 24) (UK Device)
(Jonas) #2

Links to above mentioned apps & handlers:

Erocm123:
App: https://github.com/erocm123/SmartThingsPublic/blob/master/smartapps/erocm123/virtual-physical-switch-sync.src/virtual-physical-switch-sync.groovy
Handler: https://github.com/erocm123/SmartThingsPublic/blob/master/devicetypes/erocm123/generic-dual-relay.src/generic-dual-relay.groovy

Pukkahq:
App: https://github.com/Pukkahq/SmartThings/blob/master/Fibaro%20FGS-222%20APP
Handler: https://github.com/Pukkahq/SmartThings/blob/master/Fibaro%20FGS-222

Fuzzsyb:
App: https://github.com/fuzzysb/SmartThings/blob/master/SmartApps/fuzzysb/Fibaro%20Dual%20Relay%20Secondary%20Switch%20Binder/FibaroDualRelaySecondarySwitchBinder.groovy
Handler: https://github.com/fuzzysb/SmartThings/blob/master/DeviceTypes/fuzzysb/Fibaro%20Dual%20Relay/FibaroDualRelay.groovy

FAQ smartapps & device handlers

FAQ: An Overview of Using Custom Code in SmartThings


(Mat) #5

Great set of instructions. As you say I had to try to whole reset/inclusion process a few times but eventually got it connected.

I’ve installed the Pukkahq : Fibaro FGS-222 Dual Relay Device Handler. All working great bar a couple of exceptions.

  1. Delay - I’ve noticed a delay in the Smartthings recognising the state of the virtual switches. For instance I might switch one of the relays off through Smartthings and the app seems to loose its state. I don’t have physical switches hooked up and am looking to control this purely on a virtual basis.

  2. Is there is way of have one button that controls both switches?? I have the dual relay hooked up to two sets of outdoor lights. Both of which I will mostly have on together but I’d like the freedom to control independently.

  3. How can I setup a way of automatically having the relays turn on and off depending on time? The whole point of me installing the Fibaro dual relay was so that the outdoor lights would automatically switch on at a set time and off.

  4. Using the Good Night routine in Smartthings I’d like to be able to switch everything off at once, all my sockets, lights etc. The Fibaro Dual Relay does not appear in the ‘lights of switches’ to turn off.

Thanks


(David Jacobs) #6

Whilst this is an excellent set of instructions and ahead of others I am absolute newbee and am still confused.

  1. I include the device to the hub - all good.
  2. I install the device handler “Pukahq” - seems OK but never done this before so just copied all the code into the “from code” page. I wasnt sure what to do to the From Form & Template page so apart from putting my name in left them as they were.
  3. Link Device handler - Yes that worked ok.
  4. Install the SmartAPP of Pukahq - From your second entry as first was dead- Is this OK?
  5. Create Two simulated switched - Created two differently named new devices both as “simulated switches”
  6. Install smartapp - Done

My problem is and I’m guessing is with setting the momentary switch to act as that rather than latching constantly on.
If I look in things my two simulated switches although they do work (I can hear the relay clicking) do not offer any configuration options. The device handler created shows two switches and one configure button under it. The configure button is grayed out and doesn’t seem to work. If I hit the gear button at the top of the page however this does get me into configuration where I can put in the parameter number 14 and the value 0 - I assume that affects both switches?
I try to highlight the switches in this first then go to the gear button and hit the replace - It goes off to check device health but keeps spinning and times out.
I think its all kind of working but not properly and I don’t believe its accepting the parameters.
Any help PLEASE much appreciated. I realise that the problem is probably due to my lack of understanding in the developer part of the install.
Thanks


(Paul Phillips) #7

Thanks so much for this.

I’ve installed it in the bathroom controlling the lights and extractor fan. Works a charm!


(Nigel Williams) #8

Hi all

I have been getting my SmartThings v2 hub up and running.
All good with Outlets, Motion and Smart Sensor and defining Routines and even SmartApps.

I have acquired a Fibaro FGS222 from amazon and done the Hardware install with Neutral, no problems.
Now the fun starts.
Pasted the code for Pukahq’s device handler and Included the device, changed the device handler to the z-wave Device multichannel Thing included.
So far so good I think.
Then I pasted the code for Pukahq’s SmartApp and ran it. But its not working too well.
I can Turn On the Multi-Channel device and both independent switches are actived and the reverse works.
But the Switch Endpoints remain on in the My Home but in reality are off!!!

So I started the Delete the independent Endpoints and then the Device Multichannel. Errors are reported and the Switch Endpoints remain.
I have tried to Remove via the iOS App and the IDE without success.
I have emailed ST Support to request them remove these so I can start again.
I await feedback.

In the interim, can someone kindly explain the following as it remains unclear to me
4) What are the specific parameters and what options exist?
5) create two simulated switches…how?
6) how does this step differ from 4)???

Thanks for the advice on resetting the device and putting into Include mode, these work fine.

I would appreciate your insight and help…


(Nigel Williams) #9

The error message I get when I attempt to Delete 1 of the Switch Endpoints via the IDE is -

Validation error whilst flushing entity [physicalgraph.app.InstalledSmartApp]: - Field error in object ‘physicalgraph.app.InstalledSmartApp’ on field ‘state’: rejected value [COMPLETE]; codes [physicalgraph.app.InstalledSmartApp.state.validator.error.physicalgraph.app.InstalledSmartApp.state,physicalgraph.app.InstalledSmartApp.state.validator.error.state,physicalgraph.app.InstalledSmartApp.state.validator.error.physicalgraph.app.InstallationState,physicalgraph.app.InstalledSmartApp.state.validator.error,installedSmartApp.state.validator.error.physicalgraph.app.InstalledSmartApp.state,installedSmartApp.state.validator.error.state,installedSmartApp.state.validator.error.physicalgraph.app.InstallationState,installedSmartApp.state.validator.error,physicalgraph.app.InstalledSmartApp.state.Input ‘[rootDevice]’ is required.physicalgraph.app.InstalledSmartApp.state,physicalgraph.app.InstalledSmartApp.state.Input ‘[rootDevice]’ is required.state,physicalgraph.app.InstalledSmartApp.state.Input ‘[rootDevice]’ is required.physicalgraph.app.InstallationState,physicalgraph.app.InstalledSmartApp.state.Input ‘[rootDevice]’ is required,installedSmartApp.state.Input ‘[rootDevice]’ is required.physicalgraph.app.InstalledSmartApp.state,installedSmartApp.state.Input ‘[rootDevice]’ is required.state,installedSmartApp.state.Input ‘[rootDevice]’ is required.physicalgraph.app.InstallationState,installedSmartApp.state.Input ‘[rootDevice]’ is required,Input ‘[rootDevice]’ is required.physicalgraph.app.InstalledSmartApp.state,Input ‘[rootDevice]’ is required.state,Input ‘[rootDevice]’ is required.physicalgraph.app.InstallationState,Input ‘[rootDevice]’ is required]; arguments [state,class physicalgraph.app.InstalledSmartApp,COMPLETE]; default message [{0} does not pass custom validation]

Does this help further?


(Paul) #10

Some excellent wiring diagrams here that may be of use to some of you:

http://www.vesternet.com/resources/application-notes/fibaro


(David Jacobs) #12

Hi Did you manage to resolve this?


(Nigel Williams) #13

Yes all sorted


(Frank Reymenants) #14

I’ve been trying to connect my Fibaro Relay Insert 2 * 1.5 KW frantically but no luck :blush:

I keep the search things page open while I try the press 3x b button or switch… I tried resetting and adding many many many times :slight_smile: I’m usually not so clunky. Any tips?


(JK) #15

I see it is a week since you wrote so hopefully you’ve managed to get this to work by now. Just wanted to share that I installed one of these today and it was a total pain to get smartthings to recognise it.

In the end the problem seemed to be that I was too far from the hub. I got a long Ethernet cable and brought the hub right beside the Fibaro then did the ‘press button b 3 times’ inclusion method and it worked straight away.


(David Jacobs) #16

I’ve had similar problems. They do eventually pair, the further away the more difficult it is. Strange as the relay does appear to be harder than the other Fibaro products to. Pair.


(Mark Green) #17

I have been struggling with this today. I installed the device handler from Pukahq and now id I click on the device in the mobile app I can see the two switches. the Pukahq smartapp seems to have gone from GitHub (or the link at the top of the thread is wrong!) The Erocm123 smartapp is there so I installed that.

IN the simulator I created 2 virtual switches… and then, well nothing. there still aren’t two switches in the mobile app and I can’t really do anything other than turn the lamps off from my phone… Any help would be great.


(Mark Green) #18

So I have found the right SmartApp here: https://github.com/Pukkahq/SmartThings/blob/master/Fibaro%20FGS-222%20APP

Installed it, run the simulator and set up two virtual switches…

I still don’t see how I can get switches that can be automated via another smart app. (I.e. if I create a new Smart Lighting app, it does not list the Fibaro switches (or virtual switches, or indeed anything to do with this device in the list of potential lights.

I am sure this is just me being dense, any help gratefully received.


(Mark Green) #19

Ah Ha!

I was being stupid… I hadn’t properly created the virtual switches. Al working now :slight_smile:


(Sergio Ferreira) #20

Does this work with Fibaro roller shutter?


(Neil Stanfield) #21

@davidj

Did you ever get the parameters for a momentary switch working using the Pukkahq app/ handler?


(David Jacobs) #22

Yes I did, I think. What’s your problem. I think I was not following the setup correctly.


(Neil Stanfield) #23

Hi @davidj,

Thanks for the reply. The problem I am having is as you described in May last year.

My problem is and I’m guessing is with setting the momentary switch to act as that rather than latching constantly on.
If I look in things my two simulated switches although they do work (I can hear the relay clicking) do not offer any configuration options. The device handler created shows two switches and one configure button under it. The configure button is grayed out and doesn’t seem to work. If I hit the gear button at the top of the page however this does get me into configuration where I can put in the parameter number 14 and the value 0 - I assume that affects both switches?
I try to highlight the switches in this first then go to the gear button and hit the replace - It goes off to check device health but keeps spinning and times out.
I think its all kind of working but not properly and I don’t believe its accepting the parameters.

I am using the Pukahq device handler and App.

Under the “My Home” tab in the ST App I have three devices listed - Z-Wave Device Multi-channel (renamed to FGS-222), and two Virtual switches named Garage Door and Switch 2.

On the device, If I hit the cog in the top right corner I get the option to input parameters, however if I turn on the virtual switch labelled “Garage Door” I can hear the relay switch on but not automatically turn off. My understanding is that these parameter settings should automatically turn that relay off after a second. As you mention these options are only available to set on the Z-Wave Device Multi-channel (FGS-222) device and not the two virtual switches.

Looking to see if this is similar to your setup / original issue. Is this where you set the parameters to mimic momentary switch. Do these settings apply to both switches given they are set on the device rather than the simulated switches?

Any help is much appreciated.

Cheers,
Neil