FAQ: Zwave repair not working (how to fix error messages)

That would be a good place for it. :blush:

1 Like

Following the instructions here after logging into my account, i cannot get the network repair utility to work. Opening Live Logging in another tab, or going to hub Events after initiating network repair does nothing, no messages anything like in this thread, no indication any repair is happening or was successful or not. I have tried half a dozen times letting it run for an hour. All I see is a little wheel turning under hub Events… Live logging just reports regular network traffic from sensors etc. What’s up - Or how do I really get network repair to work? Thanks

@RonaldL52 I’m having the same problem! I don’t get any indication that a repair is happening…

If you just see the little wheel turning, the connection has been lost. Look at the Hub events list to see past events. You should see the start of the z-wave network repair there. What I do is use the live Hub Events page without the zwNwkRepair Name Filter (leave the Name Filter blank). Open that page in a separate tab first, the start the z-wave repair. You should see all of the events there (plus a few pings and other things).


Really, this is the best status diaplay we can provide, i have no idea if its runing or not? Suerly a status or list of devices could be added as they are tested. Only seen a completed message once in 10 runs…

1 Like

If you get those with an ID rather than a device name, this is most likely an orphaned device - you can check in My Devices whether you actually do have a device with that ID. If not, you can remove it by following these steps (I just did that to remove the ten or so orphaned devices I had and after three more network repairs, I was able to get the network repaired without any errors):

  1. Go to My Devices
  2. Click “New Device” at the top right
  3. Enter some obvious name (I just used “Trash”), put the orphaned network ID into the “Device Network ID” field, select “Z-Wave Device” as the type, and select your location and hub
  4. Click “Create”
  5. In the mobile app, go to this newly created device (you might have to refresh the device list), select “Edit Device” and force-remove the device

This will remove the orphaned associations from the hub and no longer cause the hub to look for non-existent devices.


Can some one tell me if the zwave repair action is still included in the IDE? I cannot find it anywhere?



It’s at the hub level, since people may have more than one hub.

Enter IDE
Choose My Hubs
Select a specific hub
Look down the page for “View Utilities”

You should then be able to select Zwave repair.

Thanks for the reply @JDRoberts. Oddly I am still not seeing it? Is it suppose to be on this page?

Below the Data box (bottom of your .jpg) there should be two more lines, one for Events and one for Utilities.

The right side of Utilities is a link labeled “View Utilities.” Click that.

Hmmm, no utilities for me…so it seems?

Wow, that’s weird! Are you in the US or UK? Hub V1 or Hub V2?

US and V2, thanks again for your thoughts and help.

Then definitely write support@smartthings.com. Good luck, let us know how it goes!

Will do, thanks again.JD.

@JDRoberts - Just wanted to follow-up to let you know the issue I had with the IDE was resolved. I have two email accounts associated with my ST Hub (one on cell phone and another on a PC). Using one of the email accounts will not show the utilities info in the IDE and the other does.



1 Like

@ahndee Thanks so much for your instructions on how to delete ghost devices. After two weeks of being without Zwave I now have it? Again a big thanks.


When you run a zwave repair, The hub goes through its device table and attempts to contact each device and ask them who their current neighbors are.

The hub then takes all of this information together and calculate some optimal routes in advance. It sends this routing information back to each individual device, just The part that applies to that specific device. So each device ends up with a partial routing table. All of this should make routing faster and more efficient.

So in a sense the hub asks a question, the node answers, and then the hub sends out a New map for the node to use.

The two common error messages that you will see are

“Failed to update mesh information.” This means the node didn’t answer the first question. It didn’t send back the list of its neighbors. That might mean in the node is missing altogether, it might mean it was just asleep, it might just mean it’s out of range, or it might mean the data was corrupted. If it was just asleep, it’s no big deal. If it’s out of range it may not be a problem as the rest of the map is filled in.

Note in particular that “failed to update mesh information” won’t cause a problem for the network if that particular device was a battery powered device because they don’t act as repeaters. But if that device is a repeater, it can’t be used in routing until the error message goes away, so you can lose access to a lot of other devices down the line.

“Failed to update route”

After the hub has collected all of the information from all of the devices it starts calculating the routes. when it has the partial map ready for a particular device, it sends the information to that device. It should get back an acknowledgement. If it doesn’t, you get the “failed to update route” message.

Again, this can happen for a couple of different reasons. If the device is battery-operated, it might just have gone to sleep again. It happens. if any devices get physically powered off during the repair, it can happen. if devices get moved around it can definitely happen.

When this does happen, it’s actually not that big a deal. It just means that there’s a device out there that doesn’t have the most optimal route.

I’ve mentioned before that a lot of field techs will do 3 zwave repairs in a row. Cleaning up These kinds of errors are the main reason.

Of course you could also get either of these errors because of either data corruption in the address tables or device failure in the hub itself, obviously both a problem. But most the time it’s just a sleepy device that’s thrown something off and it will run fine the next time.

Ghost devices

The ghost device error where you only see a device number not a name and you get “[ ] not responding” is a different kind of error, and one you really shouldn’t see very often. The problem has been well described in posts above, it means the hub has a listing for a device which is no longer on the network. You have to clean up the address table so that the network will stop trying to use it.



This is awesome information!

How did you find this out?

I have been thinking for awhile how I would ask these questions because these are the kinds of errors I sometimes get.

College major in Computer Information Systems, worked as a network engineer, asked a lot of questions. :wink:

Z wave repair utility is a standard function for the protocol. But the exact wording of the individual error messages is up to each controller company.