Z-Wave repair routine doesn't work, and neither do any z-wave devices


(Shelley Powers) #1

The Z-Wave repair facility isn’t working, it’s just cycling. And because of that none of my z-wave devices are responding.

Yeah, that’s none of them.

So what’s the excuse this time? What did you do to break it?


#2

Very frustrating!

During a zwave repair, no other Z wave messages are sent, so that part makes sense.

If it was me, I would take the hub off power (including taking the batteries out) for 15 minutes and then restart it. That will force it to re-sync with the smart things cloud account, among other things. And I would check to see if any zwave devices are working.

If they are, again if it was me, I would try The zwave repair again and see what happens. Because results might be unpredictable otherwise.

But that might mean you have to do the power off routine a second time if The zwave repair hangs again.

I’d report it to support in any case.


(Shelley Powers) #3

I did just report it, JD.

I’ll give your solution a shot. I have too many z-wave devices to leave them all in a non-working state.

I’ll post back what happened.


(Shelley Powers) #4

Didn’t work. The repair didn’t work. It started, and then that’s it. Nothing finishes.

Definitely busted.


(Beckwith) #5

Before you reboot, go into the IDE and turn on live logs. That should give you more information on what is causing the problem.


#6

Sometimes one bad device can flood the network with messages, and that can prevent the zwave repair from completing. So I agree, it’s worth checking the logs if you feel like going to that effort.

You probably know all this, but just in case, here’s the logs FAQ:

The following probably doesn’t have anything to do with your issue, but I just want to mention it in case someone finds this thread later, which is that there is a known problem if you have more than one Sonos devices attached to your network where they flood the system and zwave messages can’t get through. ( from an engineering standpoint, that doesn’t make any sense, but apparently it does happen. ) The only workaround for now is to remove Sonos devices and then magically Z wave devices all start working again.


(Shelley Powers) #7

I ended up removing the outlet from SmartThings, and then adding it back in. Everything seems to be connecting again.

I did check the logs, but it seemed like they were also stuck. When I re-booted the device, I re-ran the Z-Wave repair. Evidently it did finish, but the message didn’t show up on the device. It did show up in the events in the Web UI. But I still couldn’t get things to work until completely removing the outlet from the Hub and adding it back in.

When I added the outlet back, the application never did say it was found. But when I went back into Marketplace, it gave me a notice that there was an unconfigured device.

Things are majorly creaky with the Hub, as has been noted elsewhere.

Interesting about Sonos. Thankfully I never invested in them.


#8

Sometimes the Z-wave network repair screen will not show all the updates but if you log into the IDE go to My Hubs and then List Events and refresh that page and you will see everything from start to end during the repair so you will know when it is done. This page usually updates faster than the app does too.


#9

@Shelley_Powers - When you said “I ended up removing the outlet from SmartThings, and then adding it back in.” do you mean you have unplugged the hub for the 120 outlet?

I too am having issues with z-wave repair. It does not work at all and give failure messages. The folks at ST said that I should unplug the hub for an hour, plug it back in and try the repair again. I did these things and z-wave repair still does not work (after multiple tries). Just checking to see if you’ve done anything different?

Thanks,
Shawn


(Shelley Powers) #10

The first time it didn’t finish. Either in the mobile app, or in the IDE.

I had to unplug the device, wait a bit, to try it again, and it still didn’t fix problem or even note a problem.


(Shelley Powers) #11

Hi Shawn

I had to remove the device from SmartThings, completely, and then re-add it. I used the remove button in the app.

Once I removed the device, the rest of my z-wave devices worked. And when I added the outlet back in, it worked again.

But again, I had to literally remove the device. Unplugging it, and plugging it back in, didn’t fix the problem.


#12

Ah, gotcha @Shelley_Powers, thanks. I did not see in the upper part if the thread that the culprit was an outlet. Now that I think about it, I don’t see how you determined the outlet to be the trouble maker? Did you see it “flooding” the network using the live logging as described?

Thanks for your help; still tryig to get my zwave repair to work!

Shawn


(Shelley Powers) #13

I found out it was the outlet when the light plugged into the outlet wasn’t coming on.


#14

Got it; thanks again Shelley.


(esung) #15

Hello
I’m also having an all z-wave outage problem. None of the z-wave products work, and I cannot find out which one is causing problem or if there even is one culprit. ST support person suggested power cycling hub but it’s something I already tried (and again) which still didn’t fix the problem. Repair z-wave utility is no help either.

I took one z-wave device - aeon lab multi sensor - and removed it from all the routines/apps. I think I unpaired it from the network successfully because the blinking light that indicates unpaired status. When I try to re-pair and add it back to ST it halts in the process. App shows spinning circle of ‘looking for the device’ and the blinking light goes solid which probably means it is talking to the hub, yet it never gets added. On the log I don’t see particular error except ‘Socket is unhealthy’, but a lot more ‘Connection is healthy’ signs.

Has anybody dealt with z-wave problem like this?

Thanks


(Tutu) #16

This definitely looks like my issue right now. Unfortunately I have nearly 50 devices which are now unresponsive/unavailable (all z-wave) and i dont want to try remove/re-add until I’ve found the culprit. Switches and relays are all showing as unavailable. Door/motion sensors and other battery powered z-wave devices are showing as online in IDE but are unresponsive. All zigbee and other products are working.

For now I’ve tried turning device health off, power cycling the hub as well as wall switchs via breaker, and running zwave repair with no luck. Can’t seem to pinpoint anything in live logging that might be doing this either.

Any tips on narrowing down the problem?


(Ken) #17

I recently had all of my Zwave devices become unavailable. I reset the hub several times and ran zwave repair, but nothing worked. I rembered that two of my kwikset locks became unavailable over the last few weeks and I had to reset them. So I took the battery packs out of all five kwikset locks and reset my hub. All of my other zwave switches started working again. I then went to each lock and reinserted the battery packs and everything is up and running again. I don’t know if this will help anyone, but if you have kwikset locks, you might want to check them out first.


(Tutu) #18

I reached out to support and they helped me resolve my issue. Below were the exact steps. Took several tries, but everything is working now without having to delete any devices or rules. Note that per the steps below, it doesn’t actually add any devices in the “add a new thing screen” and the add device screen won’t update, it will continue to pinwheel and say looking for devices, but the already added device came back online for me after power cycling a few times. Hope this helps someone else!

Here are the steps:

"What I am going to have you do for any future and current offline devices is to perform a “rejoin” of the device. A rejoin basically tells the device to look for the best possible connection for that one device as opposed to the “z-wave network repair” which tells all devices to look. I wouldn’t do any more repairs at this point as that resets all the connections that this rejoin will repair.

Here is how to do a rejoin of offline or non-working z-wave devices:

First, put the Hub in inclusion mode. Do this by tapping on the “My Home” tab, going to the bottom of the “things” list, and then tapping on “add a thing”. While it is in this “looking for devices” screen, go to step 2.
On any device that is offline, please simply switch it on and off a few times. Start with the devices that are closest to the Hub first. This should get the device to show up again as online and should get it to find a new connection point to the Z-wave network. Please repeat this for any devices that fall offline or do not respond to commands. Make sure to not do a Z-wave network repair as it will break these new connections. Once finished rejoining a device, exit the “add a thing” screen and see if the device responds and is online after about 20 seconds. Note: you will not see any devices getting added on this “looking for devices” screen, it is simply used for getting the Hub in the right mode.
Go ahead and try that out for any of your offline or non-responding devices and let me know if you are having issues getting them back online."