[DISCONTINUED] Blink Camera Device Handler/SmartApp

Blink disabled api so this SmartApp no longer works.


Awesome… will check it out this weekend. Thanks!

I just released a new version that supports taking photos and enabling/disabling the cameras.

I just released version 1.3 of this Device Handler and SmartApp which has the following changes:

  • Supports multiple cameras.

  • Can Arm/disarm, add cameras, and view status of cameras and sync module from the SmartApp

  • The device’s refresh button reloads the camera’s home screen photo.

  • Events deleted in the Blink SmartApp get removed from the device handler’s event list.

  • Replaced the CarouselTile with the HtmlTile, but since it’s not officially supported yet, it could stop working at any time.

  • Images no longer appear in the camera’s activity feed and the only place they get stored is the device handler’s state variable.

  • After taking a photo or loading an event image, you can refresh the displayed image by going to the Device Handler’s SmartApps tab and then back to the Right Now tab.

See the first post for the latest version


This is great, thank you for creating and sharing this! Would it be possible to select which cameras were enabled for Armed Stay vs Armed Away?

Also, using this app I’m not seeing the Blink system arm when SHM arms but everything works with manual control. Any ideas why? Using redloro’s app the Blink system successfully arms and disarms based on mode and I assumed this one would arm/disarm Blink based on SHM status.

Update: Disabling SHM integration and re-enabling it fixed the issue with SHM arming and Blink arming not being in sync. I’m guessing it’s another Android app bug. It would be great to see the Stay vs Away options for arming indoor vs outdoor cameras.

Thanks Kevin. I tried your device and smartapp and it worked in term of capture picture and displaying the temp. I have not tried the SHM yet.

So you’re all set with the basic SHM arming/disarming functionality, right?

I’ll take a look at the SHM section the next time I make changes because I’m probably not refreshing the cameras after they’re armed by SHM causing them to not appear armed until it polls.

In theory, that should be easy enough to do, but depending on how many cameras you have, it may run into problems with exceeding the maximum execution time.

I only have 3 cameras, but I’ll play around with it and if it works OK, I’ll add it to the next version.

FYI, in the next version, when you select a camera from the main menu of the SmartApp, it will show all the settings of that camera, allow you to enable/disable it and take a photo.

I’m glad it’s working OK for you. Just be aware that when you take a photo, the image being displayed doesn’t automatically refresh, but you can force it to refresh by switching to the SmartApps tab and then back to the Right Now tab or by closing the device and re-opening it.

My version reports motion when armed, but the notification will be a few minutes late because it only sends them when it polls.

I want to add immediate motion events,the ability to change all the camera settings (recording length, audio enabled, motion sensitivity, etc.), and Live Streaming, but Blink hasn’t released their API specs with anyone except rboy so the only way you can get those features is to purchase his version.

Correct, SHM functionality is good after the disable/enable.

I have 3 cameras also… :slight_smile:

thanks for creating a community version of the Blink app

I have installed both your Blink codes (as a pull from your repository) and see the Blink System Connector SmartApp listed under my apps, but when i click on it, nothing happens (i have enabled OAuth for the smartapp as well)

Not sure what’s wrong

I also tried deleting the app and it wont let me delete (says one or more users are using this app)


Quick update… i had ST delete the SmartApp, installed again, same issue

When i go to check on the SmartApp under my Location / SmartApp it has the word dev next to it,

SmartThings made a change in one of their recent updates that automatically adds the “dev” to all new SmartApps installed through the IDE. That shouldn’t cause any problems.

When you’re on the screen you mentioned that lists the SmartApps, did you try clicking the Edit link which is near the top of the page and then clicking the “Uninstall” link that will appear next to the SmartApp when it’s in the edit mode?

Before I have you start trying different things, I want to make sure you have a way to remove the SmartApp yourself instead of having to contact SmartThings every time.


i can uninstall the app from under hubs in IDE

When i try to install the app on my Phone from Marketplace, nothing happens, then the app is listed under my Smartapps

when i click on the app under smartapps, nothing happens, also no logs in IDE live logging

Was live logging open while you tried installing it?

When I get home, I’ll try a clean install and see if it’s still working for me. I’ll get back to you in a couple of hours.


Yes, i did have live logging on… did not see any logs

Thanks for your help


Quick update… installed v 1.2 (april 7) from Github and i was able to complete the install steps

Then i was able to update to 1.3 and continue using the latest code, but i cant update any settings in the SmartApp…

Not sure if that will help with the debug…


Do you mean the camera settings or settings like enabling debugging?

Are you able to see the devices in the Things list? Their names should start with "Blink - ".

I think either SmartThings or Blink changed something because the image functionality seems to have stopped working, but I’m still looking into it.

I just released version 1.4 which should fix the problems you were experiencing. If you were unable to get version 1.3 working, I recommend uninstalling it before updating to the latest version.


thanks for your help

Installed 1.4, everything works as expected :slight_smile: