[DEPRECATED] Remotec ZFM-80 specific device

Specific device driver for ZFM-80 dry contact relay module.
-parameter settings are set/changed in the preferences tile
-settings are updated when the preferences tile is closed

Implemented parameters
External switch types: Disable, Momentary NO and NC, Toggle NO and NC
Fail safe feature implemented as an optional auto shutoff timer
If enabled, relay will turn off on it’s own after the selected time, without needing a separate ST app.

I use this feature on my gas fireplaces to turn them off, as the family fires them up then takes off to parts unknown…
The ability to disable the external switch is a pretty cool feature of this module.


Damnit. I was halfway done. Thanks. :slight_smile:

1 Like

Ha, too funny man!..

@Mike_Maxwell What type of fireplace valve do you have? I have a millivolt valve and have been looking for a way to automate it, but have come up dry. Do you happen to have this type? With my “dumb” remote there is only on or off and the device is basically reversing the motor with on vs off.

No matter what it is, if it’s already got an existing external switch to control it, you can use this module to in the switches place.
No idea what a millivolt valve looks like, have a schematic you can post?

I don’t but my valve you have to hold the on/off button until your desired setting. It’s not a switch you toggle to turn on or off like some fireplace valves I have read about. Is your a toggle switch?

Yea, they are both electric. You’re outa luck unless you replace the gas valve with an electric one.
The advantage with the electric valves is that there’s no pilot light.

I’m still trying to figure this environment out. Please forgive the basic question. I have one of these installed and I wanted to switch it to this specific device type. I created a new device type, pasted this code into it, saved and published it. Now I went to devices and tried changing the device type to this new type. I get an error about a NULL number. I have tried deleting the device from the webpage and creating a new device with the same network ID (24 in my case) and it just says it is inactive and doesn’t do anything (although the properties page is nice!).

I must be missing a step here somewhere, but I just can’t figure out what I’m doing wrong. Thanks for any help!

From your description you changed the device correctly.
Not sure why switching the device failed. By deleting the actual device in the IDE, you will now have to exclude/repair the remotec. Actual devices can’t be added to the hub this way.
Delete the one you created, repair it to the hub, then switch out the device driver to the new one again.
I just re-ran through the device replacement for one of mine, so I know the source code on git hub is OK.
Also, when you copy from git hub, make sure you tick the RAW tab first, you don’t want to copy all the line numbers.

This happened to me as well when I tried. Figured the IDE was acting up and I’d try again on the weekend. Maybe not.

Yes, please do give it a shot.
I’ve got two of these, both using this device, not had the above problem. But if there is a problem with the device I would like to fix it.

Just tried it again and got the same error message, below:

Error:500: Internal Server ErrorURI:/device/updateReference
Date:Sat Feb 21 16:52:01 UTC 2015
Message:For input string: “null”

I recopied/pasted/saved/published the device type again using the “raw” method. That is much easier than flipping over to chrome (it would allow you to just highlight the code and not the line numbers) - thanks! The same result, though.

I created the device by using the app and letting it find the device. It adds it as a z-wave relay with a name of z-wave relay.

I am then going into the device in the IDE, getting into edit mode, changing the device type to the new “remotecZFM80” type and hitting the update button. Then I get the error. I have also done it with changing the name to “ZFM-80” as well - same result.


OK, I think I know what this.
Can you try again when after make the update?
Appreciate the help.

Sure, just let me know when. Looks like there may be a general IDE problem right now, too? I can’t log in there right now anyway.

Yea, me too, I guess you broke it. LOL

Well, I’ve always been good at testing… :smile:

1 Like

OK, found and fixed the bug.
Please get the latest, let me know…

1 Like

Worked great! I wish that the external switch worked like the Aeon Labs microswitch - where a toggle of the external switch from either position flipped the relay’s state. With this one, no matter which switch mode I pick, I get at least one case where I have to double flip the switch to change the state.

One note: When I selected all from the raw view I seemed to get an extra “bad” character at the end. I got a syntax compile error and it wouldn’t save. I just went to the last line and there was a red dot after the last close bracket and I deleted it. It saved fine then. I don’t think that I left any characters behind when I cleared out the old code - I did a select all and delete key. I didn’t try and duplicate this so I’m not sure exactly where it is - just mentioning it in case anyone else runs into it.


Yea, still a nice device none the less.
I think there was a missing CR/LF at end of file. I added that in for they next guy.

This may be somewhat working backwards but would someone walk me through the steps to pair (include) this switch to the network, I have spend the last 4 hours attempting to connect 4 different devices and this is the last one giving me problems…
The problem for most of these devices are the manufacture’s instructions, or lack there of. This one actually has the most content but is horribly written.

Basically i need to know how to put the switch into include and exclude from pairing mode and if someone could confirm if their app was able to pair using the specific “switch” device or the general “connect new device”?