[DEPRECATED] Remotec ZFM-80 specific device

What I noticed with these is that seem to pair better when pairing to the specific switch. And it seems to take longer than other zwave devices. Also, I pair these types of devices from an extension cord, so I can get close to the hub. Then mount in the final location. After pairing and mounting I generally run a zwave repair as well.

Thanks. I was finally able to get it included but seamed to be by pure luck. The “general exclusion” botton appears to be the key when it fails to connect right off the bat, but without status lights on most of the devices it’s hard to tell whats going on while ST is “looking”. Not sure why I am having so much difficulty connecting devices… very few when smoothly.

@Mike_Maxwell quick question regarding the Remotec ZFM80 and your custom device handler.

I’m going to be setting one up for fireplace control. The auto shut off feature, do you know if that works with the physical switches too or only when controllered via ST.

I love the thought of being safe from either controlling the relay via sw or toggle switch to auto shut off after 60 mins??

Thanks for all your excellent work. Its greatly appreciated by the community.

Auto shut off works with both, physical and zwave.

I’m curious if you or anyone else that is using this device type is seeing the same behavior I am. First my environment:

One of the fireplaces works without issue. On the other fireplace I am seeing the following behavior:

I am able to control the fireplace from both the Smartthings app, the Remotec switch and the thermostat. If I turn the fireplace on/off at the thermostat and at the Remotec I am not seeing the device status refresh in the SmartThings app. If I manually refresh the device then it will show the correct status.

Has anyone else noticed this behavior? Is this caused by a defective unit?

When I try add this DTH from repo I get the following error.

“Updated 0 devices and created 0 new devices (1 skipped due to errors)”

Any thoughts?

1 Like

I can’t seem to find the specific switch type within the smartthings app in order to add it. I also can’t seem to get it into include mode for the app to recognize it.

Just updated to this new DTH. As far as the settings go, I’m not sure which EXTERNAL SWITCH MODE: Momentary NO, NC, Toggle NO, NC. Some help with the choice would be great.

thanks

Hey everyone.

I’m really having trouble getting the external button to work. Anybody else having trouble with that? I’m trying to use this as my doorbell. Basically hook my existing wired doorbell button to this and then have core trigger my aeon doorbell. When I select Momentary NO, nothing happens. Well actually it disables the built in button, but nothing else. When I (wrongly) choose Momentary NC, the relay turns on for a sec and then right back of. But again, no external button function. When I enable the garage door momentary on function, it only seems to work for the built in button. When I turn it on in ST, it stays on and is not momentary. Any advise? I’m at a point where I believe my relay is defective…

Thanks, Andre

Doorbells are low voltage. I use mine in the garage, 120v in, no load out, dry contact hooked to my opener. This does require 120v to power up. How you do you have it wired up?

I have 120V going in to power it and then my existing normally open standard wired doorbell button to the external button terminals. It works with built in button and from the ST app. Just not the external button. I even tried shorting the terminal with a piece of wire with no success…

Where did you pick up the two wires from the doorbell button?, at the doorbell button itself? or the doorbell…
What you are trying to do should work, however there is an a.c. transformer in series with existing doorbell circuits, this transformer cannot be in any way connected to the remotec external switch inputs.
The erratic behaviour you describe suggests that it is.
If you post a schematic of what you have setup currently, that will make things much clearer to us.

The external switch type should be set to normally open, not no momentary.
The remotec should then stay on while the doorbell button is pushed, then switch off when released.
When the input is set to momentary the relay will change state with each button push, this is not what you want.

Of course I removed the original transformer and doorbell and only have the two wires that are coming directly from the doorbell button. I checked the wiring with a voltmeter. Measured the two wires: open, had my wife push the button: closed. I even removed the external button and just shorted the terminal with a piece of wire.

I strongly believe there is something wrong with my relay… Your code looks fine, my wiring is correct and yet it doesn’t work. I’ll probably open it and maybe solder my external button in parallel with the internal button… That should do it. …Unless you have some other advise.

Thanks again.

That device supports having the external switch contacts disabled, wondering if it’s stuck in that configuration…

I said screw it… Opened it up, soldered some wires from the terminals to the mini switch and hurray, success!

@Mike_Maxwell Thanks! This looks awesome. I’m waiting on my ZFM-80 to arrive to set this up. I already switched out the fan blower for a standard GE smart switch. The fireplace switch is in the same gang box as the blower switch. Can I just place this in the same place as the old switch and power it from a pig tail from the blower load wire and then pig tail to the neutral bundle in the gang box? I understand from other posts that I’ll need to dremmel out the face plate a little to allow the ZFM-80 to fit, but I think I can manage that and still have it look acceptable to the wife.

Where did you buy the ZFM-80? I can’t find it anywhere.

Amazon

I’ve purchased and installed 3 of these from Amazon.

1 Like