[DEPRECATED] Ecobee DTH and Helper SmartApps

Current Release: Ecobee Suite v1.4.* (Still Free)

Please see the latest release below:

I am pleased to announce a major update to my Open Source enhancements to the Freeware Ecobee DTH and suite of supporting SmartApps. This is an extension of the fantastic work done originally by Sean Stryker @StrykerSKS

Now with Ask Alexa Message Queue Integration!!! For users of Michael Struck’s most awesome Ask Alexa, you can now have your Ecobee Alerts and Reminders sent to Ask Alexa Message Queues, where they can be “read” to you by Alexa!

Enhanced User Experience Buttons, Icons and Status displays now update in near-real time, and buttons that are unavailable in the current Mode/Program/State are dynamically greyed out. The Routines/Modes/Programs Helper SmartApp now allows you to specify minimum fan on time per Program, and also to cancel a Vacation hold based on SmartThings Routines or Modes.

If you would like to try out the Device Types and SmartApp, you can follow the instructions on my GitHub SmartThings repository:

For those familiar with using SmartThings/GitHub integration, the particulars you need are:

Owner: SANdood
Name: SmartThingsPublic
Branch: StorageAnarchy-Ecobee

You will need to get ALL the .groovy SmartApps under the SmartThings directory whose names start with ecobee, as well as the two DTHs in deviceTypes under the SmartThings directory. More information is in the Readme file linked in the GitHUB directory linked above.


As noted, this work is fully Open Source, and available for use at no charge. However, if you would like to make a donation, you can send it to me at https://paypal.me/BarryABurke


Any idea if this will work with the Carrier Cor? The standard Ecobee DTH works with a couple small issues but was hoping for something better.

Edit: Meh - I’ll try it and let YOU know :slight_smile:

Edit2: Most of the functionality didn’t work with the Carrier Cor. The temperature and humidity shows and you can change the temperature but everything else basically didn’t work. It showed the routines but pressing them didn’t do anything. Just posting this in case any other unfortunate soul has the Carrier Cor and wants to try this.

I got this while installing ecobee-connect.groovy

startup failed: script148967686507954372022.groovy: 1582: unexpected token: switch @ line 1582, column 18. switch (it.value.hvacMode) { ^ 1 error

I’m getting an error when I try to install ecobee-connect.groovy

startup failed: script148967705899254372022.groovy: 1582: unexpected token: switch @ line 1582, column 18. switch (it.value.hvacMode) { ^ 1 error

I should note that I started from scratch. I deleted all devices and smartapps before I tried to install the v1.0.2 release.

@xdreamwalker, @RobMan, @lbreggi

Please grab the 1.0.2a - cat-on-the-keyboard typo… sorry about that. Never let cats write code…

That installed just fine. Thanks for the quick update.

Note that the issues reported above by @xdreamwalker & @RobMan have been repaired.

Note also that my version is now available via SmartThings/GitHub integration. See [here] ([RELEASE] The Best FREE Ecobee DTH and Helper SmartApps - Now with Ask Alexa Message Queue Support, and an Enhanced User Experience!) for more information.

@RobMan -

Well, did it work with your Carrier Cor? If not, let me know and I’ll try to make it work!

Most of the functionality didn’t work with the Carrier Cor. The temperature and humidity shows and you can change the temperature but everything else basically didn’t work. It showed the routines but pressing them didn’t do anything.

Hmmm…odd. I’ll do a little research…

Also Motion doesn’t work but that is also not working with the default ecobee smartapp.

So, from what I can tell:

  • the Cor doesn’t have a motion/occupancy sensor, and doesn’t support external sensors
  • the Cor supports Climates/Programs/Profiles “Wake”, “Home”, “Away”, “Sleep”
  • the Cor supports an external humidifier, and dehumidification (not sure if it’s by AC only, or with a separate device)

If you want me to figure out how to make Program changes work, you could turn on Debug Level 5, enable Live Logging for the device, and then try changing the Program from the SmartThings device - hopefully the log will capture an API error that I can track down…

Also, it appears that the Carrier Cor can disable remote API-driven schedule/Profile/Program changes…you have to Enable this from the Cor itself:

@storageanarchy, @StrykerSKS
Hi Barry and Sean,

Thanks for your work, guys. I’m encouraged by this effort to benefit the ST community. One thing I’m not 100% clear on:

Does this set of DTH and Apps for the Ecobee support averaging in temps from third-party sensors similar to this:

Just curious. This is one of the most important functionalities for my purposes.


I’m sorry, at present neither my version nor Sean’s supports averaging temperatures using non-Ecobee sensors (we just let the Ecobee does the job it is designed to do). I’m not aware of any free/open source version that does.

Thanks for the clarification, Barry, and please do keep up the good work.

Updates posted today adds support for Health Check in both thermostat and sensor devices. Also, the thermostat date and time of the last poll response is displayed on either side of the “Command Center” display.

I have also begun the work to support thermostats in time zones/zip codes different from the SmartThings’ hub location. This will allow for ST thermostat devices for other locations, even if there isn’t a ST hub at that location. This isn’t quite complete yet, but it should work (and not crash) - weather icons might not change from night/day correctly, and a few other oddities might still exist.

I’ve read most of the post on this thread, but did not notice this. I have three “Helper” apps set up to change ecobee mode to Away, when my goodbye routine runs, Home when “I’m Back” runs, and Sleep, when Good Night runs. It seems be working as far as the ecobees (I have 2), do change to those modes, but the Smartthings Ecobee (Connect) app shows them as Auto Away.

Heres a quick screen shot from the Ecobee App and Smartthings App. I clicked refresh, closed the app, etc. I updated all apps and device handlers to the most current version as of today.

I am currently in Home mode on my ecobee, when I took these screen shots

Update: I just noticed that My downstairs Ecobee shows the correct Mode of HOME. Additionally when I tried to manually change the mode to “Home” it went right back to away. Screen Capture attached

Hmmm…it appears that Upstairs thinks the default program is Auto Away…do you use the Smart Home/Away feature on Upstairs but not on Downstairs?

If you’re going to let SmartThings manage Home/Away, you might want to turn off this feature on the Thermostat.

That said, Ecobee (Connect) should handle the situation. I’m going to need to ask you to capture some info for me so I can chase this down. I’ll send instructions in a PM…

Thanks Barry and Stryker. I set this up on my Ecobee3 Lite with 2 remote sensors. So far it is working beautifully. I’m getting data from all of the sensors. For the Smartapps I have only tested out the Routines/Programs. It is successfully switching the mode of the thermostat based on Hello Modes.