[OBSOLETE] Updated Open Source Ecobee Device Type and SmartApps

NOTICE: Please see the General Release announcement here.

The BETA has been completed, and this version has been deprecated.


Great work here!

I’ll hopefully be able to get this integrated back into the branch sooner than later, but will need at least a few weeks.

In the meantime, any feedback that others have will be very helpful as I start to look it over.


Hi Barry,
Thank you for this open source contribution!

I want to be sure I understand correctly - the first main SA should be published and the 5 child apps should not be published, correct? Not sure I will get to this tonight, but very happy to explore/ test it out.

Thank you again,

1 Like

I am getting this error when installing child app (sensor)

and this error with the thermostat child app… the other 3 installed successfully (not published)

ugh —probably DTH’s and not SA ? ? I just didn’t see the “device type” in the header ?

sorry for all the questions.

[quote=“femwitjava, post:7, topic:75836”]
ugh —probably DTH’s and not SA ? ? I just didn’t see the “device type” in the header ?
[/quote] I am guessing you didn’t see the Installation Instructions? Here is the link for the excellent step by step install instructions that are very helpful. Just follow them a step at a time because he has it all broken out in smartapp installs separate from the device handlers plus some warnings to heed.

@storageanarchy I did the installation using the “risky” copy-over-existing-code save/publish and everything seems to be just fine. Even the ecobee-Connect kept all it’s config’s intact even showing I didn’t need to re-authorize back to ecobee servers but I did it anyway. I also added the Helper SmartApps just 'cuz I thought everything seems great.

-Like the decimal point option.
-When I change the setpoint there isn’t any visual feedback so I ended up tapping several times before I noticed the setpoint was changing at the slider bar.

Question: what do I need to enter for adding your github repo for

for properly configuring these new smartapps and device handlers so any updates will show up in my IDE? I simply copied over the existing so right now it is tied back to @StrykerSKS repo. I guessed and it didn’t add it in when Owner:SANdood Name:Ecobee Branch:master

1 Like

Great News - glad to hear it worked for you!

Changing the setpoint is a long turn-around operation. First the DTH has to detect the changes, with up to a 5-second delay (you can shorted this in preferences. Then it gets sent to the Ecobee cloud. Then it appears to have to make the full round trip to the thermostat, back to Ecobee, where it is then picked up on the next poll from the (Connect) SmartApp. I’ve tried forcing the poll in the code itself, but it always seems to take a while before the API reports the change.

I’ll look into it and see if there’s something more that can be done to get feedback sooner…(maybe I’ll just cheat, and update the setpoint directly, before getting confirmation from the Ecobee API).

To keep things simple, I didn’t integrate with the SmartThings github support yet - that’s part of why this is called "BETA. I think @StrykerSKS is going to merge these changes back into his repository, once he has a chance to test it out himself.

What I was thinking was not getting the actual feedback (which would be ideal) but feedback that when I touched the correct portion of the screen that the screen button itself would change. right now when I touch the arrow up / down screen I can’t tell the smartapp is registering an input from my touch. For example like when I touch the ecobee refresh icon it changes background to show it recognized my touch.

[quote=“storageanarchy, post:9, topic:75836”]
To keep things simple, I didn’t integrate with the SmartThings github support yet - that’s part of why this is called "BETA.
[/quote] I don’t quite understand. Isn’t BETA exactly when you want github integration because you will be making tweaks as you find bugs?

Well, that part of the UI (the multiAttributeTile) is entirely under control of SmartThings - it is an “opaque” utility - there are specific values that can be set to appear on the tile, but there is no control over how it operates.

Looking at the code, it DOES try to update the thermostat’s setpoint, so the line of text at the bottom that says “Heating to XX” should change, but it could be a few seconds after you hit up/down.

Sorry, wish we could do more, but it is out of our control…perhaps you could log an enhancement request to SmartThings :slight_smile:

Yes, but in discussions with @StrykerSKS, we’ve agreed we really don’t want a separate branch. So since he’s going to (at least consider) merging back into his, I didn’t make the investment.

I’ll make a deal - if he decides NOT to merge into his branch, I will do the integration into SmartThings github. OK?

1 Like


Apparently, the settings.fanMinOnTime value does not reflect or control fan circulation while the thermostat is in Vacation mode. Need to look into reporting and modifying event.(active vacation).fanOnTime instead (within Ecobee (Connect), possibly silently/transparently).

So, for now the FanOn display is only accurate if not in Vacation mode…

Update 2017-01-29 @ 8:50pm EST fixes this issue. Note that there are 3 files required to update (see master post at top of this thread), and a new preference setting is required to be turned on in order to enable adjustments during Vacation mode.

1 Like

Hi Barry,
I want to wipe the slate clean and start from scratch - I will PRINT and use the install guide as Dale pointed out to me.

I seem to be having trouble even deleting the SA’s I am getting errors all over Mobile app side and direct in IDE … I removed the devices and hit delete.

I will try again later, I started that too late (for me) last night and need to step away for awhile and come back with fresh eyes/brain waves

I really appreciate community dev’s who release in the spirit of open source. Thank you for the revival!
Stay tuned,

I got this up and running but encountered quite a few errors. The main issue I had was that it kept saying I wasn’t authorized to perform this action when trying to use the ecobee (Connect) app, which I solved by enabling OAuth in the IDE. This should maybe be added to the installation instructions? I also was not getting a temperature reading at the thermostat at first, it just showed 0 degrees, but that resolved after 5-10 mins.

Now my only question is, can non-ecobee sensors be integrated in? I have a couple motion sensors that also report temperature. I tried running the ecobee Smart Circulation app but got a message that an unexpected error occurred. Is this because I only have one ecobee sensor?


No, Smart Circulation should work with anything that reports temperature - it doesn’t check if they are ecobee or not.

What exactly are the errors you are seeing?

The Thermostat device crashes the mobile app when I click it- It also has no temperature display. I’m on a iPhone 7. My additional sensor works fine.

stopped the crashing by only using the work around for multiAttributeTile- but I have no data being displayed - no temperature etc.

Hmm…odd - I use on an iPhone 7 also with no problems. Sorry that it is crashing for you…

Was this a fresh install? If so, did you enable Oauth? (I just updated the INSTALL doc to call out this requirement specifically).

If you could capture the errors in live logging for both the Ecobee (Connect) app and the Thermostat device when it crashes, that would be helpful…