Check me, Did I miss anything: Suspected Zigbee Radio Failure (Hub v.2)

All:

Need a quick double check. Woke up this morning with no response on the zigbee side of my system.

I’ve restarted the hub (Physically and in the IDE)
I’ve left the hub offline for > 20 minutes with no batteries and restarted it
I’ve moved a sengled bulb close to the hub
I’ve tried to verify no channel overlap with Wifi (Wifi AP’s are even in different rooms)

Everything Zigbee is unresponsive in both New and Classic and show offline in New.

I think I’ve got a dead Zigbee radio - anyone have anything else to check before I bite the bullet and go for a new hub?

Does zigbee show as functional in IDE? Your hub is not next to a wireless router? No usb cables near the hub?

As always, contact ST and let them investigate.

1 Like

Yes It sure does unfortunately @jkp - good pointer. I pointed at the screen and yelled “Liar!” at it…

Ticket already opened.

Oh - and no… My WiFi gear is in completely different rooms…

Keep us posted!

1 Like

The USB is just due to the recent post about USB 3.0 cables/devices can be noisy in a harmful level.

I will tag @BroderickCarlin, he might can help you to verify the issue, and state the time of death.

There are some similar topics,

This was some sort of interference.

No cables nearby and only other 2.5 ghz radios are on opposite ends of the house on channels that *shouldn’t overlap. As suddenly as it dropped I’m beginning to think dead.

1 Like

Yikes, and with no backup utility to help recover either! I’m on a v2 hub with a ton of devices, and if there’s one thing that keeps me up at night with my hub is the fact that we have no backup and I’d have to start all over again.

You’d think that over the years that ST has been around that we’d have this capability by now, especially considering others already do, like Hubitat.

2 Likes

Truth, John.

I have both a new v. 3 hub and a Hubitat hub sitting on my desk. I get to make up my mind tonight on which direction I’m going. Having a backup would have made this a no brainer… Having to transfer 145+ physical devices doesn’t look fun no matter what way you slice it.

2 Likes

Experienced something similar last weekend…
I also tried rebooting and suddenly it all came back… Very strange…!
One thing though: have you tried unplugging your mains powered Zigbee devices (smart plugs etc.) and power them up again…?
I used to have a Sylvania plug that needed a reboot once in a while, because it made my Zigbee mesh hang…

Yes. Many. Many times… I also reset one and it will not rejoin. The add device screen just spins and spins.

Hey @nathancu,
What you are describing sounds just like an interference issue. An initial look at your hub shows that the Zigbee radio is fully functional but that it is unable to transmit any messages to devices. One of the most common issues we see in these cases is interference caused by USB 3.0 devices. It can be anything from a USB harddrive to a USB 3.0 hub that you have recently purchased/powered. I saw mention of USB cables above, but just wanted to clarify that it isn’t necessarily cables that are the issue but USB 3.0 devices in general.

One test that may be easy to do is to try and move the hub itself. I saw you mentioned you brought some devices closer to the hub but if it is in-fact an interference issue I wouldn’t expect this to actually help.

Whitepaper about USB 3.0 interference in the 2.4GHz band: https://www.intel.com/content/dam/www/public/us/en/documents/white-papers/usb3-frequency-interference-paper.pdf

3 Likes

Hey @BroderickCarlin, thanks for taking a look. I was hoping I’d get past the 1st tier of support by now, but they’re still asking me what version of the client I’m using and to turn things on and off again… :frowning: I get, it, I was a software support manager for 12 years - but the process is SLOOOOOW.

ANYWAY. I’m pretty convinced it’s not interference at this point because:

  1. There is literally nothing in my office (where the hub lives) that is active on USB 3. I have one usb 3 portable drive I only use for File History on occasion and my phone - but they are not connected in my office and have not been for over two weeks. I DID power off my USB hub that sits on my desktop about 4’ from the hub just in case that was it - no joy. Also note this USB hub has been in the same place in relation to my ST Hub for almost a year with no issue.
  2. There have been no adds / moves of any of the devices in my office for over 2 weeks (yes a few power cycles here and there, but no sudden activation - I’m an always on kind of person)
  3. I have moved the ST hub closer to zigbee devices, (I have a 25’ lan cable available - yay Zwave locks)
  4. I have moved devices literally on top of the hub
  5. I have tried joining DIFFERENT zigbee devices (I have a few known good Sengled bulbs and some peanut plugs lying around) Nothing joins in either New or Classic - it just spins and spins.
  6. I have no 2.4Ghz Wifi anywhere within 25’ of the hub and what I have are on verified non overlapping channels. (Hub is on Zigbee channel 19 - APs are Linksys Velop Mesh - on Wifi ch. 11 - two nodes, one on each end of the house where the ST hub is near the middle)
  7. It was a sudden failure. Last good operation was at about 11:30P Central two days ago. The wife woke the next morning at about 0530 Central and the lamp automation for our bedroom when she gets out of bed triggered, but did not change the lamps successfully. that means it happened sometime during a 6 hour window where nobody was awake. I could conceivably see a situation where a wifi node suddenly jumped channels during an optimization, but they’re still on 11 where they should be…
  8. Neighbor’s WiFi should not be an issue. I’m in a rural neighborhood on an acre - They’re barely in range to see their SSID, let alone interfere.

If you saw my setup, then you know I’m absolutely into trying literally ANYTHING else because the thought of transferring all of this to another hub is TERRIBLE (If there’s a hub backup/restore/transfer beta, have the person in that program call me - dear lord the more I look at this the more I get depressed.) Everyone says the radio appears to be working, but on my end it’s like theres no antenna there.

And now I’m REALLY Confused. I tried another join attempt (with the nearby Sengled bulb and the hub in its original location) after I wrote that last note

@BroderickCarlin - is this a Zigbee Join message in my hub log at 10:07?

zbjoin: {"dni":"57D5","d":"000D6F000B1DF912","capabilities":"80","endpoints":[],"parent":"D071","joinType":16,"joinDurationMs":0,"joinAttempts":1}

The device didn’t join (Device 57D5 is the contact sensor on my master bedroom door) but if I see the join ATTEMPT in the log, that means the radio is working? The device parent in the call is D071, which is the Peanut in my kitchen. It is my strongest repeater - maybe it went bad?

Try to unplug everything and build the mesh repeater-by-repeater.
If a repeater is the problem, then you will see the battery powered devices to connect nearby to the Hub.

1 Like

What I can unplug, most of my Zigbee is battery powered and Sengleds - which I chose because they dont repeat… :slight_smile: But yeah sounds like a plan. The fact the hub saw SOMETHING (If I’m reading that log entry correctly) gives me enough hope not to trash the setup yet.

1 Like

Do you have an SDR sitting in one your drawers waiting for some fancy radio project?

You can search for sources of interference with that:

https://www.rtl-sdr.com/rtl-sdr-spectrum-analyzer/

1 Like

HA I wish… Sorry no. My only projects right now include flooring and replacing a wired security system (Which is powered off and in a box, in another room at the moment…)

1 Like

I had the same thing happen to me last weekend. I tried rebooting the Hub 10-20 times which didn’t fix it. I don’t have batteries inside my Hub either. So I got my spare brand new Hub out of storage (wanted a backup Hub since this is the heart of the system). Anyway, after adding the new Hub to my account in a new location, it did not work either when trying to connect a brand new spare smartbulb. Wow!!! I then unplugged all of my electronics, home entertainment system, computers, wireless routers, cable modem, turned off my UPS’s, took the batteries out of all of my motion sensors, unplugged all my SmartThings power outlets, etc, but the Zigbee mesh was still down.

So on Monday I did the unbelievable. What I did was go out to my breaker panel and shut off every breaker switch to my place to simulate a power outage. After I flipped all my breakers back on, well I couldn’t believe it, but all of my SmartThings Zigbee devices came back online. Who knows what it was. Maybe some other non wireless appliance in my place. I haven’t got a clue.

Good luck…

3 Likes

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.