Serious Connectivity Problems with Zigbee Devices

I’ve had SmartThings for many years and everything has been working flawlessly the entire time, until recently. I have 18 total devices on a V2 hub, 8 of them are Zigbee. For some reason, all the Zigbee devices are unresponsive and they are showing offline in my app and on the advanced web app. I have some lightbulbs, a motion sensor, a button, and an led strip light. All of them aren’t working.

I’ve tried everything. I’ve deleted the devices in the app and tried to repair them, they don’t show up. I’ve tried just repairing them without deleting, nothing. I rebooted the hub, unplugged it (took the batteries out). I’ve made sure unsecured rejoin is enabled, I’ve changed Zigbee channels, and I’ve verified the Zigbee radio is functional in the advanced web app.

Is anyone else having the same problems? Any ideas on how to get the Zigbee devices working again?

First… is the hub near any networking equipment that could cause and interference or examined the channels used by the ST hub and wifi in your home.

Seems something odd may be going on. There’s another discussion about this. I ended up rebooting my hub and all seems to be well for the most part. Some slow commands but at least everything is staying online :crossed_fingers:

Yes, the hub is a few feet away from a Google WiFi router. But it’s been that way for years and everything has been working great until recently.

But guess what? Everything started working again!!! I have no idea why or what changed. The devices slowly started to come back online and I was able to add back the few that I deleted. So all good for now. Hopefully it was a strange one-time problem.

1 Like

Dang…same problem I’m having, too. I have tried just about everything you have. Praying it starts working like yours.

1 Like

Well, I spoke too soon. Seems like all my Zigbee devices are having problems again. Some are now showing as offline while others are saying they are online but they aren’t responding. This is all so very strange and frustrating.

Could this be something wrong with the SmartThings service? It makes no sense how nothing has changed and now all of a sudden, the Zigbee devices are having problems again.

contact ST aupport

try powering down your hub for 20 minutes (remove batteries with v2 hub).

I powered down the hub and took out the batteries for around 30 minutes, turned it back on and the Zigbee devices still aren’t working. And the weird thing is some of the Zigbee devices say they are online but they don’t work. They are all messed up.

I guess I’ll just have to contact SmartThings support.

Ok, I think I figured out where the problems are coming from. My Xbox!! I was playing some games last night while trying to troubleshoot the Zigbee problems, resetting the hub and whatnot. I was noticing that my wireless Xbox controllers kept disconnecting and then connecting again. Then it dawned on me, the Xbox wireless controller signal is the same wireless frequency as Zigbee (2.4GHz). (EDIT: After some more research, I think the Xbox wireless controller protocol runs off of a proprietary 5GHz frequency. Regardless, something from the Xbox is causing interference with my Zigbee network)

I just did a test, I turned on the Xbox and played for a little bit, all the Zigbee devices were unresponsive (still showing as online, just not working at all). As soon as I turned off the Xbox, they started working again.

This is incredibly strange because I’ve been playing Xbox for many years with the exact same setup with no problems whatsoever. The Xbox and the SmartThings hub are pretty close to each other, but everything has worked for years, no idea why there is really bad interference now for some reason.

Any ideas on what to do next? My Zigbee devices are currently using channel 24, would it help if I moved them to another channel? Would I have to re-connected all of them after changing the channel?

@brenthaag Do you happen to have an Xbox and are using it when your problems pop up?

If the ST hub and Xbox are within 10 feet of each other… move one of them.

I know… you have had them that way for years… could be an update on the Xbox… could be ST… you could have neighbors that changed something and together they are causing issues now. Doubt you will ever know but best advice is to move ST hub away from any other networking device, tv or device with usb ports.

I do not. However, after opening a ticket, moving the hub, and multiple reboots, etc., I finally have a few Zigbee devices back online. The ones that aren’t, I think I’m going to have to remove and re-pair (which is not going to be fun). Oddly enough the ST branded devices reconnected easily (without repairing)…non-ST ones are still offline.

Yeah, I might have to try that. The problem is I’m not sure how to move one or the other, my internet router is in the corner of my living room and I can’t really run long cables elsewhere.

If I change Zigbee channels on my hub, do I have to reconnect the devices? Or do they automatically reconnect? I might give that a shot before trying to move stuff.

I moved all of mine to channel 25 but this was before the Edge migration. If I remember correctly all of my devices changed on their own. I think it took a few hours before everything came online again. It worked well for me but may not for everyone. There are a lot of other posts recently about Zigbee problems and devices going offline so it may not help. I did read someplace about some of the older devices not being able to switch automatically. I would definitely make this a last resort.

1 Like

I would try moving/separating the router–even a couple feet. I don’t know if that was my issue, but it seems like that was a good source of it.


I have some good news and bad news. The good news, I was able to sort through the mess of cables in my cabinet where the hub was located and I moved it maybe 5/6 feet away from the Xbox. And that seemed to fix the Zigbee problems! I can now have the Xbox on and still use all my Zigbee devices.

The bad news is, for some reason my Xbox controllers are still randomly disconnecting/reconnecting. And it’s happening with two different controllers, so I know they aren’t the problem. Sometimes everything will work fine for 30 minutes and then the controller will disconnect and reconnect. One time it was disconnecting constantly, like every 30 seconds to 1 minute. So I unplugged the hub and took out the batteries, the controller started working again and stayed connected while the hub was shut down so I’m pretty sure the hub is causing the problems.

At this point I’m thinking about just ditching the V2 hub because it’s so old and migrating everything to the new Aeotec hub. It’s probably not worth my time/energy to troubleshoot and fix this problem because if it’s a hardware issue with the V2 hub then there’s really nothing I can do anyway.

Probably just a reminder but:

  1. The V3/Aeotec hub is still a 5 year old device and has half the memory as the 8yo V2 hub.

  2. There is a new ability to migrate from one hub to another that might reduce the pain of moving but some are reporting errors. SmartThings staff is blaming the use of (some) community-developed edge drivers.

If you don’t have any Z-wave devices the SmartThings Station might be an option, at least it’s a new device. I don’t know if the hub migration feature will work at all going from a V2 hub to the Station.

If the hub migration feature doesn’t work you’ll have to remove and reset your devices one-by-one and add them to your new hub, then manually recreate any automations.


I don’t see what moving off the V2 does at all here? I’d not bother.

Sometimes interference is a matter of centimeters left or right, and it’s very conditional. There’s a Homeassistant video on thier channel that talks about how easily a Zigbee signal can be literally Stopped by nothing more than being in close proximity to a USB3 SSD (they hold a coordinator stick over a SSD, no signal. Move it 6’ away and boom signal) so I’m pretty sure you’re on track moving the hub.

Other things that can give issues maybe you wifi 2.4 channychanged recently?

But in short the Xbox controllers are not the culprit for this issue (as you noted they’re a 5ghz custom comm) and they definitely can’t be impacted by your st hub. So while you have issues with them. I’d be more concerned with wifi signals than the hub and now that zigbee is up that’s where I stop. Anything else you’re just making busy work for yourself. Go troubleshoot those controllers. :wink:


Thanks for the suggestions. I was just thinking that since the newer Aeotec hub can be run over WiFi, I could try and set it up and then move it further away from everything (Xbox and my WiFi router). Unless I figure out something crazy with long ethernet cables, I’ve moved my V2 hub as far away as possible since it needs to be hard wired. But like @HalD said, if the hub migration feature doesn’t work then it’ll be a huge pain in the butt to get everything back up and running. And I do have a number of Z-Wave devices currently.

Maybe I’ll do some more thorough testing but it’s very strange how I’ve owned the Xbox Series X for 3 years now and I’ve had zero problems with multiple controllers, until these Zigbee problems started popping up. The other day my controller was disconnecting/reconnecting constantly until I unplugged and shut down the V2 hub (removed the batteries), then the controller started working perfectly fine for the 5-10 minutes I had the hub shutdown.

The only other recent change was I got a new TV, a Samsung S90C. It’s currently connected to my WiFi network so maybe I’ll shut that off to see if it helps with the Xbox controller problem.

1 Like

I wish I could rip the wifi radio out of that thing. :wink:

Don’t use wifi for ‘server’ or infrastructure devices and don’t use wifi for something that is known to be subject to interference from wifi… (from a troubleshooting perspective you also complicate the test matrix)

Also see my rant on why I hate the SmartThings Station (but that’s well known at this point so I’ll spare you the soap box)

What you’re describing screams to me that something changed environmentally that is impacting your wifi networks… Turning off the xb wifi prob will not have any impact. I’m curious as to what channels your wifi APs are on.


I have a Google Nest mesh WiFi system with the main router in my living room and 1 access point upstairs. Using the “WiFi Anayzer” app, for my 2.4GHz network it looks like the main router is on channel 11 and the access point is on channel 1. Unfortunately, I don’t think I can adjust these channels as they get set automatically. For my 5GHz network, both are on channel 149. My current Zigbee channel is 24 and it’s showing version 5.6.4.

My Xbox is hard wired, I’m not using WiFi for that device.

I had this exact set up for many years with zero problems with SmartThings (Zigbee and Z-Wave devices), the Xbox, or the Google WiFi system. The only new thing is the TV that I just purchased (Samsung S90C) and that is currently using WiFi which I might turn off to see if that’s the culprit.

Before moving the SmartThings V2 hub, it was pretty much right next to the Xbox in a cabinet, separated by a thin piece of wood. But everything worked flawlessly for many years. And like I mentioned earlier, before I moved the hub, the second I turned on the Xbox, all my Zigbee devices would go unresponsive and then offline. The second I turned off the Xbox, all the devices would work instantly. This happened with the new TV on and the TV off, so I’m pretty much isolated the Zigbee problems to the Xbox. After moving the hub, the Zigbee problems seemed to go clear up but I’m still having controller disconnect/reconnect problems.

And to reiterate, I’m not using WiFi on the Xbox, so (as far as I can tell) the only other wireless signal that it’s broadcasting is whatever it’s using for the controllers, which have been constantly disconnecting/reconnecting right when all these Zigbee problems showed up. All this is too strange not to be connected somehow.