Can't Connect New Devices

I have been having an issue for several months now. Samsung support line keeps giving me the same answers like exclude device and try again. Or get closer to the hub. I have similar products and had no issue before. I have about 120 devices added already. I am trying to add a few different devices and having the same issue

When…
Adding by product. It stays on the screen “getting everything ready”. Stays like that forever and never moves to the next step when you select the location and room.

Added by scan. It finds the device. It makes me click on it to add securely. Once clicked, it says “getting everything ready” again. Same issue as above. Never gets added.

On the list of all devices, i see the new device, I click on it and it says “loading”. Then it disappears. I exclude it and do it again, Same issue. I have tried several devices. . I waited for a new update but the issue is the same. It will not let me get to the next step after “getting everything ready”. It won’t let me get to the portion where you select location or hub.

I have tried deleting and re-adding the app. I tried using different phones. I rebookted the hub. Wifi is strong and no issues managing existing devices. Just having an issue adding new ones. The hub is a Samsung Smartthings v3.

Any one else have this issue or know how to go fix?

1 Like

brand/model for some of the devices you are trying to add?

For the ones that want you to connect securely, are you providing the DSK or skipping it? Have you tried adding them via QR code?

I have a few but the ones I need is Bali sun shades and an aeotec sensor. I have both already added in the past. These are new ones i am adding

I tried the qr code. Its going to the same “getting things ready”. For the shades, there is no QR code but i have added several in the past. This just started a few months ago.

I just purchased a aeotec hub and I am having awful luck so far. I installed the Hub on the ST OK, but the first device I tried (Zooz sensor ZSR29 V2) hasn’t been working. I first downloaded the suggested new driver from Zooz and then installed the device. The install looked successful, but it keeps saying “this device hasn’t updated all of its status information yet. Check again”. I waited a few hours and same message. I tired to exclude and delete the device and it won’t go away. I next tried a Dome siren and same issues. I ended up deleting the location, and starting all over again. Same story again. Any suggestions?

  • move the hub to within inches of the device or device to the hub - whichever is easier and try excluding the devices again. Note: put the hub into exclusion and do the steps needed on the device to initiate the exclusion.
  • if unable, go to SmartThings Advanced Web App and remove it from there.
  • don’t reset your hub! ask the community questions before considering a reset but I still recommend NEVER resetting your hub. Even if ST support recommends resetting… ask the community first and still don’t reset. :slight_smile:
  • if exclusion failed above, try again after you remove it from the system. Note: put the hub into exclusion and do the steps needed on the device to initiate the exclusion. devices should to be within inches of the hub.
  • try to add device within inches of the hub… scan QR for devices that offer it

try the steps and if you continue having issues, let the community know so others can provide more assistance. They may ask for more info on the devices that they will give details on what to provide.

1 Like

That message means that the device has null values for one or more of its attributes, which the mobile apps uniquely consider matters. Typically when devices are installed the integration initialises the attributes with synthetic values to keep the apps happy but that is disabled on a number of stock drivers at the moment for some reason (my best guess is that you don’t really want it when live devices are being migrated from the legacy platform rather than installed as new). Generally time should be a healer but ‘playing’ with the device can help as that should make them report in. By ‘playing’ I mean doing the sort of thing you’d typically do with a new device to test it - turning switches on manually, breathing over temperature and humidity sensors, jumping up and down in from of motion sensors, opening and closing contact sensors etc.

Generally you don’t see the same problem with third party drivers as those still generate the synthetic events.

That said, it can also be an indication that the device hasn’t installed correctly.

1 Like

Thanks for all the help and suggestions, I will let you know how it goes. Had no idea there was an advanced web.

Take care and have a great 4th.

Did you ever get it fixed? I’m having the same issue using an older SmartThings hub. Never had this issue before till I started having to replace bad switches.

Could you provide more details. Brand/model of the devices. What is happening… can you describe what happens when you attempt to add devices or something else? Which model hub? Does older mean the v2 because many can be considered old at this point.

1 Like

I believe my SmartThings hub is a v2 as I’ve had it for years. I’m using GE smart switches and replacing them as they go bad with newer GE smart switches. This is the first time I had this problem where I install the switch and I get a message saying
This device hasn’t updated all of its status information yet. Check again later.
It says connected but is unusable. Now when I check the SmartThings app it says not connected even thought it’s a hardwired ligjt switch.
I’ve tried scanning the code to searching and adding. The same thing happens.

What Edge driver are being installed and used by the GE Switches. You may want to consider installing @philh30 Edge drivers for GE/Jasco and switching your devices to them (if you are not currently using them).

2 Likes

It’s installing


I haven’t had to ever use another driver so I’ll look into how to do that. Thanks for the help
I got the drivers installed no issue but when I select change driver in the app it says none. Others do show the new drivers.

I’ve installed the drivers but it doesn’t allow me to select them. Is there a way to assign drivers though the advanced website?

I don’t believe you will be able to switch in the Advanced Web App either for the Edge driver but you can try.

You may want to try removing and reinstalling the device(s) to check if it driver is picked up or allows you to switch the driver if it isn’t picked up when you pair. If either does not solve the problem… check if the fingerprint of the device matches what is available in the custom Edge drivers. You can find the finderprints in AWA or API Browser +. Not sure if those GE/Jasco Edge drivers are still being actively supported by the developer.

this thread provides info on finding fingerprints: https://community.smartthings.com/t/how-to-get-the-manufacturer-id-and-model-fingerprint-without-the-ide/253012

if still unsuccessful: post the brand/model/fingerprint info and hopefully other community can offer assistance for them.

2 Likes

And be sure the fingerprint shown in the AWA is valid, i.e., non-zero. The following post describes some of the symptoms and steps you can take…

3 Likes

You can find the fingerprints supported by the driver using the API Browser+ that @jkp mentioned. Go to Hubs->Your Hub->Installed Drivers->Details->Fingerprints. Compare the fingerprint of your device with those in the driver details to see if it is supported.

Philh30 doesn’t do much here these days, but @csstup has indicated he is going to be taking up support for the GE/Jasco drivers in the near future.

4 Likes

Good information, I didn’t know about this. Very useful. I was always going to their Github page and searching for the yml file. This is way easier!

3 Likes

Good to know. I was not aware that you could use the API Browser+ to check the available fingerprints in a driver.

3 Likes