New Device - Couldn't Add Device

I am having problems adding any new device. I always get “couldn’t add device. Something went wrong. Try again later.”

I have a version 3 hub and around 20 devices. I’ve tried multiple ways to add a new device. Including scanning the barcode and selecting by brand. I have Rebooted the Hub and tried reinstalling SmartThings app.

I am at a loss what to try next. Any ideas?

iOS or Android?

Brand/model of device you are attempting to add?

1 Like

Zooz Switch. Android.

Hey there! @IndyKid, Welcome to the Community! :slight_smile: I’m sorry to hear you’re having issues with onboarding your devices.

Give these troubleshooting steps a try:

  1. Attempt to add your device by the specific Model code or Scan nearby for devices ready to be connected/claimed.

  2. Ensure your Zooz device is within range of a hub-enabled device or repeater.

  3. Check the device is plugged in and/or has sufficient battery power.

  4. If you continue to have issues it is recommended to reach out to the Manufacturer.

Here is a link to get support for your specific model: Home - Zooz Support Center

I hope this message finds you well!

^SamsungZell

It is not just the single device that I’m trying to set up. It is for all devices. I cannot add any devices to SmartThings.

This is what i get if i try to add any new device.

I am having this same problem now that I never had before. Not sure if an app update broke it. I cannot add light bulbs, motion sensors, switches, outlets, nothing!
I have been using SmartThings for years to create a smart home, but things continue to break and requires continuous maintenance on my part to keep my home running smoothly. My whole family gets annoyed when things stop working, usually SmartThings is to blame. :frowning:

Are you able to exclude the devices? Do you have a support@smartthings.com support ticket # I could reference?

I have not tried to exclude devices because I get this error for all new devices. Is getting a support ticket the best way to get this problem resolved?

Probably. The community here is great but they don’t have any insight into the backend of what’s going on.

In regards to excluding, I would always recommend excluding Z-Wave devices prior to adding them. It’s a good test of functionality as well.

Same problem here !!

Can you give it another go? I think I found and resolved your issue.

Exactly the same problem with a Schlage Connect lock. If I scan the QR code I get the same screen as above. I have excluded the lock and still get the same result. I have rebooted the hub (V3) multiple times and reset the lock to factory settings multiple times. No luck. If I try to add through a search for the device it connects in a non secure mode and asks to reconnect but when I follow the prompts the screen locks (Android). If I try to connect by manually identifying the device, I still get the message that it can’t connect right now, try again later. Very frustrating.

Same thing happened to me and here is how i fixed it.

Instead of manually adding the devices, once you put the items in pairing mode (sengled bulbs for me) select SCAN FOR DEVICES instead. The bulbs (along with nearby devices) came up and i added that way.

Scanning the items barcode never worked for me.

Good luck

I see no one posted here anymore. I am having the same issue on all my android devices. Can’t add anything as the error is coming up right away. I have opened up a ticket with Support and they do not know what is happening. I have created a new account and invited to my main one. I was able to add devices this way but today it stopped working. However, on my IPHONE is still working. What is actually going on?

I fixed my issue by changing the name of the ssid for my wifi. It had a special character "underscore " that smartthings did not like. Once i changed it everything worked…

I hope this helps.

My IT experience kicked in and took this issue into my hands as I have not received any response back from Support. Just in case someone will encounter this issue, here is how to fix it. When I deleted my hub it was actually not deleted so I ended up with 2 Smarthtings hubs in my account. You can’t see it in the Android app but you can see it on IOS Iphone when you try to add a device, it will show 2 hubs. I can see that they did a better job with the IOS app. Thats a shame because none of the Samsung devices are running IOS. However, the only way you can solve this problem is to login into Smartthings IDE (https://graph-na04-useast2.api.smartthings.com/) which is their API manager and look under My hubs to see if you see a deleted hub. You can only remove the hub after you have removed any associated devices. After that you should be able to add devices again in android app. Hope that helps everyone.

1 Like

This will fail for a majority as they will not be on their appropriate SHARD. Those users would need to add the additional step of going to My Locations first and clicking on their location, then they can click on the My hubs.