SmartThings No Longer Works

I need some advice. I am not a computer expert but have been using Smartthings since the days of Iris & Lowes. I have a Samsung hub STE-ETH-250 connected to wifi door sensors, a couple of motion sensors and a light controller. As of a couple of months ago, all worked perfectly fine. Yesterday checked the Smartthings app and nothing works. Nothing connects and app lists only a couple of TVs. I have read about Samsung/Aeotec changes and just happy I have not hooked up more items. Any suggestions would be appreciated.

I’m sure that’s very frustrating. :rage:

What’s the brand and model of some of the end devices that have stopped working?

Also, there was a recent firmware update to the hubs: are any of the LEDs on the hub blinking?

OK. First check is always to make sure you are looking at the right Location. If you click on the ‘Favourites’ icon at the bottom you should see your Location name at the top of the page. If you tap on it do you see any other Locations listed or is it just the one?

You said the app lists only a couple of TVs. Are they in a room named ‘Personal Devices’ or are they in another room? Are there any other devices at all? What about the hub? If you click on the room name and select ‘All devices’ from the list of rooms that pops up does that reveal anything?

What does ‘Nothing connects’ actually mean? What are you trying to connect and how?


I think the 1st thing I need to do is get the Hub up & running. It won’t connect with a cable from router to hub. When I disconnect the router cable, the hub goes from steady green to blinking blue. But when I go to register the hub using Welcome Code, it reports - No network connection, a network or server error occurred, Try again later. (This all worked last time I used it but that was a couple of months ago) I checked the Google store for updates but found none. Thanks for your help.

Location shows correct & just one location. I think the 1st thing I need to do is get the Hub up & running. It won’t connect with a cable from router to hub. When I disconnect the router cable, the hub goes from steady green to blinking blue. But when I go to register the hub using Welcome Code, it reports - No network connection, a network or server error occurred, Try again later. (This all worked last time I used it but that was a couple of months ago) I checked the Google store for updates but found none. Thanks for your help.

I am puzzled by that description. You connected the hub to the network and the LED was green, which means it is fully registered and is working correctly. Then you disconnected it from the network and it flashed blue, which means it is setup but can’t contact SmartThings which is what you would expect if you’ve just disconnected it. Then you attempted to register the hub again?

What am I missing?

plug the hub back into its previous cable and port. reboot your router/modem.

I did attempt to register by being on wifi, that didn’t work, so I reconnected cable router - hub, have again a steady green, but when attempt to connect to SmartThings app with Welcome Code, get the following message as before - No network connection, a network or server error occurred. If I reset the hub, it flashes blue for a few seconds, then goes back to steady green. And still will not be recognized by app. Very frustrating. Thanks.

to clarify… by reset - do you mean that you unplugged the hub (and removed the batteries), pressed the reset slot with a pin and held it while you reconnected the power and waited until you got the solid yellow led on the hub?

Did as directed, hub flashed blue, then steady blue for a short time, now steady green. App still doesn’t recognize it. error - No network connection, a network or server error occurred, try again later. Thanks.

does your hub still appear on SmartThings Advanced Web App?
your phone is on the same subnet as the hub? does Router show correct DNS info for hub. hopefully you rebooted your router/modem from my earlier message.
pull the power cord (remove batteries)… power it back up after a minute. leave batteries out. if your phone is connected to wifi on same subnet, try adding the hub. if successful, reinsert batteries. if not successful… contact ST support and let they can investigate.

Yes, did as suggested, it went solid yellow, red for couple seconds, then continued to flash blue for about 8 minutes, now steady green, router IP address, still will not connect to SmartThings app, same - No Network connection etc

I am still puzzled. You are describing a V2 hub that is connected to a network, connected to the SmartThings servers, and registered to a user account. It is all systems go from the point of view of that hub.

Did you try logging into the Advanced Web App with the Samsung account you were previously using with the hub, as @jkp suggested? It would be good to assess the situation without involving your mobile app, which to me sounds like it is having far more problems than your hub is.

Have you tried your SmartThings app with the phone disconnected from your home wi-fi?

I did as you suggested, including router reboot, still solid green. No connection to app. I greatly appreciate all your help, maybe I need a new hub. Anyway I will attempt ST support but not very optimistic. Thanks. Cheers, don

ok, I am on the Advanced Web App. I does not recognize my hub despite it showing on my router, also nothing I used before is noted, it does have my location but that is about all. My hub shows a steady green. Will try and figure out how to add the hub…I don’t think SmartThings likes me… Thanks for your help.

I’m afraid there’s no way to change what’s already been done, but I did want to make sure you understand something going forward.

There are two different kinds of “resets“ that you can do on a hub: a hard reset, and a soft reset (which Samsung sometimes calls a “reboot.“)

Here’s the official support article:,flashing%20yellow%20to%20solid%20yellow.

If the app is asking for a welcome code, then either you have done a hard reset on the hub or you are trying to add it to a different location.

If you have done a hard reset on your hub, not only is it no longer known to your account, but all of the devices which were hub connected to that hub have lost their network affiliations, and they will not show up on your account anymore either. That will include pretty much everything that uses an edge driver: Zigbee, zwave, thread, Matter over WiFi.

(If the missing devices were part of a “linked service“ integration, like Ring, or Nest, then those integrations are at the account level, and they don’t care whether you have a hub or not. So in that case, it would have been more likely that the problem was that you had accidentally signed into a different location. So as always, the first rule of Home Automation, applies: “the model number matters.“)

For this reason, you never want to do a hard reset unless you are willing to rebuild most of your account from scratch.

From your description my guess is that you held the reset Long enough to trigger a hard reset. So after that, the only devices you still had on your account were LAN devices which will be automatically discovered by the new architecture equivalent of “super LAN connect.“

All of this is why, in my first post in the thread, I asked for the specific brand and models of the devices you had lost. To see if they were hub-connected devices.

As I said, I don’t know of any way to undo the effects of a hard reset. But I did want to bring it up now so you would know what the consequences might be in the future and so you could make decisions in the future about whether you wanted to do a hard reset or a soft reset.

Once you do get the hub itself up and running, then you will need to individually add each hub-connected device that you want to use. If they are Z wave devices, you will need to do a general exclude on them first. If they are Zigbee devices, they can just be individually reset.

Once you have them back in your device list, you will have to re-create your automations.

I’m sorry: I know that’s a lot of work. But for hub-connected protocols, the hub is the owner of the end devices, and if you hard reset the hub, the account no longer knows about the other devices. :thinking:

1 Like

That green light on the hub is still suggesting to me that it is set up on a different account to the one you are now using. If it is you wouldn’t be able to add it to your current account even by successfully factory resetting as it will already be ‘claimed’.

1 Like

Thanks for the explanation. My problem is I can’t get the app to recognize my Hub. I don’t mind adding the devices, but without hub recognition I can’t proceed. My hub is recognized by my router, but not the app itself.

I’m sure that’s very frustrating. :disappointed_relieved:

I agree with @jkp and @orangebucket : at this point, it sounds like your hub thinks it belongs to a different account. Unfortunately, when that happens, only official support can help you, and they have been pretty hard to get hold of since they changed to a new system in January. They seem to want everybody to use a special app, called Samsung members, and then you get what appears to be an AI assistant for the first conversations.

You can try the options on the following page, but I don’t know how well they’re working right now.

Enter “SmartThings“ in the search box there, and then they should have some contact options down at the bottom of the next page.

They will probably want you to send them a screenshot of the bottom of your hub showing the serial number.

The only account the Hub has been connected to is a SmartThings account. When I went to use the account, which I had not used recently, I was directed to “get new SmartThings app”, which I did, and the hub has not been recognized since. If I clear the hub, which I did with both a hard & soft reset along with a reboot on the router, should not the New SmartThings app connect to the hub?