Auto unlock door on arrival?


(Ken) #1

So I’m setting up my v2 and noticed there is no auto unlock door on arrival. This was huge for my wife as it helped her out a ton. Am I overlooking it or is it really not an option anymore?


#2

Does using a Routine work? Or did you need something more?


(Ken) #3

Thanks JD! That was it!


(Michael Holmes) #4

I don’t think you need to even add a new Routine. The option to unlock doors is right there under “I’m back.”


#5

Yep, “I’m back” is a routine, so same options. :sunglasses:


(Bigpunk6) #7

The problem is it does no have the same function as the unlocked when someone arrives app that was under doors and lock. It does not unlock every time someone arrives because it’s already in the routine. So if I’m home and the door is locked and my wife comes home the door will not unlock for her. This is just another thing ST did not add back after they removed the old one.


(Ken) #8

I noticed this today. We both left together and the door unlocked when we arrived. But if one of us is already home and I arrive it never unlocks. Also in the “Automatically lock door on close app” (Dont know the exact name because i deleted it) But i set it to auto lock the door after the door is closed for 3 minutes. But i noticed yesterday, if you accidentally lock the door on the way out then it will unlock the door after 3 minutes. So basically its not checking to see if the lock is already locked before it runs the command. This is a big security issue for us. The lock functionality was perfect prior to the app upgrade. I really hope this gets fixed and is being considered a priority based on the nature of the issue.


(Steven) #9

What the heck?!? I was losing my mind trying to figure out why the doors weren’t unlocking with my ‘Arrival’ Routines. The way it’s worded it seems it would fire each time a person came home… That’s how other smartapps work. So right now my doors are very flaky. I guess I need to dig up some old smartapps to handle this. Major bummer!


(Richard) #10

I have just gotten the Hub V2 and I am struggling with the routines. I am trying to make the schlage lock to unlock when I come home and it will manually work but it does not do the routine automatically even if the smartsensor is present. :frowning: Could anyone help me please ??


(Ken) #11

Do you see the routine firing in the logs but the door is just not unlocking? How many presence sensors do you have? In my recent experiences, I have two prescence sensors, one for the wife and one for me (our cell phones). If the wife is at home, and I am arriving home, the door will not unlock. But if the wife and I are both not at home and one or both of us arrive at the same time, it will unlock the door.


(Richard) #12

No, I don’t see the routine firing, that’s making me mad. I just don’t under=
stand why. I have created a new routine and by mistake I found a setting off=
time delay buried somewhere and changed from 10 to 1 and got it working. I g=
uess when I was testing I would not wait long enough because I was not aware=
the sensor needs 2 minutes of away time and street that the away status of t=
he hub changes 10 minutes after that so I needed to be out for 12 minutes at=
least. I think that was the issue. I am not sure.


#13

Possibly this is a mode issue. It did exist as a problem with v one, but only with hello home actions, not with shortcut groups.

It’s pretty simple once you understand what’s going on, it’s just there’s nothing anywhere that tells you that this is what’s going to happen with routines.

OK if you have a routine that changes the mode, then nothing in that routine will run if the house is already in that mode. That’s not very intuitive. A lot of people assume that it will already run, just the mode won’t change because it’s already in that mode. But that’s not how smartthings handles routines. Instead, the entire routine gets bypassed because The system is already in the mode it’s supposed to end up in.

So if you have a situation where you want the door to unlock on arrival for two different people and you want the mode to change, you just need to have two separate routines.

The first routine changes the mode to home when either spouse arrives home.

The second routine does not do a mode change. All it does is unlock the door when either person arrives home.

That way if first spouse arrives home and the house is empty, routine one runs and changes the mode to home. Routine two runs and unlocks the door for them.

Then, when the second spouse arrives home and the first spouse is already there, routine one does not run because the house is already in Home mode. But routine two still runs and unlocks the door for the second spouse.

( @slagle it’s my belief that some of the situations where people are reporting that the mode is being ignored are situations where they used to have code that ran in the shortcut group and now they’re running that code in a routine and it is being ignored because the mode has already changed. This will explain all the wrong mode issues, but I think it explains some of them. )

Basically, anytime you have a routine with a mode change you need to think about whether you really intend to skip all the other logic in that routine if the house is already in that mode. If not, you need to break out the mode change from the other events and have multiple routines.


(Richard) #14

Thanks for the reply and help JD. Well the issue started with the I’m back routine that will not even unlock my lock when I was manually tapping the I’m back tile. Spoke with Customer service and he was looking Real time on his end he could see this commands being send but three lock would not respond. Then I created a new routine just for unlocking the door and was able to manually run it and unlock the door. Customer services suggested maybe the lock was out of range my hub was also sitting next to my router. I moved the hub 6 feet away from the router and about 9 feet away from the lock. When I was initially seeing my I’m back routine i did not set a Mode change because I don’t want to do anything else based on a mode change, so all the routines I created were without mode change. That did not work. I did some research online and I came to the conclusion that even if I don’t I somehow need to change modes so I had my unlock door routine changeb mode to Home. Then I realised when I was at work that the mode was still Home because I have never set the goodbye routine. So while at work with both my phone and presence sensor in away mode I set the goodbye routine and set the delay time to 1 and waited 3 minutes and the hub mode would not change. Then I manually pressed on goodbye routine and hub mode changed to away. I came home and the door was unlocked but the problem is that many hub detects my sensor from my underground parking because my apartment is on the first floor and the lock does autolock by the time I get to the door taking about frustration. I thought about buying a zwave panic button from Aeotec and use that to unlock the door. I live in a multifamily property and work as a manager so I am constantly in and out and around my unit, I thought I would eliminate the hassle of using the code 100 times a day With this presence sensor but it’s not going to work. I think a one button remote would do it better. This is my progress and my frustration so far. I am open to any advice. Thank you.


(Ken) #15

JD,

This makes sense. Basically I had mine set up like this. My goodbye routine would set the mode to away, would arm the smart alarm, turn off all the lights, and lock the door. My I’m Back routine would set the mode to Home, disarm the smart alarm and would unlock the door. After looking at this, I dont even think I need the mode changes as I dont use the modes for anything at all. I dont even understand the point of modes if we have routines? I can turn off the change mode to on both routines and it will still shut the lights off, and arm the smart alarm etc… So basically setting a mode state change is completely pointless unless im using modes for what?


#16

Modes are basically used to control what things will happen when different conditions are in place, and they let you define those conditions anyway you want. . They can prevent a routine from running, which is sometimes what you want.

For example, at our house we have one mode for “night” which is when motion sensors will cause overhead lights to come on brightly, and another mode for “asleep,” which is when the same motion sensors will cause dim night lights to come on instead. :sunglasses:

Other people might do the same thing just with a time based rule, but at our house our schedules are pretty erratic, and we prefer to use modes so we can control exactly when the rule changes each night.


(Joel) #17

i have my door unlock and lock with my routine however… in the morning it goes from asleep to Home Day and runs the home day routine at Sunrise. but Sunrise is getting pretty early now and our front door is next to our bedroom so I hear the door unlock.

I would like to disconnect my Welcome and it’s day routine (hello home phrase director) from my door locking/unlocking - but doesn’t looks like it’s possible based on this thread?


(Ken) #18

In my routine for my door locks based on my presence sensors, I dont have it change modes at all. Seemed to work for me. But it wouldnt let me delete it either. I had to completely delete the routine and set a new one up and just didnt add anything to the change mode to section


#19

Why don’t you create a specific morning routine that doesn’t unlock doors then create another Home Day routine and use that with “hello home phrase director”. This way your door will not unlock at sunrise.


(Joel) #20

err… i dont know why! thank you great idea :slight_smile:


(Joel) #21

finally got around to looking at this. It won’t work as the Home day will need to include unlock door and will still run at sunrise

It would work nicely if i could simply not enter one for “Every Ones home and it’s day” on routine director, but it’s mandatory. Then just have a welcome home and good day that runs based on presence and only if we’re in away day mode.

EDIT: Took Mpulse’s advice and just removed the unlock door function from my welcome home and good day (which is run by routine director). And created another routine that just unlocks the door when anyone arrives but does not change the mode. I think this should work nicely.