Announcement | SmartThings Edge for Devices and Automations

Any news on this Paul? My Iris iL07/iMagic by GreatStar 1117-S got to a point where it was staying online, but would not report motion. Resetting and re-adding didn’t help. I deleted it and reset/re-added and it added as a device but whenever it detects motion the LED flashes green and then blue which seems to indicated it isn’t fully paired.

@Automated_House is this because you tried switching to ST’s Edge driver?

Correct, using the SmartThings provided Edge driver.

1 Like

7 posts were split to a new topic: [ST Edge] Using Switch Edge driver as a reference

Nothing definitive to report as of yet but changes at least for some identified device health issues are in discussion and development. @carter.swedal has been doing the legwork on that front and may be able to provide some more information after we pin things down. The fixes lined up may not work for all devices and we are looking at both specific device fixes (e.g. configuring the device to do periodic reports of other attributes if the ones configured today are not working according to spec) as well as improving some of the inferences made by the core protocol code used to automatically determine the expected reporting interval and fallback “ping” behavior for devices.

For the devices not working are other attributes (if supported) such as battery or temp reported at all? Sorry if these devices don’t support those, I’m being lazy and not looking up the specs as I don’t have those particular devices in my home or test setups. Not receiving the attribute at all does seem like a configuration problem for those devices.

1 Like

2 posts were split to a new topic: [ST Edge] Some questions regarding Edge as a user

For the iris il07 the temperature and humidity report fine. Motion is the only attribute that doesn’t report.

4 posts were merged into an existing topic: [ST Edge] Some questions regarding Edge as a user

@Paul_Oliver, told me that he was using my channel’s zigbee motion sensor Mc driver, which is a modification of the original, with temperature reporting settings and it worked fine for him.
In case you want to try it


I’m trying to setup ST dev env in my macOS High Sierra & need some help as I can’t really follow the over simplified guide.

I followed instruction from smartthings-cli, Step 1. Download the binary from releases tab of the github page, in the page, I saw the Assets section, expend the section, downloaded smartthings-macos-zip.

Different from Step 2, after download, I expend the file, I got an executable file with the name “smartthings”. (not sure why the github step 2 say install it and rename to smartthings, probably not updated).

I move it to a folder call “st_edge”, go into command prompt, navigate to the “st_edge” directory, Following step 3 on the “smartthings-cli” github page, fire the command “smartthings --help”, response is “command not found”.

So what did I missed?

To execute a binary in the current working directory on a Unix system you’ll need to add ./ (dot slash) before the binary name. So to execute the smartthings command in that directory run ./smartthings

This page summarizes some of the history on why this particular bit is required (it’s security related). Linux FAQ: Why Do We Need a Dot Slash Before a Local Command | MangoLassi


Thanks for the very swift reply Paul, that work. Will be good to have someone update the github readme, so less people get stuck at the 1st 3 steps.

Thanks for the ./ FAQ :slight_smile:

1 Like

Working well for me as well

1 Like

Where did you find that driver for the ZEN30? Does Zooz have an edge channel?

@nayelyz @erickv
What is the status regarding Edge support on wifi hubs? I’ve had a couple people unable to get one of my drivers to work: it can’t seem to create a (virtual) LAN device as a result of an Add device / scan nearby. Is this a known issue?

Our team is aware of some behavior that is preventing some Edge functionality on the Samsung Connect Home and SmartThings WiFi devices from working as intended. We are working on correcting this behavior and hope to have it resolved in a future firmware release for these devices.


OK thanks Nayely!

1 Like

A post was split to a new topic: [ST Edge] Issues with the Device Network ID

Inovelli has posted some beta drivers:


Where we can subscribe to their channel?