Amazon Echo -> SmartThings -> Harmony; Worked for a year, now doesn't work (July 2018)

echo
harmony

(Matt H) #1

Howdy ya’ll:

I’ve had my harmony hubs (three of them) working via voice control on my Amazon Echos through my SmartThings V2 for at least a year, likely more. As of Tuesday this week Alexa responds immediately “hmm, I’m having trouble reaching SmartThings” but still works fine with switches, bulbs, etc.

I can control the harmony “switches” from the SmartThings app, I can see these as “scenes” in the Alexa app.
I’m at a loss… my young son can’t handle the complexity of the harmony remote, but he’s always been able to just say “Alexa, turn on family room TV” or “Alexa, Turn on XBox”… now we have to use the app so the integration is basically useless for us.

I don’t even know where to start trying to debug this.


Harmony(Connect) Not Working (July 2018)
Alexa is having trouble reaching smartthings (Nov 2017)
Alexa is having trouble reaching smartthings (Nov 2017)
Thinking About Switching Teams (Wink to SmartThings)
Alexa, Smartthings and Logitech problems (July 2018)
(Matt H) #3

The Alexa skill only handles one harmony hub, we have three harmony devices


(Matt H) #4

I just remembered live logging… SmartThings gets the poll from Amazon Echo, but reports the harmony devices offline. I hit the button in the smartthings app and it works.

I try using alexa RIGHT after using the app… “8:23:59 PM: error Family Room TV is offline”
thought I’d see if it was failing because of an activity timeout… nope.


#5

There is a second skill to add another hub. It has a red icon.


(Kraeg) #6

Mines doing the same thing - thought mine was because I updated to the new Samsung account a couple of days ago and I’ve not had a chance to diagnose it.

Might have to do some digging this weekend


#7

Definitely report it to support, as this is an official integration.

https://support.smartthings.com/hc/en-us

Meanwhile, for a workaround that can work with all three of your Harmony home hubs, you might consider the free yonomi app. They have worked with Harmony to come up with an official Yonomi/Harmony integration that can handle multiple Harmony hubs, although it just lists all of the activities in one long list. But it will let you set up rules that allow echo to trigger harmony activities from multiple hubs, so it might be worth a look.

https://support.myharmony.com/en-es/harmony-experience-with-yonomi

There’s no direct integration with SmartThings, but quite a few community members have used it just to get the echo/harmony integration.


(John Rubin) #8

I too am having this issue. Not really a fan of looking at work arounds with yet another product in the mix. There are so many moving parts already, adding another one just creates further complexity and another avenue for things to break down.

The weird thing is that everything works just fine when interacting from Google Home, it’s the Alexa integration that’s broken. One option I’m considering is creating virtual switches for all my Harmony activities and using the Smart Lighting SmartApp to trigger the actual Harmony activity from Alexa. This should work in theory (I’ll try when I get home later) but it’s weird that it would come to it.

If I had to speculate, it’s most likely because the Harmony virtual switches show up to Alexa as Scenes and not an actual switch, so there’s probably something broken on that end with either Amazon, Logitech, or SmartThings (or all 3!). Annoying nonetheless.

Hopefully it gets resolved soon. Or at least an official word that the feature was deprecated so I don’t sit here wondering how long til it’s fixed (and subsequently what the next thing to break will be).


(Kevin) #9

(moved from another older forum)

As of 7-14-2018 I am as well having the same issue since Samsung had an update last weekend.

I lost all communication between the ST HUB and Alexa. I also have tried just about everything. In addition, I sent in a “ticket” to Samsung support…

Still have NOT heard back!

As a last resort, I am wondering if maybe (like a PC) if there is a way, to roll the firmware back to the previous version? Currently, Firmware Version 000.022.00013


#10

Bumping this thread. The title is not as descriptive as the 8 month old one. The problem is Alexa stating, “I’m having trouble reaching Smartthings”

Hope there is a resolution soon.


(Kevin) #11

Ok what is the solution for now,do I:

A: wait for a fix from Samsung or Alexa? just humor this as long as some have here…
B: Change out the Samsung Hub or Alexa …And with what?

When you have older people that rely on this and now don’t have it. It makes life a PITA!!


(Kraeg) #12

Mine has randomly started working again - not sure if it’s just a hang over from the migration…


#13

I’m quadriparetic, and voice control of my television was amazing when I first got it through SmartThings/Harmony/echo back in August 2015. But by November 2015 it had broken two or three times because of changes that smartthings made and it just became very frustrating.

Once harmony introduced their own skill (the original “Red” one), I switched to that, and it was much more stable. Then they introduced a newer “blue” skill, which added more features. All good. :sunglasses: The only problem is that it can only work with one harmony hub. If you have two, you can use the blue skill with one and the red skill with the other, but that can be confusing because the control phrases are different. But if you just have one Logitech Harmony home hub and you just want echo control of it, I highly recommend the blue skill.

https://support.myharmony.com/en-us/harmony-experience-with-amazon-alexa

If you have more than two Harmony hubs and you want echo control, the best thing I found is yonomi, which does have official integrations with both harmony and echo. This is a free app. It’s not perfect: there’s no integration with SmartThings, and all of the activities from all of your harmony devices show up in one long list, but it does work and is quite quick to set up.

https://support.myharmony.com/en-es/harmony-experience-with-yonomi

So if you have someone who is physically dependent on voice and they don’t want to wait for smartthings to fix the integration, you could use one of these methods.

In the meantime, definitely report the problem to support, as it is an official integration. I expect that smartthings will fix it sooner or later, but then I expect it will also break again eventually, as they just don’t seem to test this before releasing new features. :disappointed_relieved:

JMO


(Matt H) #14

Can anyone else confirm this is suddenly working again? I swapped to the two alexa skills and I’m having issues with them, but they mostly work… I’d have to delete them to try this again.


(Kevin) #15

As Side note: Thankfully Cotana works! :slight_smile:


(Graham) #16

Having the same issue and it’s not working how annoying. After 30 mins deleting and re-adding its not working at all, it discovers then as scenes.

Interestingly I have a google home mini and this works fine so deffo a SmartThings to Alexa only issue.


(David Williams) #17

I’m not using Harmony through SmartThings but I am also getting “hmm, I’m having trouble reaching SmartThings” when triggering thermostats - but the action still works perfectly. So not limited to Harmony it seems. Very annoying!


(Nick Snyder) #18

I am having the exact same issue. Spoke to support and they just said its a known issue and told me to bypass Smartthings for now. I am using harmony directly through the echo for now which is a shame since my harmony activities used to trigger lighting.


#19

A couple people have said they’ve spoken to support and support has said it’s a known issue. If so, why does http://status.smartthings.com show all green and no issues reported?

Also, where do we go to open a support ticket on this issue? And to someone who has spoken with support, did they acknowledge it as a smartthings issue or did they say it’s a Logitech issue?

Thanks


(Benji) #20

Looks like someone else is having an issue as well:

I haven’t tried mine, yet but if you’re all having issues, then you all need to reach out to ST support and log a ticket so they can correlate it.


#21
  1. Samsung should role back everyones update untill they have problem resolved.
  2. I wounder if we can set up st and ifft up to flood the suport server with new request ticket emails every second to fix st system. I think i will look into this tonight. Be kinda funny if we crashed samsung server. We are not there test monkeys!!! Stupid silo hardware companies.
  3. I wish there was a PLC computer for home automation, i want stability!!!
  4. I will be happy when a better home automation hub comes out, better features, stable, easier to program, hardware config file.
    I wish my hub became glorified papper weight!!
  5. How is smartthings smart? What a dumb name!
  6. Home automation needs a well thought out Standard, so the silo hardware companies stop breaking our systems. Tired of this stuff beeing so fragile. Everynight I come home from work I wounder what part in my eco system will stop working. Fisher Price cheape. What rickity piece of crap.

Very disappointed SAMSUNG! UNACCEPTABLE!! Get your Sh*** togeather. Role back the update TODAY, while you figure out a fix!!! Stop making the problem the communities problem!!!