Harmony Hub UK Integration


(Dean Smith) #1

I’m just looking to see if anyone from the UK has managed to get Harmony integration working since the OAuth issue was resolved?

Or is this a case of Logitech still need to change something their end?


ST app network error message
Logitech Harmony Questions
(Chris) #2

I can’t even see Harmony as an option anymore :frowning:


#3

Not yet, still hanging on v1 where it works. Believe logitech still need to do something


(danny) #4

just tried to integrate smartthings into harmony elite, can auth and choose location but does not import devices into harmony. so looks like we need harmony to update so they can fudge round how smarthtings has essentially setup 2 separate cloud services. once harmony looks at eu servers instead of us servers we should be good to go.


#5

Is there even word that they are currently working to update this or not?


(Giles Houghton) #6

I still don’t get why SmartThings has used this 2 cloud fudge. Everyone else seems to manage using location-aware provisioning. I can’t help but think we will always have a rough ride in Europe as a result of this decision.


(Bob Tume) #7

I tried the workaround that Logitech suggested on their home control forum but had no success. The more people that badger them the better

https://forums.logitech.com/t5/Harmony-Home-Control-Experience/Integration-with-SmartThings-in-the-UK/td-p/1456757


#8

Also have the same issues using my UK hub and Harmony Hub.

@Smartthings, please give us some official info on what is still to to on your site or on any other parties site. Thanks!


(Dean Smith) #9

I’m not too sure if any of you have already seen this… Harmony Connect App Crashing

But it worked for me - Can now control harmony activities in ST (UK user)


#10

Where is that harmony connect app (confused).


#11

And the other way around too? For the harmony to control smartthings devices?


(Dean Smith) #12

NO unfortunately - I have not yet been able to get harmony to control ST stuff. This is something that Logitech need to update on their systems.


#13

Ok thanks, yes I am pestering Logitech on that too


(Paul Gale) #14

I’m in the UK and have just bought a Smartthings v2 kit. I’m a long-term HAer (15+ years) but Smartthings is obviously new to me. I’m trying to add a Logitech Harmony hub but not getting very far as there’s NO Harmony smartapp in the marketplace that I can find (Marketplace-More). I can connect the harmony app to smartthings but after logging in to smartthings and then returning to Harmony, it fails to retrieve any of the ST devices.

I read the thread linked to but it didn’t make any sense.

Should this be working in the UK or not?

Thanks,

Paul.


(Dean Smith) #15

You need to go into the Smartthings IDE - “New Smart App”, From Template “Logitech Harmony (Connect)”

Bit like this:

Then create and “Publish for me”.


(Paul Gale) #16

Ah thanks Dean!

I also just got it working by trying to connect from the Harmony - and then the app appeared in the smartapps list (I presume it’s the same version?). I then had to connect via the smartapp and it took quite a while to find the hub. I can now turn activities on/off. Should there be more features?

Cheers.


(Dean Smith) #17

No I’m afraid that’s all its limited to at the moment.


(Andrew Cole) #18

Has this stopped working now - im in the UK and ive tried adding my devices to the US server although it still fails to retrieve the devices?


#19

So, @deano12 you made no changes to the code from the template?
I tried that and it failed with an {“error”:“invalid_request”,“error_description”:“Missing or invalid argument.”} error when I click to enter my Harmony credentials. I’ve been trying the “create a US hub and copy your devices you want to control to that” workaround from Harmony too and that doesn’t seem to work but maybe that is causing problems somewhere?
All very frustrating given I had it working a few weeks ago (having tried to log in from Harmony) and have subsequently ended up removing it somehow!


(Dean Smith) #20

What I did was:

Tried to integrate ST to Harmony via Harmony first - I authorized this but as normal it failed - but it was authorized.

I then proceeded to go into ST and used the Harmony Connect SmartApp and installed it from the Catalog of apps on the IDE.

From there I went onto the phone app and loaded up the SmartApp, put in my credentials, done the discovery, and bobs your uncle, I got to pick the activities that I wanted as switches and away I went.

I think what may have helped here is that I tried to link Harmony to ST via Harmony first…