Harmony Home Control - SmartThings Control and vice versa


(David Ingram) #1

I have integrated SmartThings and a Harmony Home Control into my home.

I’ve successfully added the SmartThings control to my Harmony Home Control so that my harmony can control all smartthings items. However, I have not been able to cause SmartThings “things” to control Harmony “things”.

Like having a sensor turn on the TV, or having the TV turn off when I leave the house.

There are two SmartApps for Harmony on the SmartThings side. One was automatically installed and allows harmony to control smartthings. The other allows smartthings to control harmony, and that app will not find the harmony.

Does anyone have any experience with this setup? Seems like it will be very slick once it’s working.

Thanks,
Dave


[RELEASE] Initial Setup for Ecobee3 & 4, Smart-SI, EMS, Smart-02 thermostats - My Ecobee Device
(Mike Maxwell) #2

Is your harmony hub set up with a static lease on your router?
I’m not having any issues with the activities app finding my hub.

I do find that on android the hub needs to be re-discovered in smartthings each time I scan for new devices from the harmony side…


(David Ingram) #3

The harmony hub nor the smartthings hub are utilizing a static IP lease. Would this help in discovery?


(David Ingram) #4

FWIW, I just used my Linksys e4200 router to assign a DCHP static IP to both the Harmony Home and the SmartThings hub.

The ST SmartApp (SmartThings Labs) that is called “Trigger Logitech Harmony Activities when certain actions take place in your home.” will not find my hub and therefore will not install.

The ST SmartApp (SmartThings Labs) that is called "Allow you to integrate your Logitech Harmony Hub with SmartThings was automatically installed when I did the installation/setup of the Harmony hub itself. I have no issues using the harmony controls, either in the Harmony app or on the Harmony remote, to control SmartThings devices. I just cannot use SmartThings triggers to perform any Harmony actions.

I hope this makes sense. I did purchase these together once I learned that Harmony and SmartThings worked together. (I am a Revolv refugee, ditched this half baked system once Nest killed it. SmartThings is much better, though it probably will never support HomeKit)


(Mike Maxwell) #5

Static reservations make it easier to connect devices on your internal network.
If the power goes out, or you restart your router all the lan devices that have static leases won’t have trouble finding each other…
I would try to uninstall, then reinstall the harmony activities app, see if that helps it find the hub…


(David Ingram) #6

So I’ve done what you suggested and it seems that the SmartThings app still can’s see any harmony hubs (I have the new Harmony Home Control).

Again, the Harmony can see Smartthings and I have many devices successfully connected (i.e. Turn down the lights when I watch a movie). However Both SmartThings Labs apps do not see any connected harmony hubs when they search.

The SmartThings Labs app, “Trigger Logitech Harmony Activities when certain actions take place in your home” will not find a device when I select “connect new” and therefore will not install, at all.

The “Allow you to integrate your Logitech Harmony Hub with SmartThings” app was automatically installed when I set up SmartThings on my Harmony Home Control. If you click it, you still cannot find the Harmony, but it seems to be working as I can control SmartThings items via Harmony.

It’s not a super huge issue, as SmartThings is a big step up from where I was, however, this is functionality I specifically bought both of these units together to achieve. I do appreciate you help, Mike, and would appreciate any additional assistance from you or any others.


(Beckwith) #7

@David_Ingram

You need Harmony Hub firmware version 3.12.9. Go to your Harmony Setup and select SYNC.


(David Ingram) #8

I’ve updated firmware. I’ve sync’d.

Either Harmony SmartApp cannot see my Harmony Home Control hub. Again, I have the Harmony Home Control, not the stand alone hub.


(Chuckles) #9

That version of firmware is for the older series hubs. The new Home series hubs which provide integration with SmartThings run 4.x firmware.


(Barry) #10

I had a similar problem, and the only way I fixed it was:

  1. Verify you have the right Harmony (Must be the Harmony Home)
  2. Remove the ST support from your Harmony
  3. Remove the Harmony Connect support from your ST
  4. Sync the latest firmware for the Harmony (you say you have)
  5. Sync the latest firmware for your ST Hub (Check under Location Settings on your phone)
  6. Power Cycle both Harmony and ST Hubs
  7. Start over with adding ST support to your Harmony, which should auto-install the Connect on your ST
  8. Then go back and add the Harmony app on your ST - it should now show the Harmony hub that should have been discovered/created in step 7

If this doesn’t work, and you are using an iPhone, let Support know - I ultimately got it to work, but instead of using my iPhone I used my Android tablet the final time. We couldn’t determine if success was related to the Android…

Good luck!


(Ron S) #11

The newer firmware version took me by surprise. It works much better now… Even though it does not detect all my devices and puts some of them in incorrect categories. Group on/off of lights is nice too…

Have been seeing some errors in the live logging for the Harmony hub in ST. Will post and send it to support.


(Barry) #12

Yes, I’ve seen errors in the log as well (index out of range, or some such) - reported to support, but never heard back from them.


(Ron S) #13

Exactly the same error here.


(David Ingram) #14

I’m about to try the suggestion by storageanarchy.

I have the following item:

I’ll follow those steps and see how it goes.


(David Ingram) #15

Welp, the suggestion by storageanarchy didn’t work either. I can still control SmartThings items via my Harmony, but SmartThings triggers cannot perform Harmony actions.

I guess I’ll see if support can help, unless anyone on here has any additional suggestions.

Thanks!


(David Ingram) #16

Bump. Still no luck here. Is anyone else having this issue on their iOS device (I use an iPhone 6 Plus) and could chime in? Anyone at SmartThings have any input?

Again, I’m able to get Harmony to Control SmartThings items, but not SmartThings to Control Harmony items.

The “Trigger Logitech Harmony Activities when certain actions take place in your home” application is installed, and says “Select your Logitech Harmony Hub”.
Selecting the “tap to set” asks me to “Connect New” or “Shop Now”. Obviously I click connect new and it goes to the next screen that says “I’m looking for a Media Controller…(spinnywheel)”

It never finds the Harmony.


(Mike Maxwell) #17

You might check some basic TCP/IP stuff…
–The Harmony and smart things hubs need to be on the same network (meaning share the same network mask) this will be the case when the devices are connected to the same router/access point.
–Go into the harmony app, find the about section, get the IP of the hub, then see if you can ping the hub, first from an ethernet port, then over wifi (many routers have a ping utility you can access from the config utility)
–The harmony hub is showing a green LED right?, if it’s not then the hub is having wifi connection issues for sure.
–I was not able to get my hub working consistently until I configured my router to use a fixed wifi channel, (vs an automatic setting.)
–I also configure static dhcp reservations for all my hubs/servers, doing this prevents them from receiving different ip addresses when the router is rebooted.
–Check the harmony app on your phone, is it able to connect to your hub via wifi?

I’m guessing that your harmony hub’s having some connection issues, and that’s preventing the smartthings hub from finding it.


(David Ingram) #18

I’m wondering if this isn’t working because my smartthings is connected via ethernet and the harmony hub is connected over wifi. I might try connecting smartthings over wifi to see if anything changes.


(Mike Maxwell) #19

the ST hub doesn’t support wifi…, which is a good thing IMHO


(Ron S) #20

Hi David! I

[quote=“David_Ingram, post:18, topic:6716”]
smartthings over wifi
[/quote] - How will you do that? :slight_smile: Not supported.

Logitech hub action related stuff is a known issue - port related. Support can fix it on case by case basis or you can wait on an overall fix as it is still in the lab. We are supposed to wait for a full integration.